Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

А что, в свежерелизнутой УППе 1.3.162.1 никто ещё НДС не пытался закрывать?

А что, в свежерелизнутой УППе 1.3.162.1 никто ещё НДС не пытался закрывать?
Я
   Asmody
 
22.06.21 - 17:29
Дабы поглядеть, что там наваято в плане новых с\ф и УПД, обновили УППху до последнего релиза 1.3.162.1

Полюбовались на новые формы, а потом бухам приспичило закрытие месяца сделать.

Ну и получили такое:
{Обработка.ПроведениеДокументовПоРегистрамНДС.МодульОбъекта(1091)}: Недостаточно фактических параметров
            ДокументОбъект.ПодготовитьТаблицыДокумента(СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоУслугам, Неопределено);

Пошел глядеть глазами, а там в модуле дока РеализацияТоваровУслуг у вышеуказанной процедуры появился еще один параметр.
Вот так она теперь объявлена:

Процедура ПодготовитьТаблицыДокумента(СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоУслугам, ТаблицаПоТаре, ТаблицаПоПрослеживаемымТоварам) Экспорт


В общем, я вас предупредил.
   Kesim
 
1 - 22.06.21 - 17:52
(0) они только первичку в первом релизе сделали,  до закрытий месяцов и отчетности еще не добрались...
   Amra
 
2 - 22.06.21 - 17:55
(0) Узнаю 1С
   yamtileon
 
3 - 25.06.21 - 06:00
Как же с этим бороться?
   rphosts
 
4 - 25.06.21 - 06:07
Какой закрыть НДС, там с документами есть "моменты": Новый СФ и УПД в УПП 1.3
   Вафель
 
5 - 25.06.21 - 07:35
Просто кто писал общий модуль и тот кто должен был документы дорабатывать - разные люди. А второй вообще в отпуск пошел
   NorthWind
 
6 - 25.06.21 - 07:46
(3) поглядеть по коду, скорее всего, Неопределено последним параметром передать.
   NorthWind
 
7 - 25.06.21 - 07:46
но это неточно
   NorthWind
 
8 - 25.06.21 - 07:48
чует мое сердце, релиз 162.2 не просто просится, а прямо кричит благим матом что он должен быть выпущен :)
   d_monah
 
9 - 25.06.21 - 07:54
(8) Ситуация в дальнейшем будет только ухудшаться.
   rphosts
 
10 - 25.06.21 - 07:59
(6) или в параметрах вызова ..... = Неопределено)
   rphosts
 
11 - 25.06.21 - 08:00
(9) нам нужно больше проектов запуска ЕРП!
   d_monah
 
12 - 25.06.21 - 08:20
(11) Ну а тож)))Господа,я пока продаюсь на 200,вставайте в очередь,завтра будет уже по 250)).Эх заживем,не думал я ,что на моей улице перевернется фура с водкой))))
   Smit1C
 
13 - 25.06.21 - 08:32
В новой бухгалтерии тоже везде ТаблицаПоПрослеживаемымТоварам запихали.
   DimVad
 
14 - 25.06.21 - 08:33
(4) Там много весёлых моментов.

Например, документ РТУ. Процедура формы "ТоварыНоменклатураПриИзменении". Смотрим :

    СтрокаТабличнойЧасти = ЭлементыФормы.Товары.ТекущиеДанные;
    СтрокаТабличнойЧасти.ПрослеживаемыйТовар = СтрокаТабличнойЧасти.Номенклатура.КодТНВЭД.ПрослеживаемыйТовар;
    
    Если Не ЗначениеЗаполнено(СтрокаТабличнойЧасти.СтранаПроисхождения) И ЗначениеЗаполнено(СтрокаТабличнойЧасти.Номенклатура.СтранаПроисхождения) Тогда
        СтрокаТабличнойЧасти.СтранаПроисхождения = СтрокаТабличнойЧасти.Номенклатура.СтранаПроисхождения;
    КонецЕСли;

Вопрос - что будет со страной происхождения если пользователь поменяет номенклатуру в строке ?
Про изящество кода "через точку - и ещё раз через точку" я уж и не говорю...
   serg999
 
15 - 26.06.21 - 10:14
(14) Тоже косяк .. Документ.СписаниеТоваров.МодульОбъекта процедура ДвиженияПоРегистрамПрослеживаемыхТоваров

при том что УсловияПрослеживаемости.ВедетсяУчетПрослеживаемыхТоваров = Ложь и Запрос.Текст возвращается пустой .. в результате свойства ПараметрыПроведения.ПрослеживаемыеТовары попросту нет ..

Ошибка:
Ошибка при выполнении обработчика - 'ОбработкаПроведения' по причине:
{Документ.СписаниеТоваров.МодульОбъекта(1339)}: Поле объекта не обнаружено (ПрослеживаемыеТовары)
Процедура ДвиженияПоРегистрамПрослеживаемыхТоваров(УсловияПрослеживаемости, СтруктураШапкиДокумента)
    
    //Fix >>>>

    Если НЕ УсловияПрослеживаемости.ВедетсяУчетПрослеживаемыхТоваров Тогда
        Возврат;
    КонецЕсли;
    //Fix  <<<<

    
    УчетнаяПолитикаРегл = ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитикиРегл(Дата, Организация);
    
    Запрос = Новый Запрос;
    Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
    Запрос.УстановитьПараметр("Ссылка", Ссылка);
    
    НомераТаблиц = Новый Структура;
    ПараметрыПроведения = Новый Структура;
    
    Запрос.Текст = Документы.СписаниеТоваров.ТекстЗапросаПрослеживаемыеТовары(НомераТаблиц, УсловияПрослеживаемости);
    
    Если НЕ ПустаяСтрока(Запрос.Текст) Тогда
        Результат = Запрос.ВыполнитьПакет();
        
        Для Каждого НомерТаблицы Из НомераТаблиц Цикл
            ПараметрыПроведения.Вставить(НомерТаблицы.Ключ, Результат[НомерТаблицы.Значение].Выгрузить());
        КонецЦикла;
    КонецЕсли;
    
    ТаблицаРеквизиты = ПрослеживаемостьБП.СтруктуруВТаблицуЗначений(СтруктураШапкиДокумента);
    
    ПрослеживаемостьБП.СформироватьДвиженияРеализацияТоваров(
        ПараметрыПроведения.ПрослеживаемыеТовары,
        ПараметрыПроведения.ПрослеживаемыеОперации,
        ТаблицаРеквизиты,
        Движения);
    
КонецПроцедуры

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.