Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Новый СФ и УПД в УПП 1.3

Новый СФ и УПД в УПП 1.3
Я
   rphosts
 
22.06.21 - 05:43
Так и не вышли? Ждать обновления 30.06 в 23:59:59 по Мск, т.к. упыпырище давно для 1С "неродное дитя"?
Или мне не по глазам а релиз давное на users?
   ДенисЧ
 
1 - 22.06.21 - 05:46
А зайти на релизес? ))) (у меня для упп нет доступа)
Или пошарить на нимфостарте, наверняка кто-то уже слепил.
ИЛи тебе полноценная прослеживаемость нужна?
   rphosts
 
2 - 22.06.21 - 05:51
(1) у нас иногда будет прослеживаемость(экспорт и по каким-то з/ч возможно и импорт) и городить альтернативный 1С-у огород это дурной тон(там и без меня дури есть, опять-же диадок мою дурь не курит - ну не его-же пилить ещё раз)... слепить-то проще простого, если-бы не отслеживаемость.
   ДенисЧ
 
3 - 22.06.21 - 06:01
(2) Ну, если не хочешь лепить свой огород...
Кстати, тут подгуглил... 1.3.162.1 - говорят, что что-то уже есть
"В состав форм регламентированной отчетности добавлены формы по прослеживаемости"
"Добавлена возможность учета операций с прослеживаемыми товарами по регистрационным номерам партий товаров (РНПТ)"

https://v8.1c.ru/news/vyshla-novaya-versiya-1-3-162-1-tipovoy-konfiguratsii-upravlenie-proizvodstvennym-predpriyatiem-reda.htm
   rphosts
 
4 - 22.06.21 - 06:10
(3) это видел, но у чётом "повышенной" ответственности к качеству кода скорее всего что-то будет переделываться так что подожду.
   rphosts
 
5 - 22.06.21 - 10:30
ап
   Смотрящий от 1С
 
6 - 22.06.21 - 12:15
Я слепил по быстрому для непрослеживаемых товаров. Лежит на Инфостарте. Строка 5а не заполняется. Отложил до выяснения
   rphosts
 
7 - 22.06.21 - 12:39
(6) да это не проблема, вопрос в том когда-же 1С сделает дял прослеживаемых... 30.06 в 23:59:59 по мск как-то так себе вариант
   nv24
 
8 - 22.06.21 - 12:50
вышла 1.3.162.1
   Адинэснег
 
9 - 22.06.21 - 13:49
ага, 19.06.21
   Ivanich
 
10 - 24.06.21 - 10:48
Обновился утром 23.06
Сегодня получили:
Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{Документ.СписаниеТоваров.МодульОбъекта(1333)}: Поле объекта не обнаружено (ПрослеживаемыеТовары)
   ДенисЧ
 
11 - 24.06.21 - 10:50
(10) Обновляемая конфигурация была на поддержке или изменённая?
   ДенисЧ
 
12 - 24.06.21 - 10:50
В документе есть такая ТЧ?
   Ivanich
 
13 - 24.06.21 - 10:56
Конфигурация полностью на поддержке. Сейчас в смотрю в Конфигураторе.
Ругается здесь:
Процедура ДвиженияПоРегистрамПрослеживаемыхТоваров(УсловияПрослеживаемости, СтруктураШапкиДокумента)

внутри процедуры идет обращение к
ПрослеживаемостьБП.СформироватьДвиженияРеализацияТоваров(
        ПараметрыПроведения.ПрослеживаемыеТовары,
        ПараметрыПроведения.ПрослеживаемыеОперации,
        ТаблицаРеквизиты,
        Движения);
Вижу что Структура ПараметрыПроведения пустая!
   Ivanich
 
14 - 24.06.21 - 10:57
(12) В документе СписаниеТоваров добавлена ТЧ "СведенияПрослеживаемости"
   ДенисЧ
 
15 - 24.06.21 - 10:59
(14) Я в курсе, поэтому и спросил. Может, обновление кривое было.
   Ivanich
 
16 - 24.06.21 - 11:00
При обновлении не ругалось никак. У меня прослеживаемых нет. Думаю, может включить для проверки, только не знаю где?
   ДенисЧ
 
17 - 24.06.21 - 11:01
Смотри, где и как заполняется ПараметрыПроведения перед вызовом.
Вряд ли уж настолько явный маг пропустили бы.
   Kesim
 
18 - 24.06.21 - 11:05
НомераТаблиц = Новый Структура;
ПараметрыПроведения = Новый Структура;
    
    Запрос.Текст = Документы.СписаниеТоваров.ТекстЗапросаПрослеживаемыеТовары(НомераТаблиц, УсловияПрослеживаемости);
    
    Если НЕ ПустаяСтрока(Запрос.Текст) Тогда
        Результат = Запрос.ВыполнитьПакет();
        
        Для Каждого НомерТаблицы Из НомераТаблиц Цикл
            ПараметрыПроведения.Вставить(НомерТаблицы.Ключ, Результат[НомерТаблицы.Значение].Выгрузить());
        КонецЦикла;
    КонецЕсли;
    
    ТаблицаРеквизиты = ПрослеживаемостьБП.СтруктуруВТаблицуЗначений(СтруктураШапкиДокумента);
    
    ПрослеживаемостьБП.СформироватьДвиженияРеализацияТоваров(
        ПараметрыПроведения.ПрослеживаемыеТовары,
        ПараметрыПроведения.ПрослеживаемыеОперации,
        ТаблицаРеквизиты,
        Движения);


явный косяк номера таблиц может быть пустой структурой
   Kesim
 
19 - 24.06.21 - 11:07
(18) на третьей строке вариативно возвращается пустой текст и соответственно структуры не менялись(остались пустыми)
   ДенисЧ
 
20 - 24.06.21 - 11:07
Надо смотреть в ТекстЗапросаПрослеживаемыеТовары()
   ДенисЧ
 
21 - 24.06.21 - 11:07
Возможно, если прослеживаемости нет - он пустоту возвращает.
   Kesim
 
22 - 24.06.21 - 11:10
Функция ТекстЗапросаПрослеживаемыеТовары(НомераТаблиц, Реквизиты) Экспорт
    Если НЕ Реквизиты.ВедетсяУчетПрослеживаемыхТоваров Тогда
        Возврат "";
    КонецЕсли;
    
    НомераТаблиц.Вставить("ВТ_Прослеживаемость",    НомераТаблиц.Количество());
    НомераТаблиц.Вставить("ПрослеживаемыеОперации", НомераТаблиц.Количество());
    НомераТаблиц.Вставить("ПрослеживаемыеТовары",   НомераТаблиц.Количество());

 первые три и вторые три строки поменять местамикак вариант, а еще лучше

Если НЕ ПустаяСтрока(Запрос.Текст) Тогда
        Результат = Запрос.ВыполнитьПакет();
        
        Для Каждого НомерТаблицы Из НомераТаблиц Цикл
            ПараметрыПроведения.Вставить(НомерТаблицы.Ключ, Результат[НомерТаблицы.Значение].Выгрузить());
        КонецЦикла;
    
    
    ТаблицаРеквизиты = ПрослеживаемостьБП.СтруктуруВТаблицуЗначений(СтруктураШапкиДокумента);
    
    ПрослеживаемостьБП.СформироватьДвиженияРеализацияТоваров(
        ПараметрыПроведения.ПрослеживаемыеТовары,
        ПараметрыПроведения.ПрослеживаемыеОперации,
        ТаблицаРеквизиты,
        Движения);
КонецЕсли;
   ДенисЧ
 
23 - 24.06.21 - 11:13
Ну вот и ответ. Действительно, косяк
   Ivanich
 
24 - 24.06.21 - 11:17
Процедура ДвиженияПоРегистрам(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоТаре, Отказ, Заголовок);

    ДвиженияПоРегистрамУпр(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоТаре, Отказ, Заголовок);
    ДвиженияПоТоварамОрганизаций(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоТаре, Отказ, Заголовок);
    ДвиженияПоСписаннымТоварам(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоТаре, Отказ, Заголовок);

    
    Если ТаблицаПоТоварам.Количество() + ТаблицаПоТаре.Количество() >0 тогда
        УправлениеЗапасами.ЗарегистрироватьДокументВПоследовательностяхПартионногоУчета(ЭтотОбъект, Дата, СтруктураШапкиДокумента.Организация,ОтражатьВУправленческомУчете,СтруктураШапкиДокумента.ОтражатьВБухгалтерскомУчете,СтруктураШапкиДокумента.ОтражатьВНалоговомУчете,СтруктураШапкиДокумента.СпособВеденияПартионногоУчетаПоОрганизации);
    КонецЕсли;    
        

    // При списании партий также делаются записи в регистры бухгалтерского учета.

    Если СтруктураШапкиДокумента.ОтражатьВБухгалтерскомУчете Тогда
        Если Движения.Хозрасчетный.Модифицированность() Тогда
            Движения.Хозрасчетный.Записать();
        КонецЕсли;
    КонецЕсли;
    
    Если СтруктураШапкиДокумента.ОтражатьВНалоговомУчете Тогда
        Если Движения.Налоговый.Модифицированность() Тогда
            Движения.Налоговый.Записать();
        КонецЕсли;
    КонецЕсли;

    УправлениеЗапасамиПартионныйУчет.ДвижениеПартийТоваров(Ссылка, Движения.СписанныеТовары.Выгрузить());

    ДвиженияПоРегистрамУСНРегл(РежимПроведения, СтруктураШапкиДокумента,Отказ, Заголовок);
    
    // Движения по регистрам прослеживаемых товаров

    УсловияПрослеживаемости = Новый Структура;
    
    УсловияПрослеживаемости.Вставить("ВедетсяУчетПрослеживаемыхТоваров", ПолучитьФункциональнуюОпцию("ВестиУчетПрослеживаемыхТоваров")
        И ПрослеживаемостьБРУ.ВедетсяУчетПрослеживаемыхТоваров(СтруктураШапкиДокумента.Дата));
    
    ДвиженияПоРегистрамПрослеживаемыхТоваров(УсловияПрослеживаемости, СтруктураШапкиДокумента);

КонецПроцедуры// ДвиженияПоРегистрам()

В моем случае можно закомментировать строку 
ДвиженияПоРегистрамПрослеживаемыхТоваров(УсловияПрослеживаемости, СтруктураШапкиДокумента);
Но надо снимать конфу с поддержки
   ДенисЧ
 
25 - 24.06.21 - 11:19
Так на модуль объекта расширение же вроде как в ОФ можно натянуть?
   Ivanich
 
26 - 24.06.21 - 11:24
В конфе стоит режим соместимости Версия 8.2.13 
А там расширения вроде бы не поддерживаются.
Во всяком случае 1С не выпускает для УПП заплатки в виде расширений. Или я ошибаюсь?
   ДенисЧ
 
27 - 24.06.21 - 11:26
Ну, если 2.13, тогда нельзя расширений.
У тебя есть два варианта 
1. включить прослеживаемость и молиться )))
2. включить разрешение редактирования и поправить
   Ivanich
 
28 - 24.06.21 - 11:31
Где прослеживаеость включается?
ПолучитьФункциональнуюОпцию("ВестиУчетПрослеживаемыхТоваров") возвращает ложь
   ДенисЧ
 
29 - 24.06.21 - 11:32
У меня упп нет, но ведь можно посмотреть состав этой ФО...
   Ivanich
 
30 - 24.06.21 - 11:33
Нашел Константа.ВестиУчетПрослеживаемыхТоваров
только в интерфейсе не могу найти. Счас обработкой установлю
 
 
   Kesim
 
31 - 24.06.21 - 11:34
(26) включай редактирование с поддержкой, в след релизе поправят)
   rphosts
 
32 - 24.06.21 - 11:48
(31) или чуть попозже.
   ДенисЧ
 
33 - 24.06.21 - 11:52
(32) Следующим назовём тот, в котором поправят )))
   Ivanich
 
34 - 24.06.21 - 11:53
Константы.ВестиУчетПрослеживаемыхТоваров в истина установил.
Константы.ДатаНачалаУчетаПрослеживаемыхИмпортныхТоваров не трогал '00010101'
документ с галкой только упр.учет провелся и сформировал движения

Регистр накопления "Учет затрат (управленческий учет)"

Регистр накопления "Свободные остатки"

Регистр накопления "Товары на складах"
   Ivanich
 
35 - 24.06.21 - 11:55
Как поведут себя другие документы ХЗ.
Так что буду включать редактирование
   rphosts
 
36 - 24.06.21 - 12:19
(35) ну мы видимо к понедельнику накатим всё вышедшее с 1.3.152.3 и начнём тестить на боевой базе... отступать-то некуда - позади учёт!
   Адинэснег
 
37 - 24.06.21 - 12:21
   Адинэснег
 
38 - 24.06.21 - 12:22
сотку за поддержку, говорили они...
   rphosts
 
39 - 24.06.21 - 12:23
(38) ты не знаешь сколько стоит саппорт ЦКТП...
   rphosts
 
40 - 28.06.21 - 02:50
Вышла 1.3.162.2    от 27.06.21
   rphosts
 
41 - 28.06.21 - 03:52
Прочее
Прочие изменения

Исправлены ошибки.
   assasu
 
42 - 28.06.21 - 06:43
(0) научись конфигуратором пользоваться. все вышло еще 19 числа.
   rphosts
 
43 - 28.06.21 - 06:46
   assasu
 
44 - 28.06.21 - 07:15
(43) так про ошибки речь или про вышло не вышло?
   rphosts
 
45 - 28.06.21 - 07:21
(44) вышла сборка с (41)... вариантов нет как и времени... у нас апдейт уже готов (на нашу вхлам переписанную УПП)... завтра к утру уже будет натянуто на ИБ
   rphosts
 
46 - 29.06.21 - 17:58
Н-да...

1.3.162.3    29.06.21

Прочее
Прочие изменения
Исправлены ошибки.
   rphosts
 
47 - 29.06.21 - 18:12
Долбанный  контур так-же обновил модуль интеграции Диадок, хотя недавно было обязательное обновление....


Список тем форума
 
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.