Вход | Регистрация
 

Установка наименования картинки

Установка наименования картинки
Я
   NIGHTHUNTER
 
03.09.20 - 08:40
В конфигурации, создал добавление картинки, но в наименовании пусто. И я просматривая отладчиком не вижу где мне получить наименование файла картинки, что бы вставить его в наименование справочника.

Как мне получить наименование файла картинки?



//
&НаКлиенте
Процедура ДобавитьКартинку(Команда)
ИмяФайла  = "";
ПутьФайла = "";
//Вызываем Диалоговое окно и помещаем файл Картинки из локальной файловой системы во временное хранилище
Если ПоместитьФайл(ПутьФайла, ИмяФайла, Истина) = Истина Тогда
    //в строковый реквизит ФОТО нашей формы сохраняем ссылку на Картинку во временном хранилище
    Фото = ПутьФайла;
    //для создания нового элемента в Справочнике Файлы и записи Картинки в его реквизит Файл
    //переходим на сервер с помощью вызова серверной процедуры
    УстановитьКартинку();
КонецЕсли;
//условие ЕСЛИ нужно для того, чтобы если пользователь отказался от выбора файла
//мы не вызывали серверную процедуру УстановитьКартинку()    
КонецПроцедуры
//
&НаСервере
Процедура УстановитьКартинку()
    //создаем новый элемент в Справочнике Файлы
    НовыйФайлКартинки      = Справочники.Файлы.СоздатьЭлемент();
    //в реквизит СправочникаФайлы Файл помещаем выбранную ранее Картинку
    НовыйФайлКартинки.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Фото));
    Фото                   = ПоместитьВоВременноеХранилище(НовыйФайлКартинки.Файл.Получить());
    //записываем новый элемент справочника Файлы
    НовыйФайлКартинки.Записать();
    //устанавливаем значение реквизита Картинка Справочника Сотрудники
    Объект.Картинка = НовыйФайлКартинки.Ссылка;
КонецПроцедуры
//
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    //отображение картинки при открытии формы справочника
    Фото                         = ПолучитьНавигационнуюСсылку(Объект.Картинка, "Файл");
    //устанавливаем автомасштаб для картинки
    Элементы.Фото.РазмерКартинки = РазмерКартинки.АвтоРазмер;
КонецПроцедуры
//
   NIGHTHUNTER
 
1 - 03.09.20 - 08:42
В процедуре ПоместитьФайл в ПутьФайла идет вот такая ерунда

e1cib/tempstorage/cedf50ba-9397-41f6-ba36-10ce59eec3de?seanceId=268e3f93-7745-44ae-97dc-795776da2a7c

и все (
   NIGHTHUNTER
 
2 - 03.09.20 - 14:03
Я использовал вот эту процедуру

Если ПоместитьФайл(ПутьФайла, ИмяФайла, Истина) = Истина Тогда


А про неё написано вот что 

Глобальный контекст (Global context)
ПоместитьФайл (PutFile)
Не рекомендуется использовать, начиная с версии 8.3.13.
Рекомендуется использовать:
НачатьПомещениеФайлаНаСервер (BeginPutFileToServer)


Может в той что советуют есть нужное мне имя файла, что бы поместить его в наименование справочника?

Или где взять значение, наименование файла для загрузки ?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.