Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Передача тега 1162 в Штрих

Передача тега 1162 в Штрих
Я
   PQT
 
21.02.20 - 09:55
ФР: ШТРИХ-МИНИ-01Ф, драйвер свежий: DrvFR v4.14.0.772
Код маркировки:
010290000072511921KUp"cEi>'KcVa91002A921/15aEK7piLJkTO93Sto3El09LXtT163TeYQPaXu6QGmJde3/8fEaN+Qg/UkPzF1k/blhp9rRL7Pvr+D1ZchJw==

Подскажите как отправить, требуется ли преобразовывать как описано тут
https://честныйзнак.рф/upload/iblock/09e/09e9978505dad5ba4a8f814420ab20b7.pdf

Или должно работать так:

глФР.TagNumber = 1162;
глФР.MarkingType = 5408;    // в моем случае обувь
глФР.GTIN = "02900000725119";    //(Global Trade Item Number), передается как текст, например "12345"
глФР.SerialNumber = "pe&h=LQa>BDUu";

После попытки отправить так, вышел чек:
https://lk.ofd-magnit.ru/CheckWebApp/fds.zul?fn=9283440300136441&fs=038367221

Если я правильно полагаю, тэг не передался. Я не то передал, не так передал или нужно обновить прошивку ФР?
   PQT
 
1 - 21.02.20 - 10:42
аа, пятой строчку забыл
   PQT
 
2 - 21.02.20 - 10:42
глФР.FNSendItemCodeData();
   PQT
 
3 - 21.02.20 - 10:43
но вопрос актуален
   PQT
 
4 - 21.02.20 - 12:50
ку-ку
   oskarsan
 
5 - 22.02.20 - 14:59
(0) Тоже пробовал так с прошивкой 24.10.2018, но без TagNumber = 1162, ошибка "Неверное значение в поле длины".
Что нашел на форумах, то что многое зависит от прошивки, но в какой что...
Написал в службу поддержки, ждемс.
   oskarsan
 
6 - 22.02.20 - 18:17
(0) у тебя серийник должен быть "KUp"cEi>'KcVa"
и ссылка на чек не работает
   oskarsan
 
7 - 22.02.20 - 18:19
   oskarsan
 
8 - 23.02.20 - 07:53
(5) Обновил до DrvFR v4.14.0.792 все заработало
прошивка 24.10.2018

Объект.FNOperation(); 
Объект.MarkingType = 5408;    // в моем случае обувь 

Объект.GTIN = GTIN;  //передается как текст 14 символов

Объект.SerialNumber = SerialNumber;//передается как текст 13 символов

Объект.FNSendItemCodeData();
   Turku
 
9 - 23.02.20 - 13:14
(8) Спасибо за отзыв! А какое верхнее кассовое ПО у Вас? Явно не Розница 2.3, так?
Значит, обновление прошивки, в принципе, необязательно.
   oskarsan
 
10 - 23.02.20 - 15:19
(9) 1С 77 Торговля 9.0
По новым правилам должна стоять букавка М в чеке
https://www.shtrih-m.ru/press_center/news/stati/obnovi-proshivki-s-1-marta-menyayutsya-rekvizity-v-chekakh/
на прошивке 24.10.2018 ничего не появляется на бумаге, но в ОФД КТ есть и в ЧЗ все уходит бесплатно.
у меня клиенты не хотят обновляться, им СЦ выставил счет на 3900 на год (2 прошивки и лицензия)
   PQT
 
11 - 25.02.20 - 11:07
Спасибо за ответы! думал уже утонет ветка без них, поэтому не появлялся
Прошивку обновил, но не помогло(
При пробитии таким способом:

    глФР.FNOperation();
    глФР.StringForPrinting="Проверка 1С";
    глФР.Quantity = 1;
    глФР.Price= 0.01;
    глФР.Department = 1;
    
    глФР.TagNumber = 1162;
    глФР.MarkingType = 5408;    //(2 - Изделия из меха, 3 - лекарственные препараты, 5 – табачные изделия)

    глФР.GTIN = "02900000725119";
    глФР.SerialNumber = "iXLjqc-rNIBEX";
    глФР.FNSendItemCodeData();


Лог такой:

[25.02.2020 18:00:46.558] [00018368] [DEBUG] TPrinterProtocol -> 06
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter Unlock
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter Send.3
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter Send.4
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR FNOperation: 0
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_StringForPrinting
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_StringForPrinting: Проверка 1С
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Quantity
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Quantity: 1
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Price
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Price: 0,01
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Department
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Department: 1
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Tax1
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Tax1: 4
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Tax2
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_Tax2: 4
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_TagNumber
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_TagNumber: 1162
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_MarkingType
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_MarkingType: 5408
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_GTIN
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_GTIN: 02900000725119
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_SerialNumber
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR Set_SerialNumber: iXLjqc-rNIBEX
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TDrvFR FNSendItemCodeData
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter Send.1
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter Send.2
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter Lock
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter CommandCode=4DFF
[25.02.2020 18:00:46.558] [00018368] [ INFO] TFiscalPrinter ------------------------------------------------------------
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter Команда: FF4Dh, Передать произвольную TLV структуру привязанную к операции
[25.02.2020 18:00:46.558] [00018368] [ INFO] TFiscalPrinter ------------------------------------------------------------
[25.02.2020 18:00:46.558] [00018368] [DEBUG] TFiscalPrinter OpenPort

Ссылка на чек: https://lk.ofd-magnit.ru/CheckWebApp/fds.zul?fn=9283440300136441&fs=2410984635&fd=2433

Если я правильно понимаю в ФР серийник уходит, но в ОФД он не передает?
   oskarsan
 
12 - 25.02.20 - 17:13
(11) Попробуй так:

    глФР.StringForPrinting="Проверка 1С";
    глФР.Quantity = 1;
    глФР.Price= 0.01;
    глФР.Department = 1;
    глФР.FNOperation();

    глФР.MarkingType = 5408;    //(2 - Изделия из меха, 3 - лекарственные препараты, 5 – табачные изделия)

    глФР.GTIN = "02900000725119";
    глФР.SerialNumber = "iXLjqc-rNIBEX";
    глФР.FNSendItemCodeData();

В драйвере v4.14.0.7хх - ФН - КТН должен быть тип маркировки 5408
В эл. чеке должно появиться КТ ххххххххххххххххххххххх
   runuts
 
13 - 25.02.20 - 17:58
вот вытащил из одной отраслевой штриховской конфы:


ЗаписатьПроизвольныйТэгНаПозицию(1162, MarkTagValue);

Процедура  ЗаписатьПроизвольныйТэгНаПозицию(Знач НомерТэга_инт, Знач ЗначениеТэга_hex)
    НомерТэга_hex = ПолучитьБайтыВОбратномПорядке(DecToHex(НомерТэга_инт, 4));
    ДлинаТэга_hex = ПолучитьБайтыВОбратномПорядке(DecToHex(Окр(СтрДлина(ЗначениеТэга_hex)/2), 4));
    ФР.TLVDataHex = НомерТэга_hex + ДлинаТэга_hex + ЗначениеТэга_hex;
    ФР.FNSendTLVOperation();
КонецПроцедуры


Функция ПолучитьБайтыВОбратномПорядке(Знач Стр)
    Рез = "";
    КоличествоБайт = СтрДлина(Стр);
    Для ж = 1 По КоличествоБайт / 2 Цикл 
        Рез = Рез + Сред(Стр, КоличествоБайт - ж * 2 + 1, 2);
        Стр = Лев(Стр, СтрДлина(Стр) - 2); 
    КонецЦикла;    
    Возврат Рез;
КонецФункции


Функция DecToHex(Знач Зн, Знач КратностьДлины = 1) Экспорт
    КратностьДлины = Цел(КратностьДлины);
    Если КратностьДлины < 1 Тогда
        КратностьДлины = 1;
    КонецЕсли;
    Если ТипЗнч(Зн) = Тип("Строка") Тогда
        Попытка
            ч = Число(Зн);
        Исключение
            Возврат Неопределено;
        КонецПопытки;
    ИначеЕсли ТипЗнч(Зн) = Тип("Число") Тогда
        ч = Зн;
    Иначе
        Возврат Неопределено;
    КонецЕсли;
    Рез = "";
    к = КратностьДлины;
    Пока Истина Цикл
        Если к = 0 Тогда
            к = КратностьДлины;
        КонецЕсли;
        к = к - 1;
        д = ч/16;
        ц = Цел(д);
        д = ч - ц*16;
        Рез = ?(д < 10, Формат(д, "ЧН=0"), ?(д = 10, "A", ?(д = 11, "B", ?(д = 12, "C", ?(д = 13, "D", ?(д = 14, "E", "F")))))) + Рез;
        ч = ц;
        Если ч = 0 Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    Пока к > 0 Цикл
        к = к - 1;
        Рез = "0" + Рез;
    КонецЦикла;
    Возврат Рез;
КонецФункции
   isa2net
 
14 - 25.02.20 - 18:03
Не поможет : https://habr.com/ru/post/489614/
   oskarsan
 
15 - 25.02.20 - 19:05
(13) Спасибо, давно искал примеры.
Но это вроде для более новых прошивок после 24.1.2018?
   oskarsan
 
16 - 25.02.20 - 19:11
(14) не поможет, что и от чего?
у меня в 77 на 2018г прошивке с драйверами 782 работает.

Если сканер считывает правильно 010290000072511921iXLjqc-rNIBEX91 и т.д    
        
Объект.FNOperation(); 

GTIN = Сред(СписокТоваров.GTIN,3,14);
SerialNumber = Сред(СписокТоваров.GTIN,19,13);

Объект.MarkingType = 5408;    // в моем случае обувь 

Объект.GTIN = GTIN;  //передается как текст 14 символов

Объект.SerialNumber = SerialNumber//передается как текст 13 символов

Объект.FNSendItemCodeData();

С ЧЗ КТ выходит из оборота, при возврате встает обратно в оборот.
   isa2net
 
17 - 25.02.20 - 21:12
(16) от непередачи тэга, для топикастера писал
   PQT
 
18 - 26.02.20 - 07:18
полагаю что нашел причину, дело в отсутствии лицензии на прошивку, т.к. прошил самостоятельно, поэтому лог показывал что в драйвер данные уходили корректно, но в ОФД и на чеке признаки отсутствовали
   PQT
 
19 - 26.02.20 - 07:30
(13) подскажите что скормить вторым параметром? (MarkTagValue)
   victuan1
 
20 - 26.02.20 - 08:57
(11) На какую прошивку обновил? От 13.02.20?

Пишите мне на почту victuan # майл . ру.
Помогу бесплатно.
   runuts
 
21 - 26.02.20 - 09:05
(19) в соседней ветке
Штрих и тег 1162 (обувь)
   PQT
 
22 - 26.02.20 - 11:53
(20) ПРошивка 19018 от 13.02.2020
Написал).. от ruslan (а) marvanov.ru
(10) Полагаю прошивка от 24.10.2018 решила бы вопрос

(21) хм... чуть помогло, теперь на печатном чеке появилась строка с КТ и серийником, но на электронном чеке ОФД ничего, а вот на честном знаке оказывается давно создавались чеки, но все они пустые (без товаров и без данных)
   PQT
 
23 - 26.02.20 - 14:42
хм.. ну вот не понятно Ура, или не ура)...
1) на чеке печатается код и серийник (но не буква М),
2) из честного знака код выбывает, но в самой их базе появляется лишь пустой документ
3) в ОФД никаких признаков маркированного товара
   Turku
 
24 - 26.02.20 - 19:37
Короче, ребяты...Дело швах.
На прошивке 24.10.2018 с драйвером 792 под Розницей 2.3.3.12 никаких следов маркировки ни на чеке, ни в ОФД, ни в ЧЗ не обнаружено.
ИМХО, Розница может полагаться на распознавание марки на уровне прошивки.
   victuan1
 
25 - 28.02.20 - 14:10
(23) Прошивка обновлена на 13.02.20?
Драйвер ККТ обновлен хотя бы на 14.4.0.792?
В Тесте драйвера в Таблице № 17 произведены следующие настройки: https://yadi.sk/d/rW0XX-il_tV1xQ
   oskarsan
 
26 - 01.03.20 - 22:53
(22) пробовал на прошивке 22.02.2018, тоже теги отправляет в ОФД и ЧЗ
в ЧЗ чеки были пустые, недавно стало все отображаться.
   Turku
 
27 - 02.03.20 - 03:52
(24) Все работает, на самом деле. Ошибка была в том, что вводили руками штрихкод товара в РМК. В этом случае он "затирает" марку. И при формировании фискального документа программа марку не распознает. То бишь сначала считываем марку, а далее в форме сопоставления с номенклатурой считываем реальный штрихкод. Маркировку остатков делали в упрощенном порядке в ЛК ЧЗ.
Так что Розница марку распознает сама, не задействую возможности ККТ.
   DimonZh
 
28 - 02.03.20 - 16:46
Ребята, подскажите: передавать тег 1162 нужно до вызова 

FNOperation() 
или после? (В цикле по товарам)

Делал и FNSendItemCodeData() и FNSendTLVOperation()
до FNOperation() - ошибок нет, на чеке не печатется ничего, в ОФД, если смотреть TLV - тоже нет.

Пробовал сегодня, правда в TLVData кодировал 5408(обувь), а вроде говорят теперь 44 4D

Драйвер 4.14.0.722, теги с ИНН кассира, юрлицом и проч передаются (стоял даже 4.13 драйвер, использовался метод Sale(), переписал под FNOperation() на днях)

Пробовал FNSendItemCodeData() сразу после FNOperation() - ругается ResultCode
   runuts
 
29 - 02.03.20 - 17:10
(28) передавать надо после FNOperation()
722 очень старый драйвер, сейчас уже есть 803
   victuan1
 
30 - 03.03.20 - 04:28
(28) "Пробовал FNSendItemCodeData() сразу после FNOperation() - ругается ResultCode"
Код и описание ошибки - в студию!
 
 Рекламное место пустует
   DimonZh
 
31 - 03.03.20 - 19:47
(30) Сегодня клиент был занят, завтра обновлю драйвер до 792.

Код ошибки не посмотрел, к сожалению, в описании было про неверные параметры.

Использовал
Объект.MarkingType = целое числовое 5408
Объект.GTIN = строка 14 символов
Объект.SerialNumber = строка

Почему зараза не ругается при использовании метода до FNOperation() ?

Тестировать приходится в рабочее время в боевых условиях, постоянно дергают, и ФР не отберешь, чтобы помучать спокойно (
Нарисовал сегодня отдельно обработку, в нее буду сканировать и отправлять в обработчик ФР, чтобы не из документов БД, думаю так быстрее дело пойдет.
   victuan1
 
32 - 03.03.20 - 21:53
(31) Ошибку "Неверные параметры" лечит оюновление драйвера.
Вот так надо 
Объект.MarkingType = 17485;//числовое

остальное верно.
   Turku
 
33 - 04.03.20 - 00:53
(32) Пока все в ЧЗ приходит и с префиксом 1520. Чем это может грозить?
   victuan1
 
34 - 04.03.20 - 04:39
(33) Этот вопрос нужно уточнить в Честном ЗНАКе. И рекомендую начать отправлять в ЧЗ с префиксом 17485 как можно скорее.
   DimonZh
 
35 - 04.03.20 - 16:21
(32) Спасибо за советы.
Обновил драйвер 4.14.0.792
Отправка через 

FNSendTLVOperation() ошибка:

Маркированный товар: 17485 GTIN: 02900001395793 SN: Pb5aaqNtPCs4p

в TLVData пишу строку "8A 04 15 00 44 4D  02 A3 35 8D 94 51 50 62 35 61 61 71 4E 74 50 43 73 34 70"

код ошибки 51
Фискальный регистратор: ошибка при печати чека
Некорректные параметры в команде
Пробовал без пробелов между байтами - аналогично.

FNSendItemCodeData() отправляется, на чеке пишет КТ, но в ОФД (ofd.ru) Серийник короткий

на Печатной форме
Код маркировки 017485 02900001395793 Pb5aaqN

по кнопке TLV так (кусок):

   "1059": [
      {
         "1023": 1,
         "1030": "Стелька каталитическая \"Согревайка\"",
         "1043": 100,
         "1079": 100,
         "1162": "RE0CozWNlFFQYjVhYXFOdFBDczRw",
         "1212": 1,
         "1214": 4
      }
   ],


Не пойму, куда дальше копать...
   Salimbek
 
36 - 04.03.20 - 17:02
(33) 26 декабря 2019 года опубликован приказ MMB-7-20/434@ «О внесении изменений в приложение №2» к приказу Федеральной Налоговой Службы от 21.03.2017 N ММВ-7-20/229@ «Об утверждении дополнительных реквизитов фискальных документов и форматов фискальных документов, обязательных к использованию».

https://www.atol.ru/company/news/chto-izmenilos-v-ffd--kak-podgotovitsya-predprinimatelyu-k-novym-trebovaniyam/
   victuan1
 
37 - 04.03.20 - 17:51
(35) Прошивка ККТ от какой даты?
Тариф на передачу маркировки активирован (не помню как называется этот штриховский побор)?
   andrewalexk
 
38 - 04.03.20 - 18:18
(32) :) кстати а для прошивки от 13.02.20 и драйвера 15.807 меха Объект.MarkingType = 2;?
   DimonZh
 
39 - 04.03.20 - 18:28
(37) Не силен я в ккм, но приходится вникать, т.к. есть клиенты и на дописанных ТиС 7.7 и на собственной конфе.
Позвонил тем, кто обслуживает и шьет кассы - сказали, что прошивка от апреля 2019, передача там должна работать. На чеке у меня появляется строчка с надписью КТ и цифрой какой-то в конце строки.
Еще прислали мне скрин чека из ОФД нормально отработавшего и в ЧЗ списавшего марку - там тоже отображено 7 знаков серийника - типа не беспокойся, значит работает. Сказали, что нужно просто позвонить в ОФД и те бесплатно включать передачу в ЧЗ - я тогда точно увижу.

Получается использование FNSendTLVOperation() на данный момент необязательно, пойдет и FNSendItemCodeData()?
Или все таки мучить дальше, я так понимаю опять от версии драйвера зависит?

Благодарю всех за подсказки!
   DimonZh
 
40 - 04.03.20 - 18:44
(37) Сделал Encode Base64 из TLV данных, присутствующих в ОФД
"1162": "RE0CozWNlFFQYjVhYXFOdFBDczRw" = 44 4d 02 a3 35 8d 94 51 50 62 35 61 61 71 4e 74 50 43 73 34 70
Выходит все передалось ! :)
   victuan1
 
41 - 05.03.20 - 04:37
(39) "Получается использование FNSendTLVOperation() на данный момент необязательно, пойдет и FNSendItemCodeData()?"
Да.

"Или все таки мучить дальше, я так понимаю опять от версии драйвера зависит?" Всё у вас работает на уровне передачи данных в ККТ, ничего не надо мучить, прошивка от апрель.2019 не имеет контроля преданного типа маркировки, поэтому у тебя всё работает без активации платной штриховской подписки. Пусть пока так и остается.

(38) Для меха:

Объект.MarkingType = 21062; //десятичное, что соответствует шестнадцатеричному 52h 46h
//согласно документа "Протокол информационного обмена (ОФД) " https://честныйзнак.рф/upload/iblock/34f/Protokol_informatsionnogo_obmena_OFD.pd
   andrewalexk
 
42 - 05.03.20 - 07:42
(41) :)спс вечно у штрихов запаздывает документация
   andrewalexk
 
43 - 06.03.20 - 11:29
(41) :) странно но свежий драйвер на свежей прошивке не ест этот маркингтупе
   victuan1
 
44 - 06.03.20 - 13:45
(43) Лицензия 2020 для маркировки куплена у Штрихов для данного ККТ?
   andrewalexk
 
45 - 10.03.20 - 10:25
(44) :)
буквально в чтв приходил цтошник все сделал
ну то есть должен был
если и [м] в чеке и сгтин в офд по обуви то и по мехам будет автоматически?
или надо каждую лицензию отдельно делать?
   MWWRuza
 
46 - 10.03.20 - 11:13
(39)Сказали, что нужно просто позвонить в ОФД и те бесплатно включать передачу в ЧЗ - я тогда точно увижу.

А это для какого ОФД так надо?
1-ОФД, без всяких доп. звонков и тарифов все передает в "Честный знак", автоматом... Видит что тег есть значит надо передавать. И даже, когда нет регистрации в "Честном знаке", коды не теряются. После регистрации, они "задним числом" у них появляются...
Нет, у того-же 1-ОФД есть специальный тариф "Маркировка", но это просто какие-то доп. отчеты(я так и не понял - какие?), и еще что-то в этом роде.Просто для передачи маркировки, он не обязателен.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.