Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Штрих и тег 1162 (обувь)

Штрих и тег 1162 (обувь)
Я
   helloman
 
17.02.20 - 13:03
Доброго времени суток!
Подскажите кто внедрял, как правильно все таки (и на какой прошивке) отправлять тег 1162
Через FNSendTLVOperation или FNSendItemCodeData
   vovastar
 
1 - 17.02.20 - 13:10
Атол выпустил 85 прошивку, но ЦТО не дают....
   helloman
 
2 - 17.02.20 - 13:17
(1) Речь о Штрих-М, на Атоле все работает как надо
   SmartContract
 
3 - 17.02.20 - 13:19
(0) Отправлял через FNSendItemCodeData
   andrewalexk
 
4 - 17.02.20 - 13:22
:) я тоже причем на драйвере 792
   helloman
 
5 - 17.02.20 - 13:24
(3) Drv.MarkingType=5 ?
Drv.GTIN=00000046199737
Drv.SerialNumber="ic8kvjr"
Drv.FNSendItemCodeData

MarkingType верно указан?
Подскажите по коду, так?
   helloman
 
6 - 17.02.20 - 13:31
5 - это табак ведь (
   SmartContract
 
7 - 17.02.20 - 13:36
(5) 5408
   helloman
 
8 - 17.02.20 - 13:48
(7) а остальное верно?
   SmartContract
 
9 - 17.02.20 - 13:59
(8) Нет, наверно.
   helloman
 
10 - 17.02.20 - 14:11
(9) )))
   andrewalexk
 
11 - 19.02.20 - 23:00
(8) :) да но .GTIN я только указывал как строку
зы
и в тестовом офд отчет маркировки говорит код номенклатуры правильный
   andrewalexk
 
12 - 21.02.20 - 13:22
:)
единственно что непонятно:
при пробитии по позиции через FNOperation указываешь потом FNSendItemCodeData и ок
а если сложный вид оплаты то пробиваешь не по товару а по отделу
и тогда она не понимает FNSendItemCodeData
   Сияющий в темноте
 
13 - 21.02.20 - 19:49
(12) товар в чеке должен быть всегда
оплата уже после всех товаров и всех маркировок
   andrewalexk
 
14 - 22.02.20 - 08:14
(13) :) неа
   Salimbek
 
15 - 22.02.20 - 09:57
(12) Тут: https://forum.shtrih-m-partners.ru/index.php?topic=33714.0 пишут, что надо пользоваться другой командой.

"Марку с новым преффиксом 444D нельзя передать с помощью FNSendItemCodeData.
Пользуйтесь такой структурой:

Driver.TLVDataHex = "8A041500444d000002C0EED8583F696F2B714341426D382020";
Driver.FNSendTLVOperation();"

Либо по новой версии https://forum.shtrih-m-partners.ru/index.php?topic=33839.15:
"Привязка маркированного товара к позиции
Код команды FF67h. Длина сообщения: 5+N байт.
Пароль оператора: 4 байта
Длина кода маркировки: 1 байт
Данные маркировки N байт.
Данная команда должна вызываться после привязки всех тегов к предмету
расчета.
Ответ: FF67h Длина сообщения: 4 байт.
Код ошибки: 1 байт
Первые 2 байта значения реквизита "код товара”: 2 байта,
Тип Data Matrix:1 байт.
0 – КМ 88,
1-КМ симметричный,
2-КМ Табачный,
3-КМ 44."
   victuan1
 
16 - 25.02.20 - 08:06
(7) Что для обуви, что для табака, что и для прочего маркированного товара теперь передается единый префикс 44 4d
   andrewalexk
 
17 - 25.02.20 - 10:40
(15) :) см (5)+(7)+(11)
зы
осталось понять что скажет честныйзнак
   victuan1
 
18 - 25.02.20 - 14:55
(17) А он уже сказал:
Мы подготовили ответ на Ваше обращение №SR00186451:

Документ ("Протокол информационного обмена (ОФД)" https://честныйзнак.рф/upload/iblock/34f/Protokol_informatsionnogo_obmena_OFD.pdf ) размещен на сайте для всех товарных групп. Но на данный момент система может принимать значение кода типа маркировки и 44 4D, и прежние значения 00 05 (табак), 15 20 (обувь), 00 03 (лекарственные препараты).
Для новых товарных групп (для которых проводится в настоящее время эксперимент) значение кода типа маркировки будет 44 4D.
   andrewalexk
 
19 - 25.02.20 - 14:58
:) это и есть 5408
   victuan1
 
20 - 25.02.20 - 16:04
5408(десятичное) = 1520 (шестнадцатиричное) //для тех кто в танке ;)
   runuts
 
21 - 25.02.20 - 17:59
вот вытащил из одной отраслевой штриховской конфы: передача тега 1162

ЗаписатьПроизвольныйТэгНаПозицию(1162, MarkTagValue);

Процедура  ЗаписатьПроизвольныйТэгНаПозицию(Знач НомерТэга_инт, Знач ЗначениеТэга_hex)
    НомерТэга_hex = ПолучитьБайтыВОбратномПорядке(DecToHex(НомерТэга_инт, 4));
    ДлинаТэга_hex = ПолучитьБайтыВОбратномПорядке(DecToHex(Окр(СтрДлина(ЗначениеТэга_hex)/2), 4));
    ФР.TLVDataHex = НомерТэга_hex + ДлинаТэга_hex + ЗначениеТэга_hex;
    ФР.FNSendTLVOperation();
КонецПроцедуры


Функция ПолучитьБайтыВОбратномПорядке(Знач Стр)
    Рез = "";
    КоличествоБайт = СтрДлина(Стр);
    Для ж = 1 По КоличествоБайт / 2 Цикл 
        Рез = Рез + Сред(Стр, КоличествоБайт - ж * 2 + 1, 2);
        Стр = Лев(Стр, СтрДлина(Стр) - 2); 
    КонецЦикла;    
    Возврат Рез;
КонецФункции


Функция DecToHex(Знач Зн, Знач КратностьДлины = 1) Экспорт
    КратностьДлины = Цел(КратностьДлины);
    Если КратностьДлины < 1 Тогда
        КратностьДлины = 1;
    КонецЕсли;
    Если ТипЗнч(Зн) = Тип("Строка") Тогда
        Попытка
            ч = Число(Зн);
        Исключение
            Возврат Неопределено;
        КонецПопытки;
    ИначеЕсли ТипЗнч(Зн) = Тип("Число") Тогда
        ч = Зн;
    Иначе
        Возврат Неопределено;
    КонецЕсли;
    Рез = "";
    к = КратностьДлины;
    Пока Истина Цикл
        Если к = 0 Тогда
            к = КратностьДлины;
        КонецЕсли;
        к = к - 1;
        д = ч/16;
        ц = Цел(д);
        д = ч - ц*16;
        Рез = ?(д < 10, Формат(д, "ЧН=0"), ?(д = 10, "A", ?(д = 11, "B", ?(д = 12, "C", ?(д = 13, "D", ?(д = 14, "E", "F")))))) + Рез;
        ч = ц;
        Если ч = 0 Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    Пока к > 0 Цикл
        к = к - 1;
        Рез = "0" + Рез;
    КонецЦикла;
    Возврат Рез;
КонецФункции
   victuan1
 
22 - 25.02.20 - 18:27
(21) MarkTagValue это уже готовое значение, переведенное в HEX ;)
Код для этого преобразования тут не привиден))
   runuts
 
23 - 25.02.20 - 18:33
(22) это верно, в конфе его тоже нет, похоже передается из их внешней компоненты, придется выяснять опытным путем
   andrewalexk
 
24 - 25.02.20 - 20:09
(20) :) не ну я конечно не переводил в hex - из ветки про обувь взял
   victuan1
 
25 - 26.02.20 - 04:19
(24) пост был для других ;))
   runuts
 
26 - 26.02.20 - 08:46
а вот и функция подъехала

Функция ПолучитьЗначениеТэга1162(Знач КодМаркировки)
    
    ГТИН = Сред(КодМаркировки,3,14);
    СерийныйНомер = Сред(КодМаркировки,19,13);
    СерийныйНомерХекс = "";
    Для сч = 1 По СтрДлина(СерийныйНомер) Цикл
        СерийныйНомерХекс = СерийныйНомерХекс + DecToHex(КодСимвола(СерийныйНомер,сч),2);
    КонецЦикла;
    
    Возврат "444D" + DecToHex(ГТИН,12) + СерийныйНомерХекс;
    
КонецФункции
   PQT
 
27 - 26.02.20 - 12:24
Пробуя отправить используя (21) + (26), у меня на чеке печатает, в ОФД чек без маркировки, а в честном знаке появляются пустые документы((

ПРошивка 19018 от 13.02.2020, загрузчик 133, драйвер DrvFR v4.14.0.792 (Но без лицензии)

Причем как сказал: Передача тега 1162 в Штрих
"на прошивке 24.10.2018 ничего не появляется на бумаге, но в ОФД КТ есть и в ЧЗ все уходит бесплатно."

Если у кого есть, скиньте плиз мне эту прошивку на ruslan(а)marvanov.ru, Спасибо!
   Salimbek
 
28 - 26.02.20 - 12:57
(27) В телеграм-каналах многие пишут, что у них тоже создаются пустые документы. Но сами марки из оборота при этом успешно выводятся (статус у марки - Выбыл)
   andrewalexk
 
29 - 26.02.20 - 13:35
(27) :) ээ а без лицензии это без файла *.lic?
а зачем?
эмулятор для тестов вставляют
   PQT
 
30 - 26.02.20 - 14:43
(29) да
(28) хм.. это успокаивает

но все же не понятно Ура, или не ура)...
1) на чеке печатается код и серийник (но не буква М),
2) из честного знака код выбывает, но в самой их базе появляется лишь пустой документ
3) в ОФД никаких признаков маркированного товара
 
 Рекламное место пустует
   victuan1
 
31 - 26.02.20 - 16:27
Кто может проверить, на самом деле на прошивке 13.02.20 не работает этот код:

Drv.MarkingType=17485
Drv.GTIN=00000046199737
Drv.SerialNumber="ic8kvjr"
Drv.FNSendItemCodeData()


Нет под рукой новой прошивки чтобы проверить..
   PQT
 
32 - 27.02.20 - 07:38
могу поделиться прошивкой, куда кинуть?
   victuan1
 
33 - 27.02.20 - 09:14
(32) Она же персональная, привязана к заводскому номеру ККМ.
   Salimbek
 
34 - 27.02.20 - 09:52
(31) Вот в (15) сами разработчики пишут:

"Марку с новым преффиксом 444D (комментарий мой: 444D - это десятичное ваше 17485) нельзя передать с помощью FNSendItemCodeData.
Пользуйтесь такой структурой:"

Но вы упорно хотите... что?
   andrewalexk
 
35 - 27.02.20 - 10:09
(34) :) ....и там же пишут "Драйвер будет доработан."
   Salimbek
 
36 - 27.02.20 - 10:22
(35) Угу, смотрел я - в каком направлении они его дорабатывали. Если кратко, то они в прошивке от декабря выпилили поддержку 444D даже из TLV, и потому надо было делать даунгрейд. А выпилили почему? А чтобы вы сами не могли отправлять этот тег, и пользовались их новым методом. А этот новый метод надо обязательно покупать через лицензию "Маркировка базовая" или "Годовая 2019". В "годовая 2020" оно не входит. Вот такая вот петрушка.
   PQT
 
37 - 27.02.20 - 10:30
(33) аа.. так вот почему она по хорошему не хотела вставать у меня, пришлось разбирать аппарат и через microSD ей скармливать, и вот кстати так она ее схавала! Так что если, что могу скинуть инструкцию и прошивку
   PQT
 
38 - 27.02.20 - 10:36
(33) хотя стоп, корректирую (37)
персональная лицензия, а прошивка одна, а вскрывать мне потребовалось из-за того что у меня доработка (устройство модернизации) установлена
   victuan1
 
39 - 28.02.20 - 14:02
(31) Протестировал сегодня этот код на прошивке от 13.02.20.
Отлично он работает, признак маркировки в чек отлично встает и без проблем.

Так что брешет Селихов в (15), что нужно использовать вместо FNSendItemCodeData() метод FNSendTLVOperation().
Хотя и этот метод я тоже протестировал - он дает тот же результат, что и старый добрый FNSendItemCodeData().

Ощущение, что в Штрих-М сами не знают как у них всё работает. Хотя по моим наблюдениям, у них это так не первый раз.
   Salimbek
 
40 - 28.02.20 - 21:32
(39) Лицензия на маркировку куплена? Интересно, просто, на сколько связана передача тега к лицензиям
   MWWRuza
 
41 - 28.02.20 - 23:15
(20)5408(десятичное) = 1520 (шестнадцатиричное)//для тех кто в танке ;)


Виктор, мне стыдно признаться, но наверно я в танке... Или одно из двух :-)

1520 - переводим в хекс, получаем "05 F0". Так не мои "нетленки" делают, а типовая "Розница 2.3"... "Продаю" через нее "белые тапочки", получаю КТ "05 F0 *************", в ККТ и в тестовом ОФД... Значит, изначально, в десятичном формате, она туда 1520 передает... В кексе, получаем "05 F0". Откуда вы берете "15 20" в шестнадцериричном, когда это десятичный формат числа 1520 - ??? И откуда тогда 5408 взялось, его там просто быть не должно?
   DimonZh
 
42 - 02.03.20 - 16:01
Ребята, подскажите: передавать тег 1162 нужно до вызова 

Объект.FNOperation() 
или после? (В цикле по товарам)

Делал и Объект.FNSendItemCodeData() и Объект.FNSendTLVOperation()
до FNOperation() - ошибок нет, на чеке не печатется ничего, в ОФД, если смотреть TLV - тоже нет.

Пробовал FNSendItemCodeData() сразу после FNOperation() - ругается Объект.ResultCode
   DimonZh
 
43 - 02.03.20 - 16:06
(41) 5408 - обувь в десятичном = 1520 в шестнадцатиричном
   Salimbek
 
44 - 02.03.20 - 16:08
(43) С первого марта - нет уже 15 20, только 44 4D
   DimonZh
 
45 - 02.03.20 - 16:09
(44) а по поводу (42) поможете?
   victuan1
 
46 - 03.03.20 - 04:34
(41) 5408 - это отмененный с 01.03.20 тип маркировки для обуви (он же = 15h 20h).
С 1 марта действует единый тип маркировки = 17485 (он же = 44h 4Dh). О чем и сказано в (18).
   victuan1
 
47 - 03.03.20 - 04:35
(42) бОъект.FNSendItemCodeData() или Объект.FNSendTLVOperation() после Объект.FNOperation()
Версия драйвера должна быть не ниже 4.14.0.792.

Если ругается Объект.ResultCode, то прошу сообщить код и описание ошибки.
   Turku
 
48 - 03.03.20 - 05:43
(47) Так что, теперь нужно вместо StampType="1520" в узле GoodCodeData отправлять StampType="444D"? Только несколько дней назад проверял типовую 1520 в РТ - все работало. А драйвер Штриха и сама ККМ как на это посмотрит? Или ей все равно, что слать в ОФД?
   victuan1
 
49 - 03.03.20 - 06:38
(48) Старая прошивка не проверяет StampType на корректность, а новая прошивка автоматически сама преобразует старые StampType в новые значения.
   DmVl76
 
50 - 03.03.20 - 08:37
(49) Я на прошивке от 24.08.2018 на тестовой кассе отправил StampType=17485, тег 1162 встал верно 444D, можно было не перепрошивать кассы получается?
   DmVl76
 
51 - 03.03.20 - 08:38
(50) Извиняюсь, увидел ответ в другой теме
   Сияющий в темноте
 
52 - 03.03.20 - 09:04
все команды ширих с префиксом фн требубт пароль 30,под другими паролями не работает или не всегда работает.
   victuan1
 
53 - 03.03.20 - 09:07
(52) Да, есть такое. Писал в техподдержку Штриха об этом "дефекте". Сказали, менять не будут.
   MWWRuza
 
54 - 03.03.20 - 13:20
+(41) Разобрались... Была ошибка в драйвере под Спарк, реквизит "StampType" в XML из типовых 1С передается уже в хексе... А драйвер, его еще раз вреобразовывал в хекс :-) Вот и получалось "05 F0"... Поправили драйвер, убрали кодирование в хекс, передаем как есть, сейчас правильно работает... Сейчас там умышленно "15 20" передано, что-бы нагляднее было, но если "44 4D" передать, то он и его без перекодирования передаст.
Вот:

https://content.foto.my.mail.ru/mail/m_w_w/_mypagephoto/h-294.jpg

Другое дело, что крайние типовые релизы Розница 2.3.19 и УТ 10.3.59.3, пока по старому передают, для сигарет "05" для обуви "1520"...
Когда поправят, х.з...
При этом Розница, еще и по "новым требованиям" реквизит MarkingCode="RE0CozV4ShkhYmdrZGVZTE1USG9W", в этот же тег, как четвертый реквизит формирует... Драйвер, который у меня, пока его не обрабатывает...
Не понятно, когда переданы три реквизита: "StampType", "GTIN", "SerialNumber" и еще дополнительно "MarkingCode", что должно в ККТ передаваться? Если драйвер умеет обрабатывать "MarkingCode", то он должен его в неизменном виде передавать, а первые три игнорировать?
Правильно понимаю?
   MWWRuza
 
55 - 03.03.20 - 13:22
Тег из XML, формируемого типовой "Розницей":
<GoodCodeData MarkingCode="RE0CozV4ShkhYmdrZGVZTE1USG9W" SerialNumber="!bgkdeYLMTHoV" GTIN="02900000000537" StampType="1520"/>
   MWWRuza
 
56 - 03.03.20 - 13:29
+(54) Когда поправят, х.з...

Если вообще поправят, а то могут и забить... Будут правильно передавать в "MarkingCode", а на три старых, составных реквизита, могут и наплевать, типа АТОЛ и Штрих умеют этот реквизит обрабатывать, и ладно...
   victuan1
 
57 - 03.03.20 - 14:05
(56) Новые прошивки Атола и Штрих-М сами преобразуют любое переданного через StampType значение в 44 4D.
Получается, просто обновив прошивку, можно корректно работать на старых релизах 1С.
   MWWRuza
 
58 - 03.03.20 - 15:40
(57) Это понятно... Я могу в своей внешней обработке обслуживания под Спарк(моя обработка, поэтому знаю где и как это сделать), но только под УТ 10.3, подменить в структуре, передаваемой в функцию формирования XML все, что передается в "StampType" на "44 4D"... Не проблема...
Интересно, как с типовой "Розницей" дальше работать... Там обработка встроенная в конфигурацию. Но, она передает "MarkingCode"... Он должен быть приоритетом над остальными реквизитами, в том числе и "StampType" - ?
   Сияющий в темноте
 
59 - 03.03.20 - 16:56
при желании,можно и вызовы драйвера перехватить и заменить,но это немного сложнее.
я из Атола Штрих делал таким методом.
   DmVl76
 
60 - 28.04.20 - 13:29
Добрый день.
Появилось вот такое нововведение - http://catalog.mista.ru/journal/news/uchet-nalogi-pravo/pri-prodazhe-sredstv-individualnoy-zashchity-v-cheke-dolzhen-byt-ukazan-kod-tovara_1229198/

Для ряда номенклатуры (смотровые перчатки, маски, респираторы) нужно в тег 1162 передавать фиксированный 13-значный код, свой для каждой группы.
StampType 45 0D передается без проблем, а вот сам 6-байтовый код пустой (00 00 00 00 00 00). Как только не пробовал - передавал в GTIN, в MarkingCode - бесполезно.

Никто не сталкивался?
 
 Рекламное место пустует
   victuan1
 
61 - 29.04.20 - 06:00
(60) Из Постановления:
4. Требования к указанию в реквизите "код товара" кассового чека и бланка строгой отчетности кода идентификации, указанного в пункте 3 настоящего постановления, подлежат применению по истечении 3 месяцев со дня вступления в силу правового акта, предусматривающего введение обязательной маркировки товаров средствами идентификации на территории Российской Федерации.
5. При принятии акта Правительства Российской Федерации, определяющего особенности маркировки отдельных товаров средствами идентификации, в отношении кодов идентификации которых форматами фискальных документов, утвержденных Федеральной налоговой службой в соответствии с Федеральным законом "О применении контрольно-кассовой техники при осуществлении расчетов в Российской Федерации", не определены правила их включения в состав реквизита "код товара", Федеральная налоговая служба в 6-месячный срок с даты вступления в силу такого акта Правительства Российской Федерации вносит изменения в указанные форматы фискальных документов в части определения правил включения кода идентификации для таких средств идентификации в состав реквизита "код товара".
   victuan1
 
62 - 29.04.20 - 06:24
(60) Рекомендую использовать родные драйверы ККТ, а не недоделанные драйверы по стандарту 1С из БСП. Тем более, что она развивается с опозданием в отличие от родного драйвера (вспомнить, те же изменения с 01.07.19 где БСП успела в последний момент).

Для Атол 10:
    Объект.setParamStrHex(1162, КТ)

Для Штрих-М:
    Объект.TLVDataHex = "8A040800"+КТ;
    Объект.FNSendTLVOperation();

где КТ - код товара. Например для EAN13 = 2400001323807
КТ = "45 0D 02 2E CB 39 F3 1F"
   victuan1
 
63 - 29.04.20 - 06:26
У меня и для ДТО8 (Атол) есть, но думаю неактуально, хотя и работает.
   victuan1
 
64 - 29.04.20 - 06:32
Для Штрих-М можно еще так (на родном драйвере конечно) - но не проверял работает ли:
    Объект.MarkingType    = 17677;  //это десятичное от 450D (для тех кто в танке ;) ) 

    Объект.GTIN        = "2400001323807";
    Объект.SerialNumber    = "";
    Объект.FNSendItemCodeData();
   victuan1
 
65 - 29.04.20 - 07:44
Пришло разъяснение от фирмы 1С по поводу кодов для СИЗ:
Достаточно завести такую номенклатуру с данными штриходами. В электронном чеке он заносится в тэг "GoodCodeData MarkingCode".
   DmVl76
 
66 - 29.04.20 - 09:00
(62) Родные драйверы хорошо конечно, гибче гораздо, но переписывать не особо хочется, да и времени нет.

(65) Пробовал, MarkingCode вообще не цепляется, передавал в разных кодировках. При установке MarkingType тег 1162 появляется, но заполнен только тип 45 0D, а дальше нули.

Может дело в этом? Стандарт 3.2, как я понял - ОФД 1.1, а у меня 1.05
// Реквизит кода товара (1162) для стандарта 3.2 и выше в ККТ передается в готовом виде.

        Если НЕ ПустаяСтрока(РеквизитКодаТовара) Тогда
            ЗаписьXML.ЗаписатьНачалоЭлемента("GoodCodeData");
            ЗаписьXML.ЗаписатьАтрибут("MarkingCode", XMLСтрока(РеквизитКодаТовара));
            ЗаписьXML.ЗаписатьКонецЭлемента();
        КонецЕсли;
 

На ИТС написано, что драйвера для Штриха находятся в стадии тестирования на предмет правильности заполнения тега 1162.
   victuan1
 
67 - 29.04.20 - 09:09
А ведь 1С трубила, что у них поддерживаются все виды кодов товара, даже 0000h - для неопознанных.
Наврали, получается?
   DmVl76
 
68 - 29.04.20 - 11:41
(67) Может я что-то не так делаю, заполняю MarkingCode например.
Хотя вроде верно все ШК=2400001225408, т.е. Тип+ШК в HEX 45 0d 02 2e cb 38 72 c0, base64 - RQ0CLss4csA

  <GoodCodeData MarkingCode="RQ0CLss4csA"/>

Прошивка кассы от 13.02.2020, может из-за этого?
   rozer76
 
69 - 29.04.20 - 12:41
(65) блин, смотрю в КА 2.4.10.89 

нашел где выводится MarkingCode

Если НЕ ПустаяСтрока(ДанныеКодаТоварнойНоменклатуры.РевизитКодаТовара) Тогда
            ЗаписьXML.ЗаписатьНачалоЭлемента("GoodCodeData");
            ЗаписьXML.ЗаписатьАтрибут("MarkingCode", XMLСтрока(ДанныеКодаТоварнойНоменклатуры.РевизитКодаТовара));
            ЗаписьXML.ЗаписатьКонецЭлемента();
КонецЕсли;

... смотрю маркировка только для обуви и табака - пользуют GS1: МенеджерОборудованияМаркировкаКлиентСервер.РазобратьСтрокуШтрихкодаGS1(КодМаркировки) 

в ОМ.МенеджерОборудованияМаркировкаКлиентСервер есть РазобратьШтриховойКодТовара() и только там заполняется РевизитКодаТовара но видимо 1С сделала задел на будущее и надо обновлять КА на новую версию... эх а с нового года уже так ее покорежили... ндя...
   DmVl76
 
70 - 07.05.20 - 04:58
Разобрался, MarkingCode заработал с третьим релизом интеграционной компоненты.
   PlushCat
 
71 - 07.05.20 - 09:17
(70) Уточните, пожалуйста, что за интеграционная компонента?
   DmVl76
 
72 - 07.05.20 - 09:58
(71) Компонента, которая лежит в макете обработки ShtrihMkkt.epf. В типовых обработках для УПП/УТ 10 компонента еще 2-го стандарта, нужно установить драйвера Штрих 14.15.807, в папке C:\Program Files (x86)\SHTRIH-M\DrvFR 4.15\Bin\1C лежит архив shtrih-m_32.zip, загрузить его в макет, и в процедуре СоздатьОбъектДрайвера() заменить

Драйвер = Новый("AddIn.ИнтеграционнаяКомпонента.SMDrvFR1C22");
на
Драйвер = Новый("AddIn.ИнтеграционнаяКомпонента.SMDrvFR1C3");

Могут быть ошибки, т.к. наименования некоторых атрибутов в xml для стандартов отличаются


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.