Вход | Регистрация
 

V8: Нетленка полноэкранная форма в ТАКСИ Тонкий клиент (нужны идеи решений)

V8: Нетленка полноэкранная форма в ТАКСИ Тонкий клиент (нужны идеи решений)
Я
   andrewrocker
 
27.10.19 - 18:52
Коллеги, привет!

Я хочу программно реализовать свою полноэкранную обработку фронта (РМК), а-ля Интерфейс кассира как в рознице 1.0. То есть пользователь входит в систему и у него автоматически открывается моя РМК.
Вопросы, где прошу подсказок или как-то натолкнуть на мысль, указать на неизвестные мне возможности платформы:

-- Я не понимаю какой объект конфигурации мне для этого нужен - предполагаю, что просто это делать обработкой, не чем другим. Я прав? Пилить какой-то спец формой к какому-то документу не вижу смысла.
-- Какие где нужно галочки расставить или какие типовые свойства формы изменить, чтобы было именно полноэкранно?
-- Какой может быть механизм реализации чтобы юзер, при запуске 1с попадал сразу в РМК, минуя рабочий стол, бэкфронт?
-- Вижу РМК исполненной как экран разделенный на 4 четверти. Можно ли в 1с Такси сделать, или хотя бы две разделить экран пополам на независимые части (а-ля РМК розница 1.0);

Заранее благодарю!
 
 
   palsergeich
 
1 - 27.10.19 - 18:53
(0) Есть режим киоска
   palsergeich
 
2 - 27.10.19 - 18:53
   PR
 
3 - 27.10.19 - 18:55
Лучше пиши на фузне, там пара строк
   palsergeich
 
4 - 27.10.19 - 19:02
(3) Он по моему за тобой по пятам ходит
   vde69
 
5 - 27.10.19 - 19:02
управляемая форма, режим рабочего стола
   andrewrocker
 
6 - 27.10.19 - 19:04
(5) чуть подробнее можно ? я же говорю - я пока не понимаю как это сделать т.е. этот совет совсем шифровка, которая до меня не дошла
   palsergeich
 
7 - 27.10.19 - 19:04
(6) Я тебе ссылку на это дал (2)
   ДенисЧ
 
8 - 27.10.19 - 19:05
(5) А зачем для этого управляемые формы городить?
   palsergeich
 
9 - 27.10.19 - 19:06
(8) А почему нет? Можно работать в браузере одно из преимуществ, тем более для этого уже все есть
   ДенисЧ
 
10 - 27.10.19 - 19:11
(9) А, то есть ещё геморроиться и подключать кассу к броузеру?
Особенно в том случае, когда броузер не нужен?
   palsergeich
 
11 - 27.10.19 - 19:13
(10) Это уже частности.
Можно и тонким.
но суть в том, что разрабатывть на ОФ, когда это можно сделать нормально на УФ - ну не знаю, как минимум терять свои компетенции.
   ДенисЧ
 
12 - 27.10.19 - 19:15
(11) А зачем мучать себя, пиша на УФ, когда можно нормально и быстро сделать на ОФ, не требуя повышения вычислительных ресурсов?
   andrewrocker
 
13 - 27.10.19 - 19:15
(2) с первым вопросом разобрался. Реализовал так: добавил роль "ПользовательРМК", ПередНачаломРаботыСистемы проверяет пользователя РМК и если да, разворачивает в полноэкранном режиме.
    Если ОбщийМодуль.ПроверкаЗапускаРМК() Тогда
        КлиентскоеПриложение.УстановитьРежимОсновногоОкна(РежимОсновногоОкнаКлиентскогоПриложения.ПолноэкранноеРабочееМесто);
    Иначе
        КлиентскоеПриложение.УстановитьРежимОсновногоОкна(РежимОсновногоОкнаКлиентскогоПриложения.Обычный);
    КонецЕсли;


Благодарю! Теперь следующий шаг: как открыть некую рабочую форму для этого пользователя и чтобы она была на весь экран?
   andrewrocker
 
14 - 27.10.19 - 19:16
(12) ну во-первых я не мучаюсь, во вторых касса там стоит stand-alone и нет никаких с этим проблем.
   palsergeich
 
15 - 27.10.19 - 19:18
(12) Я и на УФ это сделаю быстро без повышения вычислительных ресурсов, даже больше скажу я РМК нетленным на УФ больше года занимался.
(13) ИМХО - через роли. Заводишь новую роль кассир РМК, и настраиваешь.
   palsergeich
 
16 - 27.10.19 - 19:19
(15) И да, это были не доработки самого РМК, а прикручивание всяких интеграций и скидок, сам РМК как интерфейный механизм был написан один раз и практически не менялся
   andrewrocker
 
17 - 27.10.19 - 19:39
Стало еще полегче, открыл форму автоматически для пользователя, у которого есть права "ПользовательРМК". Убрал крестик справа сверху, в свойствах самой формы есть галочка "ОтображатьКнопкуЗакрытия". Стало совсем хорошо, решение мне нравится!

Остался последний нерешенный вопрос: как нарисовать форму с разделителем или форму независимыми блоками?

&НаКлиенте
Процедура ПриНачалеРаботыСистемы();
    
    ОбщийМодуль.ОбновлениеДатыЗапрета();
    
    Если ОбщийМодуль.ПроверкаЗапускаРМК() Тогда
        ОткрытьФорму("Обработка.Фронтенд.Форма.Форма")
    КонецЕсли;
    
    
КонецПроцедуры
   andrewrocker
 
18 - 27.10.19 - 19:53
Разобрался! Мне нужны разделите управляемых форм, самому их не добавить?
   palsergeich
 
19 - 27.10.19 - 19:54
(18) Обычные группы элементов
   Сияющий в темноте
 
20 - 28.10.19 - 18:46
поле html документа на форму и делай,что хочешь
   palsergeich
 
21 - 28.10.19 - 18:49
(20) С таким подходом и 1с нафиг не нужен.
Вот тебе бутстрап, вот тебе монга, вот тебе питон
   Сияющий в темноте
 
22 - 28.10.19 - 20:52
(21)я ему тонко и намекаю,что не для 1с задача.
потому как потом будет вопрос как поменять пользователя при открытом документе,а 1с скажет,что нельзя.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.