<

1C: 8.3 Не срабатывает оповещение

Войти
  1. illiona

    04-08-2020 09:58

    Добрый день. Не срабатывает оповещение. Режим запуска обычное приложение
    &НаКлиенте
    Процедура ВыбратьДокументПоступления()
        
        СобытияФормМДЛПКлиентПереопределяемый.ОткрытьФормуВыбораДокументаПоступлениеТоваров(
            ЭтотОбъект, Объект, Новый ОписаниеОповещения("ПослеВыбораДокументаПоступления", ЭтотОбъект));
        
    КонецПроцедуры

    &НаКлиенте
    Процедура ПослеВыбораДокументаПоступления(ВыбранныйДокумент, ДополнительныеПараметры) Экспорт
    КонецПроцедуры

  2. lucbak

    04-08-2020 10:10

    (0) Для обычного приложения есть небольшой ньюанс при использовании "оповещения" а именно необходимо процедуру оповещения расположить еще и в модуле объекта.

  3. illiona

    04-08-2020 10:13

    (1) попробую, просто повторить в модуле процедуру ПослеВыбораДокументаПоступления?

  4. lucbak

    04-08-2020 10:24

    (2) да, в модуле объекта

  5. lucbak

    04-08-2020 10:26

    (3) причем процедуру можно просто пустую вставить (без кода внутри)

  6. illiona

    04-08-2020 14:14

    (4) Все равно не получилось(

  7. lucbak

    04-08-2020 15:32

    (5) Покажи как написал код в модуле объекта и в модуле формы?

  8. ZDenis

    04-08-2020 15:39

    Может я что-то не понимаю, но если "Режим запуска обычное приложение" - то форма то какая открывается?

  9. lucbak

    04-08-2020 16:05

    (7) В обычном приложении никто не мешает открывать управляемые формы.

  10. ZDenis

    04-08-2020 16:09

    (8) Как это?

  11. ДенисЧ

    04-08-2020 16:26

    (9) Как обычную. Если она в конфигурации, а не внешняя

  12. ZDenis

    04-08-2020 16:29

    (10) что-то никогда так не пробовал делать. И что откроется прямо эта форма с ее процедурами или как если бы у объекта не было назначенных форм?

  13. ДенисЧ

    04-08-2020 16:44

    (11) Откроется нормальная управляемая форма.
    Ща пример покажу

  14. ДенисЧ

    04-08-2020 16:48

    http://pics.wfido.ru/img/frm_vtbvi.png

    Это управляемая форма в обычном приложении.

  15. ZDenis

    04-08-2020 16:57

    (13) Ха, точно. Попробовал сейчас в ЗУП 2.5 управляемые формы позапускать. Вот же. Никогда бы не подумал

  16. polosov

    04-08-2020 17:07

    (0) Не пробовал внимательно читать СП по ОткрытьФорму?

  17. polosov

    04-08-2020 17:08

    (0) Оповещай сам, короче.

  18. illiona

    05-08-2020 06:00

    (6)
    Это в документе на форме
    &НаКлиенте
    Процедура ВыбратьДокументПоступления()
        СобытияФормМДЛПКлиентПереопределяемый.ОткрытьФормуВыбораДокументаПоступлениеТоваров(
            ЭтотОбъект, Объект, Новый ОписаниеОповещения("ПослеВыбораДокументаПоступления", ЭтотОбъект));
    КонецПроцедуры

    &НаКлиенте
    Процедура ПослеВыбораДокументаПоступления(ВыбранныйДокумент, ДополнительныеПараметры) Экспорт
        Если ЗначениеЗаполнено(ВыбранныйДокумент) Тогда
            Если ИнтеграцияМДЛПВызовСервера.ЕстьРасхожденияМеждуУведомлениемИОснованием(Объект.Ссылка, ВыбранныйДокумент) Тогда
                ДополнительныеПараметрыВопроса = Новый Структура;
                ДополнительныеПараметрыВопроса.Вставить("ДокументПоступления", ВыбранныйДокумент);
                Обработчик = Новый ОписаниеОповещения("ОбработатьОтветОРасхождениях", ЭтотОбъект, ДополнительныеПараметрыВопроса);
                ТекстВопроса = НСтр("ru='В уведомлении есть товары которых нет в выбранном поступлении. Продолжить выбор?'");
                ПоказатьВопрос(Обработчик, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
            Иначе
                ОбработатьВыборДокументаПоступления(ВыбранныйДокумент);
            КонецЕсли;
        КонецЕсли;
    КонецПроцедуры

    В модуле этого же документа
    &НаКлиенте
    Процедура ПослеВыбораДокументаПоступления(ВыбранныйДокумент, ДополнительныеПараметры)
    КонецПроцедуры

  19. ДенисЧ

    05-08-2020 06:22

    Может СобытияФормМДЛПКлиентПереопределяемый.ОткрытьФормуВыбораДокументаПоступлениеТоваров кривая?

    ЧТо там в ней? ИЛи она закрыта?

  20. illiona

    05-08-2020 06:30

    Процедура ОткрытьФормуВыбораДокументаПоступлениеТоваров(Форма, Объект, ОповещениеПриЗавершении) Экспорт
        ОткрытьФорму("Документ.ПоступлениеТМЦ.ФормаВыбора",,Форма,,,,ОповещениеПриЗавершении);
    КонецПроцедуры

  21. ДенисЧ

    05-08-2020 06:32

    (19) Вроде нормально. Может ФормаВыбора кривая? Не оповещает о выборе?