Имя: Пароль:
1C
1С v8
Не хватает памяти ☑
0 Deganus
 
16.02.18
✎
23:54
У нас небольшая фирма, используем УТ 10.3 (8.3 конфигурация) и бухгалтерия 8.3
В торговле работает 15 человек. в бухгалтерии только 1 бухгалтер.
1С программист у нас на аутсорсинге у местной компании.
Возникла проблема, которую пока что они не могут решать, может вы поможете?
Проблема в том, что при проведении документов у бухгалтера время от времени лазит ошибка такая:
https://c.radikal.ru/c38/1802/09/8d71b96115f0.jpg

Если нажать на "Подробнее", то выдает вот такое уже:
------------
{Обработка.ПодборНоменклатуры.Форма.ОсновнаяФорма.Форма(265)}: Ошибка при вызове метода контекста (Выполнить)
    РезультатЗапроса = Запрос.Выполнить();
по причине:
Ошибка выполнения запроса
по причине:
Недостаточно памяти для получения результата запроса к базе данных
-------------

Сервер у нас на MSSQL, на сервере 32ГБ ОЗУ.
Комп бухгалтера тоже не слабый, с 4ГБ ОЗУ.

Есть какие то предпочтение в чем проблема ?
44 xXeNoNx
 
17.02.18
✎
14:53
(39) кратковременный прирост скорости дает чистка серверного кеша, по умолчанию в program files, тока лишнего ничего не поудаляй
45 xXeNoNx
 
17.02.18
✎
14:54
(43) ох уж эти оценочные суждения
46 Темный рыцарь
 
17.02.18
✎
14:57
(45) Чем не устраивают суждения? Видно же по скриншотам что сервер очень слабый, наверное покупался много лет назад без рассчета на будущее, когда база была еще маленькая, а фирма бедная. На тот момент он может и был в самый раз. А сейчас это уже не сервер, а фигня тормозящая.
47 xXeNoNx
 
17.02.18
✎
15:01
(46) тем, что они могут не совпадать с мнением других, в этой теме.
"Фигня тормозящая" - рановато об этом говорить не имея замеров производительности или не?
48 Темный рыцарь
 
17.02.18
✎
15:11
(47) Черным по белому написано что на сервере 32ГБ ОЗУ. Тут и тесты не нужны чтобы все понять.
49 xXeNoNx
 
17.02.18
✎
15:18
(48) ой все...
https://youtu.be/NCxX70rUz4A
50 Cool_Profi
 
17.02.18
✎
18:06
(43) Кющаете слищком много.
У меня 15 человек на 10 ГБ работают без проблем.
А в соседнем сервере на такой же базе - 28.
51 Темный рыцарь
 
17.02.18
✎
19:37
(50) Слишком много кушает тот кто платит зарплату ковыряющим в носу работникам за то что они сидят и ждут когда компьютер им выдаст результат. Это выбрасывание денег на ветер.
52 Cool_Profi
 
17.02.18
✎
19:40
(51) Вы не поверите. У меня они не сидят и не ковыряются в носу.
53 Темный рыцарь
 
17.02.18
✎
19:42
(52) Конечно. Через вебкамеры за ними подглядываешь?
54 Cool_Profi
 
17.02.18
✎
19:43
(53) Зачем мне веб-камеры, если мы сидим в одном зале? И любой крик "а что это так тормозит" я слышу и отрабатываю, изменяя код для устранения тормозов?
55 sdf
 
17.02.18
✎
20:06
"Все жалуются на память и никто не жалуется на свой ум" (С)
56 Темный рыцарь
 
17.02.18
✎
20:21
(54) Что-то я сомневаюсь что ты отличишь работающего человека от сидящего за компьютером.
57 Cool_Profi
 
17.02.18
✎
20:34
(56) Мне твои сомнения, как маску до альфы центавра.
58 Fram
 
18.02.18
✎
00:20
(52) железо стоит дешевле, чем время оператора. И тем более программиста. Поэтому в начале логичнее новым железом потушить пожар
59 tndr
 
18.02.18
✎
00:42
Что ж это за база такая, которая при формировании типовых отчотов, валится с нехваткой памяти)))
60 ansh15
 
18.02.18
✎
10:59
(59) Большая, может быть, документов много... Автор же о размере баз ничего не пишет.
61 Темный рыцарь
 
18.02.18
✎
11:15
(58) Не все это понимают. Некоторые особо отсталые админы думают что раз пользователи молчат, значит все работает нормально.
62 ansh15
 
18.02.18
✎
11:41
(3) >>1С сервер у нас 64 битный кластер
Я не то чтобы сомневаюсь в этом утверждении, просто поиск поиск по фразе "Недостаточно памяти для получения результата запроса к базе данных" приводит к аналогичным темам, в которых выясняется, что сервер приложений 32-х разрядный, например Недостаточно памяти для получения результата запроса к базе данных или http://www.sql.ru/forum/1179874/oshibka-v-1s-nedostatochno-pamyati-dlya-polucheniya-rezultata-zaprosa-k-baze-dannyh-postgressql
Ну, или база может быть битая(как пишут во второй ссылке).
Выполните для  этой базы ТиИ, посмотрите все ли нормально.
Либо и то и другое.
63 Cyberhawk
 
18.02.18
✎
12:27
Да срабатывает защита сервера приложений на расходование памяти
64 Cyberhawk
 
18.02.18
✎
12:31
ТС давно бы уже в ТЖ посмотреть мог
65 Cyberhawk
 
18.02.18
✎
12:36
Ааа, так это на клиенте запрос выполняется, ну тогда ясно. 64-битный клиент используй либо ограничивай размер выборки.
66 Fram
 
19.02.18
✎
00:27
(65) ТС пишет что в бухгалтерии 8.3. я, конечно, не телепат, но так обычно БП 3 называют. ТС админ, поэтому простительно )
так вот, если предположить БП 3, то, все таки, ошибка на серверной стороне.
67 h-sp
 
19.02.18
✎
06:11
всё-таки чем покупать огромные сервера, нужно запрос для начала посмотреть. Вообще непонятны показания ТС, почему подбор номенклатуры вызывается при проведении документов.
68 Deganus
 
19.02.18
✎
10:17
(40) Сервер один, и скрин оттуда.

(42) да уже крайний ))) сервер переустановил (винда и перенос БД из postgres > MSSQL) и уже я у них 1С программист :)))))))

(43) не наговаривайте. У меня на другом месте работы был 32ГБ на сервере и держал 50 клиентов, все компы были с 2ГБ ОЗУ. И никаких проблем и тормозов.

(44) А где в programs files находится кэш ? Я знаю только в AppData у клиента.

(62) Мы купили специально 64 битный 1С
------
> 1C:Enterprise 8.3 (x86-64) Servers
А вот тестирование не проводилась. когда то давно под PostgreSQL пробовали, но после работы какого то времени , аварийно завершился процесс. Скорее всего переполнение буфера пошел. база под MSSQL весит около 15ГБ.

(65) У клиента, да, 32 битная стоит, хотя ОС 64 битная.
Я поставил то, что 1С программист мне дал. я особо не шарю в этом.

(66) да, так и есть. тот день на MSSQL посатвил ограничение на использование памяти, но сервер еще не перезагружал. Сегодня бухгалтера спросил насчет этой проблемы, она сказала, что пока не было ошибки.
69 Cyberhawk
 
19.02.18
✎
12:12
(68) "Сервер один, и скрин оттуда" // Я вроде не спрашивал, сколько у тебя каких-то там серверов и откуда скрин. Ты просто не осилил сказанное мною.
70 Deganus
 
19.02.18
✎
12:45
(69)
Я скорее всего не правильно понял.
это имеется ввиду?
http://images.vfl.ru/ii/1519033383/d26aedf9/20647409.jpg
71 Cyberhawk
 
19.02.18
✎
20:44
(70) Нет, "рабочий сервер" - это понятие кластера 1С
https://its.1c.ru/db/v8311doc#bookmark:cs:TI000000157
72 Deganus
 
22.02.18
✎
12:31
(71)

Ну надеюсь вы пр это:
http://images.vfl.ru/ii/1519291689/f58a9c70/20687192.jpg

оно ?
73 SunFox
 
22.02.18
✎
12:48
Судя по этой картинке http://images.vfl.ru/ii/1518854390/5ec3fb57/20619034.jpg
сервер в данный момент работает нормально, и ему памяти хватает.

Посмотрите, что происходит со свободной памятью при воспроизведении ошибки. Если память остается свободной, то вам ограничения не решат данный вопрос, а просто будут подстраховкой того, что когда вся память будет использована - сервер не впадет в кому, читая данные интенсивно с диска.
74 4St
 
22.02.18
✎
14:48
(0) Ошибка то в какой базе возникает, в УТ 10.3?
Она, разумеется, типовая и на поддержке?
Интересно глянуть на текст выполняемого запроса.
Кстати, цены поставщика в УТ регистрируются?
75 Cyberhawk
 
22.02.18
✎
23:08
(72) Нет. Похоже ты не внял приведенной мною ссылке и контексту (моему предшествующему сообщению).
76 Deganus
 
23.02.18
✎
08:43
(73) на сервере никогда не наблюдается загрузки ОЗУ более 70%
И мне очень мало верится, что реально не хватает памяти.

(74) вот точно не помню.. где препроводят документы и закрывают квартал/месяц? УТ у нас конфигурация относительно новая, но переделанная, не обновляется.
А как текст вам показать, при которого возникает такая ошибка?
цены - тоже не знаю, спрошу если надо.

(75)да, не смотрел, так как требуется подписка, чтоб смотреть что там.
77 Cyberhawk
 
23.02.18
✎
08:49
"требуется подписка, чтоб смотреть что там" // Демо-доступ на 7 дней туда никто не отменял
78 Deganus
 
23.02.18
✎
09:17
(77) копи-паст или скиншот делать оттуда думаю еще быстее будет, чем тут рассказать какой я "плохой" ))
79 4St
 
23.02.18
✎
09:49
(76) Судя по соседней ветке
Формирование прайсов
я предполагаю, что проблема не в Бухгалтерии, а в УТ.
Раз программист на аутсорсе решить не может, вам стоит найти того, кто сможет. Не бесплатно, разумеется.
В этой ветке, по знакомым или еще как ищите, но дальнейшие гадания по фотографиям, на мой взляд, бессмысленны.
80 Cyberhawk
 
23.02.18
✎
09:52
(78) Зачем давать тебе рыбу, Я уже начуил тебя рыбачить
81 Deganus
 
23.02.18
✎
09:56
(79) прайс - это совсем другая история. другая контора и другая конфигурация. не путать и не делать пустые выводы.
82 Deganus
 
06.03.18
✎
18:26
Ошибка выскакивает именно в бухгалтерии.

Сначала выскакивает такое:
http://images.vfl.ru/ii/1520349878/3f3a848d/20849114.jpg

При нажатии подробнее, уже сам запрос:
http://images.vfl.ru/ii/1520349974/e1f8e51e/20849138.jpg
83 H A D G E H O G s
 
06.03.18
✎
18:49
(82) Необходимо запустить профайлер и посмотреть текста запроса в sql и сколько строк он возвращает в 1с.
84 xXeNoNx
 
06.03.18
✎
20:38
(82) регламенты делаются на базе средствами скуля?
85 xXeNoNx
 
06.03.18
✎
20:39
+(84) итоги рассчитаны в 1с?
86 VladZ
 
07.03.18
✎
04:50
(82) Я бы делал так: нашел текст запроса, выполнил его в консоле запросов.
87 VladZ
 
07.03.18
✎
04:51
+86 А дальше - анализировать этот запрос. Что-то с ним не так.
88 xXeNoNx
 
07.03.18
✎
08:19
(86) тож админ..., какая консоль, какой запрос...
89 xXeNoNx
 
07.03.18
✎
08:24
ТС хочет решить проблему на вяленького. Ты уж активизируйся, а то уйду в другие ветки.
90 Deganus
 
07.03.18
✎
08:57
(83) Что за профайлер ? я обычный админ, смогу?

(84) да, делается
сейчас запустил ТиИ, надо выложить отчет?

бух говорит, что это ошибка бывает при перепроведении ранних документов. если нет товара, то она в номенклатуре поиском ищет такой же товар, чтоб сопоставить и закрыть. Так вот при поиске и выдает эту ошибку, но опять таки не всегда.
91 StanLee
 
07.03.18
✎
09:48
64битную платформу ставьте, тоже страдал в некоторых отчетах нехваткой памяти, после установки 64битного клиента все нормально без ошибок
92 Cyberhawk
 
07.03.18
✎
09:54
(91) Ошибка на строке "Запрос.Выполнить()", клиент тут не задействован. Не хватает памяти серверу приложений, чтобы принять результат запроса от сервера БД
93 VladZ
 
07.03.18
✎
09:55
(90) Запустить сможешь. Разобраться не сможешь.
94 dezss
 
07.03.18
✎
09:56
(90) надо курить этот запрос. Его текст хотя бы выложи.
95 VladZ
 
07.03.18
✎
09:58
(90) Текст запроса дай. А так - разговор ни о чем.
96 Deganus
 
07.03.18
✎
10:29
(94) (95)

Как это делать?
запрос как копировать? Если не сложно - по этапно скажите или дайте ссылку где это написано. я не программист 1С
97 ИТ директор
 
07.03.18
✎
11:14
98 Deganus
 
07.03.18
✎
11:18
(97) спасибо за ссылку. я думал это все в 1С делается, а оказывается под SQL.
мануал выглядит внушительным. Мне это от начала до конца надо выполнить? может какой то часть только мне надо делать?
99 Cyberhawk
 
07.03.18
✎
11:24
13 страниц, где большинство - картинки, это внушительно? )
100 Deganus
 
07.03.18
✎
11:35
(99) конечно ))) я не понимаю суть всего этого мероприятия. Собираюсь делать все по инструкции. По этому спрашиваю - все ли надо делать или какой то часть?
101 Cyberhawk
 
07.03.18
✎
11:38
Если ты не понимаешь инструкцию, то как она тебе поможет?
102 dezss
 
07.03.18
✎
11:51
(96) Идешь в тот модуль, который указан в ошибке, в ту строку, и ищешь выше текст запроса. А дальше копи-паст сюда всего текста.
103 Deganus
 
07.03.18
✎
13:38
(102) это в SQL Profiler или в 1С?
А как называется модуль который мне нужен?
104 dezss
 
07.03.18
✎
14:41
(103) это в конфигураторе 1с.
вот твой путь в дереве
Обработка.ПодборНоменклатуры.Форма.ОсновнаяФорма.Форма
когда откроешь форму, там внизу будет 2 вкладки Форма и Модуль.
Переходишь в модуль, становишься на строку 265 и ищешь выше текст запроса, он будет в Запрос.Текст =
105 Deganus
 
07.03.18
✎
15:00
(104)
Спасибо большое, но не могли бы подсказать пожалуйста, как добраться туда?
вот открыл конфигуратор:
http://images.vfl.ru/ii/1520423996/db7879cb/20859336.jpg

Что, куда зайти дальше? :)))
106 dezss
 
07.03.18
✎
15:18
(105) Конфигурация - открыть конфигурацию...
слева появится дерево, в нем идешь по этому пути:
Обработки.ПодборНоменклатуры.Формы.Форма, даблклик, переходишь в модуль и ищешь строку
107 Deganus
 
07.03.18
✎
15:21
О, нашел путь. но там не нашел нумерация строк. вот общий вид:
http://images.vfl.ru/ii/1520425200/f5e050f6/20859608.jpg
108 hhhh
 
07.03.18
✎
15:25
(107) ну ctrl-g нажми
109 Deganus
 
07.03.18
✎
15:27
Спасибо :) вот сегмент кода, который выдает по этой строке:
https://pastebin.com/0qaEYfU0
110 dezss
 
07.03.18
✎
15:30
(109) стань на функцию ПолучитьЗапросДляПодбора, прямо на вот это длинное слово и нажми F12
111 Deganus
 
07.03.18
✎
15:38
(110)
Вот: https://pastebin.com/bsZhTzpC
кстати, всегда этот запрос очень долго выполняется. номенклатур у нас около 30-50 тыс. (секунд 5-10 выполняется)
112 ДемонМаксвелла
 
07.03.18
✎
15:47
вызывайте специалиста. Тут за вас код бесплатно оптимизировать никто не будет.

Вы судя по всему, даже отладчик запускать не умеете, куда там до правки и оптимизации запроса.
113 Флориан
 
07.03.18
✎
15:56
>>то "0"ТС если так происходит - "бух говорит, что это ошибка бывает при перепроведении ранних документов. если нет товара, то она в номенклатуре поиском ищет такой же товар, чтоб сопоставить и закрыть. Так вот при поиске и выдает эту ошибку, но опять таки не всегда." - то пусть номенклатуру добавляет добавлением строки через "Ins", а остатки смотрит в отчете по остаткам, тут проблему точно не решить
114 Deganus
 
07.03.18
✎
15:59
(112) вы сейчас о чем? о тормозах при подборе или при ошибке нехватки памяти?
я сразу сказал, что я сисадмин и не разбираюсь в 1С. Просто надо разобраться в чем дело.
1С_программист у нас приходящий. Он сказал, что проблемы не видит в коде, ибо проблема вне 1С и с этим надо мне разобраться.
Если вы можете решить данную проблему, то скажите сколько стоить будет это , я поговорю с руководством.

(113) - не решить , в каком плане? проблема нерешима или я просто не смогу?
115 Флориан
 
07.03.18
✎
16:01
(114) Не решима тут подсказками, еще можно поставить 64-го клиента 1С
116 ДемонМаксвелла
 
07.03.18
✎
16:10
(114) проблема в коде уже в том, что запрос возвращает большую таблицу, и выполняется на клиенте. Это уже косяк. Даже два косяка.
117 ДемонМаксвелла
 
07.03.18
✎
16:12
(114) я могу это решить, но не напрашиваюсь, мне своей работы хватает.
119 Deganus
 
07.03.18
✎
16:14
(117) цену можете назвать ?
Он действительно долго работает и замечаю, что у клиента ОЗУ до 80% грузит. (стоит 4 ГБ озу)
120 Флориан
 
07.03.18
✎
16:14
121 Cyberhawk
 
07.03.18
✎
16:15
(116) "запрос ... выполняется на клиенте" // Неа )
122 Cyberhawk
 
07.03.18
✎
16:17
Хотя формы обычные, тогда непонятно что за "бухия 8.3" в сабже
123 ДемонМаксвелла
 
07.03.18
✎
16:17
(119) если еще будет актуально в понедельник, то можно будет обсудить.
(121) почему неа?
124 ДемонМаксвелла
 
07.03.18
✎
16:18
УТ 10.3 же там
125 Cyberhawk
 
07.03.18
✎
16:18
(123) Да он картинку тут выкладывал где форма УФ была вроде с ошибкой выполнени запроса, щас хостинг его картинок протух
126 Cyberhawk
 
07.03.18
✎
16:19
А про 64-битный ему еще в (65) говорилось )
127 ДемонМаксвелла
 
07.03.18
✎
16:20
(125) ясно
128 Deganus
 
07.03.18
✎
17:35
(120)
я же написал у нас какая платформа: 8.3.10.2639
на сайт 1С доступа нет у меня, если можно, на обменник скиньте пожалуйста.

(122) У нас бухгалтерия 2.0 , как я понял.
Если обновим до 3.1, то эти проблемы решаться ?

(123) да терпит конечно, деваться некуда пока что )))
129 Cyberhawk
 
07.03.18
✎
17:44
(128) Сколько платят за решение вопроса?
130 Cyberhawk
 
07.03.18
✎
17:45
"У нас бухгалтерия 2.0 , как я понял.
Если обновим до 3.1" // То 8.3, то 2.0, то 3.1. Соберись с мыслями уже.
131 Deganus
 
09.03.18
✎
09:25
Какие то странности происходят. У меня был открыт конфигуратор на сервере 7 числа. сегодня (9-е) захожу, и смотрю такую ошибку:
https://images.vfl.ru/ii/1520576079/bfd91494/20878919.jpg

(130)  Вот версия бухгалтерии:
http://images.vfl.ru/ii/1520576733/720c7bab/20878982.jpg


А 8.3 - это торговля. Я просто думал проблема в торговли, а тут оказывается в бухгалтерии.
132 Cyberhawk
 
09.03.18
✎
18:15
Ну тогда 64-битный клиент поможет
134 ildary
 
12.03.18
✎
12:22
(133) тут подобное (выкладывание нелицензии) запрещено, не нарывайтесь на бан.
135 DrZombi
 
гуру
12.03.18
✎
12:40
(0) Предлагаю сменить программиста.
136 DrZombi
 
гуру
12.03.18
✎
12:41
(131) Магия... :)
137 DrZombi
 
гуру
12.03.18
✎
12:42
(132) У 64 битного приложения тоже есть ограничения, они обычно связаны с ресурсами самого сервера и так же с клиентской частью 1С... там оно 32х битное (обычно) :)
138 Cyberhawk
 
12.03.18
✎
13:08
(137) Так автор какой-то вялый, так и не осуществил проверку, кому же памяти-то не хватает - толстому клиенту или-таки серверу приложений
139 Deganus
 
12.03.18
✎
21:28
(138) Почему вялый то?
Я сказал, что у меня нет доступа 1С, чтоб скачать 64 битную платформу. Ну и естественно, не уверен, что если добавлю 4ГБ ОЗУ еще, то проблема точно решится. ОЗУ тоже подорожал, я уговорю директору, купим, поставлю, а если опять тоже самое будет? может все же проблема в коде или в MSSQL?
140 H A D G E H O G s
 
12.03.18
✎
21:30
Я могу посмотреть бесплатно, без регистрации и смс. Но не долго.
141 H A D G E H O G s
 
12.03.18
✎
21:30
Если будет доступ, открытая база, конфигуратор, sql профайлер.
142 H A D G E H O G s
 
12.03.18
✎
21:31
Пишите на Liveups@yandex.ru
143 Deganus
 
12.03.18
✎
22:14
(142) написал, спасибо.