Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не отрабатывает код

Не отрабатывает код
Я
   MIV 91
 
11.01.22 - 15:41
Добрый день, подскажите почему код в тестовой базе работает на ура, переношу его на рабочую, а он не отрабатывает в принципе?

&Перед("ПередЗаписью")
Процедура РасшАвтоподстановки_ПередЗаписью(Отказ)
    Если ВидДокумента = Справочники.ВидыИсходящихДокументов.НайтиПоНаименованию("Исходящее письмо") Тогда
        Если НЕ ЗначениеЗаполнено(Подписал) Тогда
            Отказ = Истина;
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Заполните поле ""Подписал""";
            Сообщение.Сообщить();
        КонецЕсли;
        Если БДопСогласующие.Количество() < 1 Тогда
            Отказ = Истина;
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Укажите хотя бы одного дополнительного согласующего!";
            Сообщение.Сообщить();    
        КонецЕсли;
    КонецЕсли;
        
КонецПроцедуры
   dubolom
 
1 - 11.01.22 - 15:42
У расширения безопасный режим в рабочей отключен?
   MIV 91
 
2 - 11.01.22 - 15:44
(1) Ага
   MIV 91
 
3 - 11.01.22 - 15:45
(1) На тестовой, которая в файловом варианте все на ура, рабочая точно такая же, но только клиент-серверная. Почему код игнорится, не пойму
   dubolom
 
4 - 11.01.22 - 15:46
(3) Может, просто отладка на сервере не настроена?
   MIV 91
 
5 - 11.01.22 - 15:48
(4) Допустим, но она мне и не нужна, я знаю что код исправен, мне не зачем его отлаживать
   dubolom
 
6 - 11.01.22 - 15:49
(5) Справочники.ВидыИсходящихДокументов.НайтиПоНаименованию("Исходящее письмо") - неплохо бы посмотреть, чему это равно в отладчике.
   dubolom
 
7 - 11.01.22 - 15:52
Вообще с поиском по наименованию всегда всё ненадёжно.
   MIV 91
 
8 - 11.01.22 - 15:54
Ссылку возвращяет, я смотрел по консольке
   dubolom
 
9 - 11.01.22 - 15:55
(8) В любом случае отладчиком ошибка, скорее всего, поймается.
   acht
 
10 - 11.01.22 - 15:55
Это в модуле чего код?
   MIV 91
 
11 - 11.01.22 - 16:00
(9) ее нет в том то и дело
   MIV 91
 
12 - 11.01.22 - 16:00
(10) справочник исходящие докумены
   Мультук
 
13 - 11.01.22 - 16:00
(0) Сократите код до

&Перед("ПередЗаписью")
Процедура РасшАвтоподстановки_ПередЗаписью(Отказ)
     Отказ = Истина;
КонецПроцедуры

Работает ?
   acht
 
14 - 11.01.22 - 16:02
(12) Модуль объекта или формы?
   MIV 91
 
15 - 11.01.22 - 16:03
(14) Объекта
   dubolom
 
16 - 11.01.22 - 16:03
(11) Не отрабатывает же.
Значит, есть.
   MIV 91
 
17 - 11.01.22 - 16:04
Вроде разобрался, сменил на запрос

Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ВидыИсходящихДокументов.Ссылка КАК Ссылка
        |ИЗ
        |    Справочник.ВидыИсходящихДокументов КАК ВидыИсходящихДокументов
        |ГДЕ
        |    ВидыИсходящихДокументов.Наименование = &Наименование";
    
    Запрос.УстановитьПараметр("Наименование", "Исходящее письмо");
    
    Выборка = Запрос.Выполнить().Выбрать();    
    Выборка.Следующий();    
    
    Если ВидДокумента =  Выборка.Ссылка Тогда
   MIV 91
 
18 - 11.01.22 - 16:04
(16) Согласен, но!!!! в тестовой нет проблем, сам не пойму
   MIV 91
 
19 - 11.01.22 - 16:05
(16) Может меня обманули, и на каникулах что то в базе поменяли
   dubolom
 
20 - 11.01.22 - 16:05
(17) Два одноименных элемента "Исходящее письмо"?
   acht
 
21 - 11.01.22 - 16:07
(19) У НайтиПоНаименованию есть еще и второй параметр
   MIV 91
 
22 - 11.01.22 - 16:09
(21) Знаю, но раньше не было таких проблем никогда
   acht
 
23 - 11.01.22 - 16:11
(22) Теперь есть. Этого достаточно.
   dubolom
 
24 - 11.01.22 - 16:12
(22) Всё когда-нибудь бывает в первый раз:)
К наименованию лучше по возможности вообще не привязываться, а, если уж привязываешься, исключить все двусмысленности.


Список тем форума
 
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.