Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Передать реквизит с одной формы на другую

Передать реквизит с одной формы на другую
Я
   Buka2505
 
05.01.22 - 18:10
В справочнике Книги создала команду ВыдачаКниг и поместила на форму элемента

написала в команду код:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

    ПараметрыФормы = Новый Структура("МассивКниг", ПараметрКоманды);
    ОткрытьФорму("Документ.ВыдачаКниг.ФормаОбъекта", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно);
    
КонецПроцедуры


В форму документа ВыдачаКниг, которая откроется с помощью команды написала:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    Если ЗначениеЗаполнено(ЭтаФорма.Параметры.МассивКниг)
     Тогда
    Строка = Объект.Книги.Добавить();
    Строка.Книга = Объект.Книга;
    
КонецЕсли;

КонецПроцедуры

Помогите разобраться где ошибка

Нужно, чтобы из формы Книги при нажатии на команду передавался реквизит Книга в форму документа
   Buka2505
 
1 - 05.01.22 - 18:12
или может есть идеи как передать реквизит из одной формы в другую?
   МимохожийОднако
 
2 - 05.01.22 - 19:11
(1) "Строка = Объект.Книги.Добавить();
    Строка.Книга = Объект.Книга;"
здесь
   Buka2505
 
3 - 05.01.22 - 19:13
Подскажите, что не так? (2)
   hhhh
 
4 - 05.01.22 - 19:21
(3) добавьте команду прямо на форму. На закладку Команды. Не надо создавать отдельно Команду, отдельно форму.
   Смотрящий
 
5 - 05.01.22 - 19:22
(0) "Создала", "переместила" ..
В карточке Антон
WTF
   МимохожийОднако
 
6 - 05.01.22 - 19:26
(3) Приведи текст ошибки.
   Buka2505
 
7 - 05.01.22 - 19:26
(4) Это ничего не изменит
   Buka2505
 
8 - 05.01.22 - 19:27
(6) Ошибку не выдает, но и реквизит не переносится
   hhhh
 
9 - 05.01.22 - 19:45
(8) вот это что за хрень?

Строка.Книга = Объект.Книга; 

что за Объект.Книга? Не было его.
   hhhh
 
10 - 05.01.22 - 19:54
(8) где вообще заполняешь реквизит Объект.Книга?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.