Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Новогодний релиз УПП (173.1) - не проводятся РТиУ

Новогодний релиз УПП (173.1) - не проводятся РТиУ
Я
   NorthWind
 
05.01.22 - 09:52
Добрый день!
Кто-то уже наталкивался?
Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{ОбщийМодуль.БухгалтерскийУчетРасчетовСКонтрагентами.Модуль(808)}: Поле объекта не обнаружено (ЭтоПоступлениеАренды)
   Dmitry1c
 
1 - 05.01.22 - 10:24
дак тут же явно ошибка в коде.

бери конфигуратор да чини
   Dmitry1c
 
2 - 05.01.22 - 10:31
Добрый день. При проведении реализации ошибка   

 {ОбщийМодуль.БухгалтерскийУчетРасчетовСКонтрагентами.Модуль(810)}: Поле объекта не обнаружено (ЭтоПоступлениеАренды)
    Если СтруктураШапкиДокумента.ЭтоПоступлениеАренды Тогда    

До выяснения  исправил так

    /Если СтруктураШапкиДокумента.Свойство("ЭтоПоступлениеАренды") И СтруктураШапкиДокумента.ЭтоПоступлениеАренды Тогда
   NorthWind
 
3 - 05.01.22 - 10:31
да, подправил почти так
   NorthWind
 
4 - 05.01.22 - 10:33
видимо, на Селезневской уже треснули шампанского за процветание 1С, когда выкладывали релиз :)
   Dmitry1c
 
5 - 05.01.22 - 10:48
(4) у них там, цитирую тг-канал ЕРП:

>>когда выйдет релиз?

- наши эльфы уже упаковывают его в праздничную обертку ))
   ДенисЧ
 
6 - 05.01.22 - 11:01
А что, ты ставишь релиз без теста сразу фигак-фигак и в продакшен?
   Dmitry1c
 
7 - 05.01.22 - 11:04
(6) ну это же УПП. там все более менее стабильно, бекап сделал и поехали))
   ДенисЧ
 
8 - 05.01.22 - 11:06
(7) Да они там все уже поехали. Тестировщиков всех на ерп пустили...
   NorthWind
 
9 - 05.01.22 - 11:08
(6) ну в общем да, и всегда так делали. Тестить некому, людей на это нет. Имеющиеся по две-три обязанности совмещают.
   NorthWind
 
10 - 05.01.22 - 11:09
(7) именно. Если бы ситуация была более сложная - восстановился бы из бэкапа.
   ДенисЧ
 
11 - 05.01.22 - 11:18
(9) ну возми ванессу, потрать месяц...
   Dmitry1c
 
12 - 05.01.22 - 11:18
(11) протрахайся месяц, ты хотел сказать.
   ДенисЧ
 
13 - 05.01.22 - 11:19
(12) Ну, я политкорректно...
   Dmitry1c
 
14 - 05.01.22 - 11:20
(13) меня до сих пор передергивает при упоминании ванессы. не рекомендую))

лучше что-то свое написать, свои автотесты при помощи внешней обработки. меньше стресса и быстрее
   ДенисЧ
 
15 - 05.01.22 - 11:23
(14) Да я в курсе, это был сарказм. Я даже 1с-тестировщик пробовал...
Пришлось, таки да, писать своё...
   NorthWind
 
16 - 05.01.22 - 11:49
(15) мне кажется, это все критично если у вас 24*7 и от ста человек сидит. Хотя бы от пятидесяти. А когда работает 10-15 человек и с восьми до пяти - ну не такая уж дикая проблема косяк вроде того что в (0). Вышли, поправили, зашли и работают дальше. А вещи действительно неприятные вроде кривых расчетов при проведении доков, которые вылезут концом месяца - такая обработка все равно не словит. Это нужно цифры ручками и головой анализировать.
   ДенисЧ
 
17 - 05.01.22 - 11:52
(16) Кривая обработка не поймает..
   Mikhail Volkov
 
18 - 09.01.22 - 18:44
Еще ОбщийМодуль.УправлениеЗапасамиПартионныйУчет.Модуль(14235 и еще в одном месте): Поле объекта не обнаружено (ЭтоПоступлениеАренды). Исправление (2) помогло.
А вот: ОбщийМодуль.УправлениеЗапасамиРасширеннаяАналитика.Модуль(589): Ошибка при вызове метода контекста (СкопироватьКолонки): Неверное имя колонки - как исправить? В 1.3.172.1 не было такой ошибки.
   ILM
 
19 - 09.01.22 - 19:36
Значит завтра буду заниматься любовью с УППешечкой. Кидайтеу кого что ещё повылезало?
   Mikhail Volkov
 
20 - 10.01.22 - 08:31
+ (18) Функция ПолучитьСтруктуруДанныхВСоответствииСШаблоном() жалуется на добавленный реквизит СпособОтраженияРасходов в табличную часть Товары документа Поступление товаров и услуг. А в шаблон видимо забыли?
   Масянька
 
21 - 10.01.22 - 08:34
(8) (9) Броневик на Селезневскую и Ленина.
   ДенисЧ
 
22 - 10.01.22 - 08:37
(21) Не броневик, а отделение спецназа. С правом.
Этого достаточно
   Kongo2019
 
23 - 10.01.22 - 08:55
(0) А почему не читаете ИТС?

Ошибка 00-00425196
Описание:
Ошибка при проведении РТУ и "Получения услуг по переработке"

Способ исправления:
В методе "ПодготовкаСтруктурыПараметровДляЗачетаАванса" общего модуля "БухгалтерскийУчетРасчетовСКонтрагентами" перед блоком строк...
        Если СтруктураШапкиДокумента.ЭтоПоступлениеАренды Тогда
            Возврат Ложь;
        КонецЕсли;

вставить строку...

    Если СтруктураШапкиДокумента.Свойство("ЭтоПоступлениеАренды") Тогда

, а после этого блока строку...

    КонецЕсли;
   1Снеговик
 
24 - 10.01.22 - 08:55
Вот вы обсудили, поправили, а в 1с об этом и не знают, чтобы поправить :(
   Kongo2019
 
25 - 10.01.22 - 08:59
(24) Знают они там все. Я им второго писал.
Они мне ответили, Зарегистрирована: 04.01.2022, Ошибка 00-00425196.
в (23) как исправить, все это есть на ИТС.
   Масянька
 
26 - 10.01.22 - 09:02
(25) - А чем у вас программист занимается?
- ИТС читает - какая-то ошибка лезет...
Дилемма: читать ИТС или исправлять ошибку?
   NorthWind
 
27 - 10.01.22 - 09:05
не сегодня-завтра 173.2 небось выложат с исправлениями
   Kongo2019
 
28 - 10.01.22 - 09:07
(26) Нет никакой дилеммы, идешь на ИТС.
Смотришь раздел с ошибками.
Их там на пять минут почитать.
   Arh01
 
29 - 10.01.22 - 09:12
Подожду пока с обновлением.
   Azverin
 
30 - 10.01.22 - 09:26
(29) а меня с утра бухи про стат. форму 1-ДАП теребят. Ставлю 170.1 -> 172.1.
 
 
   NorthWind
 
31 - 10.01.22 - 09:38
Ну шо делать... иногда бывают и косяки. Как в том анекдоте про пожарного: зашибись работа, но как пожар - так хоть увольняйся.
   Kongo2019
 
32 - 10.01.22 - 09:39
(30) Так вот кто ИТС положил.

Ошибка на нашем сервере
Данный сервис временно недоступен. Мы делаем все возможное, чтобы исправить эту проблему. Попробуйте повторить действие позже.
   NorthWind
 
33 - 10.01.22 - 09:40
(25) что интересно, страница с релизами конфигураций не показывается. Обвалили в первый рабочий день, что ли?
   NorthWind
 
34 - 10.01.22 - 09:41
чет жалуются что авансовые платежи по транспортному налогу неверно считаются
   ДенисЧ
 
35 - 10.01.22 - 09:42
(34) Да, в БП тоже жалуются... (((((
   Масянька
 
36 - 10.01.22 - 09:44
(34) ИТС читайте (это сарказм).
   NorthWind
 
37 - 10.01.22 - 09:46
(36) -> (33)
   Масянька
 
38 - 10.01.22 - 09:47
(37) Да, понял я. Но есть (28).
Опять (пардон) дилемма...
   Azverin
 
39 - 10.01.22 - 11:05
(32) Отвисло. Я смог зайти.
   Mikhail Volkov
 
40 - 10.01.22 - 11:18
(27) Надеюсь, что в нем ошибки (18) исправят...
   Emvika
 
41 - 10.01.22 - 13:05
Из непоняток релиза:

Не прошли автоматом обработки обновления в периферийной базе. Ругалось на регистратор в регистре сведений ПараметрыАмортизацииОСБухгалтерскийУчет.
Помогли танцы с бубнами...
В центральной базе обновление прошло при этом без ошибок.
   1Снеговик
 
42 - 10.01.22 - 13:26
В текущем релизе 300 ошибок, несколько десятков приняты к исправлению.
При чем много решений типа "Вставьте или измените вот эти строки".
Ну могли бы в следующий релиз быстро перенести и выпустить, если уже понятно где что менять.
   Масянька
 
43 - 10.01.22 - 13:39
(42) Пока они будут "переносить" (исправлять 150) - накосячат на 350...
Это и удручает...
   Базис
 
44 - 10.01.22 - 13:40
Поддержка стала дороже в этом году?
   Масянька
 
45 - 10.01.22 - 13:41
(44) А Доси нету...
   NorthWind
 
46 - 10.01.22 - 13:43
(42) ну собственно, первый рабский день после длинных выхов. Выпустят, надо полагать, в ближайшие дни.
   Mikhail Volkov
 
47 - 10.01.22 - 17:01
Если колонку СпособОтраженияРасходов отдельно добавлять:
        Если Найти(КолонкиТабличнойЧасти, НРег("СпособОтраженияРасходов")) = 0 Тогда
            Результат = ТабличнаяЧасть.СкопироватьКолонки(КолонкиТабличнойЧасти);
        Иначе    //+МВ 10.01.2022 1.3.173.1

            Результат = ТабличнаяЧасть.СкопироватьКолонки(СтрЗаменить(КолонкиТабличнойЧасти, "," + НРег("СпособОтраженияРасходов"), ""));
            Результат.Колонки.Добавить("СпособОтраженияРасходов");
        КонецЕсли; 

то вроде работает, проводится Поступление товаров и услуг, ошибок (18) нет.
   Topol-M
 
48 - 10.01.22 - 22:01
Ну вот, вроде пофиксили, зарелизили.
   NorthWind
 
49 - 10.01.22 - 22:32
(48) Благая весть :)
   Mikhail Volkov
 
50 - 11.01.22 - 10:39
(48) Не все, остались ошибки указанные в (18): {ОбщийМодуль.УправлениеЗапасамиПартионныйУчет.Модуль(13645)}: Поле объекта не обнаружено (ЭтоПоступлениеАренды). Ну, допустим у меня одного партионный учет где-то включен (Ведомость по партиям товаров давно не работает). Но почему ТабличнаяЧасть.СкопироватьКолонки(КолонкиТабличнойЧасти) "Неверное имя колонки", если содержит "СпособОтраженияРасходов"?
   pasha_d
 
51 - 11.01.22 - 11:17
(50) при каком событии возникает ошибка?
   Mikhail Volkov
 
52 - 11.01.22 - 12:24
(51) При проведении документа Поступление товаров и услуг.
   Emvika
 
53 - 11.01.22 - 14:37
(51) у меня партионка - этой ошибки на ПТиУ не возникает. Покупка товаров и услуг проходит без ошибок.
С какой операцией ПТиУ ошибку дает?
   SunFox
 
54 - 11.01.22 - 15:22
Вышла 173.2
   Mikhail Volkov
 
55 - 11.01.22 - 16:24
(53) покупка, комиссия
   NorthWind
 
56 - 12.01.22 - 11:52
Кнопки в форме обмена с ФСС съезжают на табличную часть и в 173.1, и в 173.2.

Полечил пока вот так.

Общий модуль РаботаСДиалогамиЗК

// Процедура определяет необходимость быстрого отбора по организации, 

//  устанавливает его, если такая необходимость есть, или скрывает, если ее нет
//

// Параметры
//  Форма                             - форма списка документов или журнала документов

//  ИмяСпискаДокументов                - строка, имя реквизита содержащего список документов
//

Процедура НастроитьОтборПоОрганизации(Форма, ИмяСпискаДокументов, ОтборПоГоловнойОрганизации = Ложь) Экспорт
    
    ДоступностьОрганизаций = ДоступностьОрганизаций();
    ОтборДоступен = ?(ОтборПоГоловнойОрганизации, ДоступностьОрганизаций.ДоступноНесколькоГоловныхОрганизаций, ДоступностьОрганизаций.ДоступноНесколькоОрганизаций);
    
    ЭлементыФормы = Форма.ЭлементыФормы;
    ЭлементыФормы[ИмяСпискаДокументов].Колонки.Организация.Видимость = ОтборДоступен;
    
    // если элемент управления отбором размещен на панели - управляем сверткой

    // если нет - видимостью

    Если ЭлементыФормы.Найти("ПанельОтборПоОрганизации") = Неопределено Тогда
        ЭлементыФормы.ОрганизацияФлаг.Видимость = ОтборДоступен;
        ЭлементыФормы.Организация.Видимость     = ОтборДоступен;
    Иначе
        // [*] ИСПРАВЛЕНИЕ ЗДЕСЬ - в 8.3 панель получается кривой после свертки

        // ЭлементыФормы.ПанельОтборПоОрганизации.Свертка = ?(ОтборДоступен, РежимСверткиЭлементаУправления.Нет, РежимСверткиЭлементаУправления.Верх);

        ЭлементыФормы.ПанельОтборПоОрганизации.Доступность = Ложь;
    КонецЕсли;
    
    Если ОтборДоступен Тогда
        УстановитьБыстрыйОтборПоОрганизации(Форма, ИмяСпискаДокументов, ОтборПоГоловнойОрганизации);
    КонецЕсли;
    
КонецПроцедуры
   NorthWind
 
57 - 12.01.22 - 11:52
* в форме журнала документов обмена с ФСС


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.