Вход | Регистрация
 

Муки Битрикса. Почему не работает настройка "Выгружать только измененные объекты"?

Муки Битрикса. Почему не работает настройка "Выгружать только измененные объекты"?
Я
   Dmitry1c
 
27.12.21 - 19:06
Почему-то не работает настройка "Выгружать только измененные объекты"?

Модуль битрикса, скачанный с сайта битрикса и интегрированный в УТ11.

Может кто-то собаку съел и может подсказать, что с этой собачатиной делать? Модуль не дорабатывался.

Каждый раз выгружается одинаковая (полная) порция данных, либо я чего-то не понимаю.
   Кулибин
 
1 - 27.12.21 - 19:08
Должно работать
   Смотрящий
 
2 - 27.12.21 - 19:12
(0) Версии модуля и уг каакие ?
   Dmitry1c
 
3 - 27.12.21 - 19:14
(2) модуль актуальный для УТ11 актуальной
   Dmitry1c
 
4 - 27.12.21 - 19:14
Модуль 7.0.1.38
   Михаил Козлов
 
5 - 27.12.21 - 19:15
Перед выгрузкой можно посмотреть зарегистрированные изменения.
   Dmitry1c
 
6 - 27.12.21 - 19:16
(5) пусто там. да и зачем их смотреть? если пусто - ничего идейно выгружаться не должно. А выгружается тот же объем данных, что при настройке "Полная выгрузка"
   Dmitry1c
 
7 - 27.12.21 - 19:22
Какой сценарий надо вогнать в базу, чтобы проверить работоспособность настройки?

Сделать обмен "только изменения" один раз, затем сделать закупку ТМЦ и сделать обмен "Только изменения" другой раз?
   Гений 1С
 
8 - 27.12.21 - 19:22
(6) отладчик православный религия в руки взять не дает, РежимОтладки указав в параметрах запуска?
Насколько я помню код 1с-интеграции с битриксом, там иногда полная выгрузка стартует по определенным условиям.
   ivanovpetr79
 
9 - 27.12.21 - 19:23
Битрикс не нужен. PHP не нужен
   Dmitry1c
 
10 - 27.12.21 - 19:23
(8) ну вот этот факт "там иногда полная выгрузка стартует по определенным условиям" надо еще знать, что разработчики там мины замедленного действия положили.

Спасибо, Геня, сейчас погляжу.
   Гений 1С
 
11 - 27.12.21 - 19:23
У тебя общий модуль выгрузки в интеграции называется Б_ОбменССайтомСерверВыгрузкаДанных?
   PuhUfa
 
12 - 27.12.21 - 19:24
(6) Ну значит что то не так с настройками. Так как тяжело выгружать "только изменения" если эти самые изменения даже не регистрируются. Другой вопрос бы был, если бы они регистрировались, но выгружались бы все равно все данные.
   Смотрящий
 
13 - 27.12.21 - 19:25
(3) уг 11.4 или "актуальная" 11.5?
   Dmitry1c
 
14 - 27.12.21 - 19:25
(13) 11.4
   Dmitry1c
 
15 - 27.12.21 - 19:25
(11) да
   PuhUfa
 
16 - 27.12.21 - 19:25
А вообще, типовой обмен в УТ11.4 нормально работает с сайтом на битриксе без этой самой надстройки от битрикса.
   Гений 1С
 
17 - 27.12.21 - 19:25
Запрос.УстановитьПараметр("ПолнаяВыгрузка",(НЕ ПараметрыОбмена.ВыгружатьТолькоИзменения ИЛИ ПараметрыОбмена.ВыполнятьПолнуюВыгрузкуПринудительно))

это в процедуре ПолучитьПользовательскиеСправочникиОбменаДляФормированияПакетов

Поставь КоличествоЭлементовСправочникаВПакете не равное нулю, похоже вот эта шняга тебя калечит:
                Если (ПараметрыОбмена.ВыгружатьТолькоИзменения И НЕ ПараметрыОбмена.ВыполнятьПолнуюВыгрузкуПринудительно) ИЛИ (ПараметрыОбмена.КоличествоЭлементовСправочникаВПакете <> 0) тогда
                    XDTOПользовательскиеСправочники.СодержитТолькоИзменения = XMLСтрока(Истина);
                Иначе
                    XDTOПользовательскиеСправочники.СодержитТолькоИзменения = XMLСтрока(Ложь);
                КонецЕсли;
   Dmitry1c
 
18 - 27.12.21 - 19:26
(12) регистрируются. но выгружаются все данные. (16) мне нужно через надстройку.
   Смотрящий
 
19 - 27.12.21 - 19:31
(14) там с 14 версии модуля для 11.4 "баг" есть - все регистрируется к обмену. Ф-я возвращает всегда Истина, а на стороне сайта - нет селекции по "измененным" объектам.
   Dmitry1c
 
20 - 27.12.21 - 19:33
(19) лечение известно?
   Dmitry1c
 
21 - 27.12.21 - 19:35
Ага, в параметрах "ВыгружатьТолькоИзменения" = Ложь определено
   Dmitry1c
 
22 - 27.12.21 - 19:36
(21) вру

Параметры.ВыполнятьПолнуюВыгрузкуПринудительно в Истина
   Гений 1С
 
23 - 27.12.21 - 19:37
(22) будь мужиком, найди где она в Истену устанавливается
   PuhUfa
 
24 - 27.12.21 - 19:38
(22) дело осталось за малым, найти где формируются Параметры и почему выставляется Истина -)
   Dmitry1c
 
25 - 27.12.21 - 19:39
Расследование привело к регистру

e1cib/list/РегистрСведений.Б_ИнформацияОНастройкахОбменаССайтом
там есть флажок "ВыполнятьПолнуюВыгрузкуПринудительно "

непонятно почему там он сейчас "истина"
   Гений 1С
 
26 - 27.12.21 - 19:39
А галочка в КОнтроль изменений на закладке "Режим обмена данных" стоит в "Выгружать только измененные объекты".
Обмен стартуешь не по кнопке "Принудительная выгрузка картинок", надеюсь?
   Dmitry1c
 
27 - 27.12.21 - 19:40
(26) только измененные
нет, по кнопке "Синхронизация - выполнить обмен данными"
   Гений 1С
 
28 - 27.12.21 - 19:40
(27) тогда хз, меняй регистер настроек напрямую
   Dmitry1c
 
29 - 27.12.21 - 19:41
ВыполнятьПолнуюВыгрузкуПринудительно = Ложь;
    Выборка = РегистрыСведений.Б_ИнформацияОНастройкахОбменаССайтом.Выбрать(Новый Структура("НастройкаОбмена" , УзелОбмена));
    Пока Выборка.Следующий() Цикл
        Если Выборка.ВидСостояния = "Принудительная полная выгрузка" тогда
            ВыполнятьПолнуюВыгрузкуПринудительно = Выборка.ПринудительнаяПолнаяВыгрузка;
        КонецЕсли;
    КонецЦикла;
    Параметры.Вставить("ВыполнятьПолнуюВыгрузкуПринудительно", ВыполнятьПолнуюВыгрузкуПринудительно)




как вам такой кодище? сравнение со строкой "Принудительная полная выгрузка" особенно
   Гений 1С
 
30 - 27.12.21 - 19:43
(29) ну ты что, это конечно не "1С совместимо", но это Битрикс, это другое.
 
 
   Dmitry1c
 
31 - 27.12.21 - 19:46
А там узлы обмена очищаются при обмене с сайтом? Сейчас при выгрузке в каталог - нифига.
Т.е. работает механизм обмена сообщениями (квитирование) ?

Проблема короче была во флажке "Принудительная полная выгрузка" в регистре сведений
   Гений 1С
 
32 - 27.12.21 - 19:50
(31) УдалениеПакетовИРегистрацийИзмененияПослеВыгрузкиНаСайт тебе в зубы
но походу там что-то не очищается, хз
   Гений 1С
 
33 - 27.12.21 - 19:51
ВыгрузитьИнформациюОТоварах вроде вызывает УдалениеПакетовИРегистрацийИзмененияПослеВыгрузкиНаСайт, но в этой процедуре убран код по удалению регистрации о выгруженных данных, видимо переделали на другую схему, хз
   Dmitry1c
 
34 - 27.12.21 - 19:52
(33) такой вот он, модуль битрикса...
   Гений 1С
 
35 - 27.12.21 - 19:54
(34) ПолучитьДанныеИзРегистраПакетовИУдалениеРегистрации покури еще. Не могу понять, он регистрацию до выгрузки удаляет что ли, хз
   Dmitry1c
 
36 - 27.12.21 - 19:55
(35) шпашибо!
   Смотрящий
 
37 - 27.12.21 - 20:06
(36) на стороне сайта нет селекции по измененным объектам. Модуль 1с в данном случае это половина от механизма обмена. Решайте через загрузку данных на сайте
   Dmitry1c
 
38 - 27.12.21 - 20:27
(37) я код модуля посмотрел. на весь модуль есть только такая отмена регистрации изменений:

Процедура УдалениеПакетовИРегистрацийИзмененияПослеВыгрузкиНаСайт(Успешно, ПараметрыОбмена, Операция, Пакет, ИдентификаторКаталога, МассивСтрок, МассивКартинок = Неопределено, МассивФайлов = Неопределено)
    
    ПараметрыОбмена.ОбменВыполненБезОшибок = ?(НЕ Успешно, Успешно, ПараметрыОбмена.ОбменВыполненБезОшибок);
    
    Если Успешно ИЛИ НЕ ПараметрыОбмена.ВыгружатьНаСайт тогда
        НаборЗаписей = РегистрыСведений.Б_ПакетныйОбмен.СоздатьНаборЗаписей();
        НаборЗаписей.Отбор.Пакет.Установить(Пакет);
        НаборЗаписей.Отбор.НастройкаОбмена.Установить(ПараметрыОбмена.Ссылка);
        НаборЗаписей.Отбор.Каталог.Установить(ИдентификаторКаталога);
        НаборЗаписей.Отбор.Операция.Установить(Операция);
        НаборЗаписей.Очистить();
        НаборЗаписей.Записать(Истина);
    КонецЕсли;
    
    //Если НЕ Успешно  тогда

    //    

    //    Для Каждого Данные Из МассивСтрок Цикл

    //        

    //        ПланыОбмена.ЗарегистрироватьИзменения(ПараметрыОбмена.Ссылка, Данные.Объект);

    //    

    //    КонецЦикла; 

    //    

    //КонецЕсли;

    
    Если Успешно  тогда
        
        Если МассивКартинок <> неопределено тогда
            Для Каждого Данные Из МассивКартинок Цикл
                ПланыОбмена.УдалитьРегистрациюИзменений(ПараметрыОбмена.Ссылка, Данные);
            КонецЦикла;
        КонецЕсли;                            
        МассивКартинок = Неопределено;
        
        Если МассивФайлов <> неопределено тогда
            Для Каждого Данные Из МассивФайлов Цикл
                ПланыОбмена.УдалитьРегистрациюИзменений(ПараметрыОбмена.Ссылка, Данные);
            КонецЦикла;
        КонецЕсли;
        МассивФайлов = Неопределено;
    КонецЕсли;
    
КонецПроцедуры
   Dmitry1c
 
39 - 27.12.21 - 20:27
(38) +больше ничего нет
   Dmitry1c
 
40 - 27.12.21 - 20:27
Грубо говоря какая-то х.та.
   Гений 1С
 
41 - 27.12.21 - 20:39
(38) посмотри (35), плохо смотрел. Там регистр пакетов. У меня изменения очищает после обмена успешного
   Гений 1С
 
42 - 27.12.21 - 20:40
(37) вы о чем? как сайт проселектирует изменения? вы что хотите все товары всегда на сайт пихать? Не говорите ерундой
   Dmitry1c
 
43 - 27.12.21 - 20:44
(41) а у тебя какой релиз модуля?
   Dmitry1c
 
44 - 27.12.21 - 20:45
(41) ты под изменениями понимаешь регистрацию на узлах обмена?
   Гений 1С
 
45 - 27.12.21 - 20:53
(44) да, регистрацию на узлах обмена.
7.0.1.32
   Смотрящий
 
46 - 27.12.21 - 20:57
(42) Да засохни, Промокашка. Ты не отдупляешь
   ivanovpetr79
 
47 - 27.12.21 - 22:21
Госуслуги оказывается созданы на базе Битрикс

Исходный код регионального портала «Госуслуг» Пензенской области был слит в интернет. Как рассказал изданию «Код Дурова» основатель сервиса разведки утечек данных и мониторинга даркнета DLBI Ашот Оганесян, пользовательские данные затронуты не были.

Как отмечает «Код Дурова», исходники «Госуслуг» первым выложил ресурс cybersec.org. В дальнейшем тема с обсуждением ситуации появилась и на платформе Habr. Авторы отметили, что код удалось скачать с поддоменов mos.ru, где тот хранился в незашифрованном виде.

Авторы слива утверждали, что в полученных ими данных также содержатся сертификаты ЕСИА. Ими был сделан вывод, что «Госуслуги» созданы на базе платформы «Битрикс», а ЕСИА — на базе OpenID. Также ресурс cybersec.org отмечал, что пытался связаться с порталом «Госуслуг» и сообщить им о проблеме. Специалисты платформы запросили точное описание слитых файлов, после чего якобы перестали выходить на связь.

Как уточнил Оганесян, речь идет об исходном коде регионального портала «Госуслуг» Пензенской области. Пользовательские данные, по его словам, не были слиты в сеть.
   ivanovpetr79
 
48 - 27.12.21 - 22:22


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.