Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Помогите написать запрос на 7.7

v7: Помогите написать запрос на 7.7
Я
   Vovka-x13
 
24.12.21 - 14:43
Добрый день, в 7.7 никогда не работал! Никак не получается сделать.
Есть справочник стандартный "номенклатура" и справочник "ИД_Номенклатура" в котором два реквизита "ссылка" это как раз и есть номенклатура и "ИД" с типом строка.
мне нужно по определенной номенклатуре узнать какой у нее "ИД"
Как это сделать на 7.7-шном коде, подскажите пожалуйста примером!
   Мультук
 
1 - 24.12.21 - 14:51
//поиск по реквизиту по всему справочнику

Справочник = СоздатьОбъект("Справочник.Контрагенты");
Если Справочник.НайтиПоРеквизиту("ИНН", ИНН, 1) = 1 Тогда
    Сообщить("Найден контрагент: " + Справочник.Наименование);
Иначе
    Сообщить("Упс! По ИНН " + ИНН + " контрагент не найден!");
КонецЕсли;
   Double_Medved
 
2 - 24.12.21 - 14:53
Вот пройдет несколько лет и будет тема:

помогите, никогда в 8-ке этой старой не работал, как в этих дурацких управляемых формах сделать кнопку?
   Мультук
 
3 - 24.12.21 - 14:53
много раз в цикле

Если Справочник.НайтиПоРеквизиту("ссылка", ИскомаяСсылка, 1) = 1 Тогда
   Vovka-x13
 
4 - 24.12.21 - 15:08
В Конвертации данных в
Обработчике "Правила конвертации свойств"
Параметры:
Источник - Произвольный. Ссылка на выгружаемый объект источник данных

 при выгрузке пишут так, но видимо с указанием "Источник" что то по другому нужно  писать 

Справочник = СоздатьОбъект("Справочник.ID_Номенклатура");
Если Справочник.НайтиПоРеквизиту("Ссылка", Источник, 1) = 1 Тогда
    Сообщить("Найден : " + Справочник.ID+"    "+ Справочник.Ссылка);
    Значение=Справочник.ID;
Иначе
    Сообщить("Упс! По  " + Источник + "  не найден!");
КонецЕсли;

Что может быть не так?
   Builder
 
5 - 24.12.21 - 15:29
(4) Что надо то? И что не получается? Я ничего не понял.
Что у тебя за тип "Источник". Сомневаюсь что ссылка на справочник.
Скорее всего код?
   GreyK
 
7 - 24.12.21 - 15:34
+(6) Прочитал (4), не понял, а при чём здесь запрос?
   acanta
 
8 - 24.12.21 - 15:45
"Ид=справочник.идноменклатура.ид;
Ссылка=справочник.идноменклатура.ссылкп;
Группировка ссылка без упорядочивания без групп;
"
Тз=создатьобьект("таблицазначений");
Запрос.выгрузить(тз,0,0);
//Это глобальная переменная при начале загрузки правил обмена

//А это в поиске
Стр=0;
Если Тз.найти(стр,ид,"ид")=0 тогда возврат
Конецесли;
Ссылка=тз.получитьзначение(стр,"ссылка");
   Эльниньо
 
9 - 24.12.21 - 16:54
СпрИД.НайтиЭлемент(СпрНом.ТекущийЭлемент());
ИД = СпрИД.ИД;
   Builder
 
10 - 24.12.21 - 17:04
(9) Это зачем?
Что мешает 
ИД = СпрНом.ИД;
?????
   Vovka-x13
 
11 - 24.12.21 - 17:35
(4) вариант работает, спасибо!
   Злопчинский
 
12 - 24.12.21 - 21:29
(9) трэш какой...
..
Недоделанные отчеты - это не беда.
Главное - доделывайте детей.
А то недоделанные дети приносят недоделанные отчеты.
И никак не разорвать этот порочный круг...
   ТакВотЖе
 
13 - 24.12.21 - 22:45
(12) 100 баллов)))
   Guk
 
14 - 24.12.21 - 22:57
о, теперь знаю, как оформлять свои ветки с вопросами по 1С
"Добрый день, в 7.7, 8.0, 8.1, 8.2, 8.3 никогда не работал! Никак не получается сделать. Люди мы не местные"...
   Злопчинский
 
15 - 25.12.21 - 14:59
ковыряю тут код у одного клиента (про доделанных ;-)...

вывод реквизита-флажка

Функция ПоказатьНовинки() 
    
    //Если ЭтоГруппа() = 1 Тогда 

    //    Возврат 0; 

    //КонецЕсли;

    //

    //Если ПустоеЗначение(ТекущийЭлемент()) = 1  Тогда 

    //    Возврат 0; 

    //Иначе    

    //    Возврат ТекущийЭлемент().Новинки;

    //КонецЕсли;


    Возврат Новинки;//[+]progadmin 25.12.21 ДОБАВЛЕНО НЕТИПОВОЕ 

КонецФункции// ПоказатьНовинки()
   Калиостро
 
16 - 26.12.21 - 00:26
(15) Если не делать проверку на ПустоеЗначение(ТекущийЭлемент()), то в пустом справочнике будет выводиться пустая строка с значением в колонке "Новинки".
   Guk
 
17 - 26.12.21 - 00:36
(16) там код вообще не рабочий...
   Guk
 
18 - 26.12.21 - 00:39
+(17) вернее рабочий, только нафиг не нужный. достаточно в дополнительно просто написать Новинки, если это реквизит справочника...
   Злопчинский
 
19 - 26.12.21 - 01:31
(16) нормально все, ничего не выводится. не, если именно вообще пустой справочник - ну, может скосячит. а так, в пустой группе - ничего не выводится, норм все.
   Злопчинский
 
20 - 26.12.21 - 01:32
(18) угу, ну раз функция была - оставил функцию.. ;-)
   Злопчинский
 
21 - 26.12.21 - 01:40
да там вообще косяк на косяк...
Доп.регистр остатков (типа интеркампани, "Номенклатура,Количество"), документы штатно (ТиС) оформляются, в т.ч. и в основных единицах/упаковках. А в регистр пишется без пересчета в базовую. Потом в документ.интеркампани количества для "интеркампани" собираются не из этого регистра, а собираются обходом документов, причем опять же из документов собирается тупо номенклатура и количество (без пересчета в базовые). И документ.интеркампани минусует регистр. В итоге +регистр = +10 (а должно быть 10уп*12 = 120), потом -регистр = -10. И ничего, живут как-то, все сходится... ;-) Не один там кто-то покопался видимо...
   Эльниньо
 
22 - 27.12.21 - 10:25
(10) В СпрНом нет реквизита ИД
   Builder
 
23 - 27.12.21 - 11:00
(22) Ахаха, а в СпрИД он тогда откуда появится? :)


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.