Вход | Регистрация
 

Перенумерация бизнес-процессов 1С Документооборот КОРП

Перенумерация бизнес-процессов 1С Документооборот КОРП
Я
   asder117
 
22.12.21 - 23:03
Доброго времени суток. Пытаюсь создать программно в 1С Документооборот КОРП бизнес-процесс
Функция ОтправитьЗадачуНаСервере()
//НоваяЗадача = Задачи.ЗадачаИсполнителя.СоздатьЗадачу();
//            НоваяЗадача.БизнесПроцесс = объект.Ссылка;
//            НоваяЗадача.Автор = ПараметрыСеанса.ТекущийПользователь;
//            НоваяЗадача.ТочкаМаршрута = БизнесПроцессы.Исполнcyjjd kение.ТочкиМаршрута.Исполнить;
//            НоваяЗадача.Дата = ТекущаяДата();
//            НоваяЗадача.Наименование = БизнесПроцессы.Исполнение.ТочкиМаршрута.Исполнить.НаименованиеЗадачи;
//            НоваяЗадача.Исполнитель = Объект.ИсполнителиЗадач[0].Исполнитель;
//            НоваяЗадача.СрокИсполнения = Объект.ИсполнителиЗадач[0].ДатаИсполнения;
//            НоваяЗадача.Описание = "Выполнение мероприятий";
//            НоваяЗадача.Записать();
    //Если Не ПроверитьЗаполнение() Тогда
    //    Возврат Неопределено;
    //КонецЕсли;
    
    Исполнение = БизнесПроцессы.Исполнение.СоздатьБизнесПроцесс();
    Исполнение.Дата = ТекущаяДатаСеанса();
    //Исполнение.УстановитьНовыйНомер();
    Исполнение.Автор = ПользователиКлиентСервер.ТекущийПользователь();
    //Исполнение.Проверяющий = ПользователиКлиентСервер.ТекущийПользователь();
    
    Исполнение.Наименование = объект.Поручение;
    Исполнение.Наименование = СтрЗаменить(Исполнение.Наименование, Символы.ВК, " ");
    Исполнение.Наименование = СтрЗаменить(Исполнение.Наименование, Символы.ПС, " ");
    Исполнение.Наименование = СтрЗаменить(Исполнение.Наименование, Символы.Таб, " ");
    Исполнение.Описание = объект.ТекстЗадачи;
    Исполнение.ВариантИсполнения = Перечисления.ВариантыМаршрутизацииЗадач.Параллельно;
    Исполнение.КоличествоИтераций = 1;
    //ПредметИсполнения = Исполнение.Предметы.Добавить();
    //ПредметИсполнения.Предмет = ЭтотОбъект;
    Строка = Исполнение.Исполнители.Добавить();
    Строка.Исполнитель = Объект.ИсполнителиЗадач[0].Исполнитель;
    Если ЗначениеЗаполнено(Объект.ИсполнителиЗадач[0].ДатаИсполнения) Тогда
        Строка.СрокИсполнения = КонецДня(Объект.ИсполнителиЗадач[0].ДатаИсполнения);
        Строка.ВариантУстановкиСрокаИсполнения = Перечисления.ВариантыУстановкиСрокаИсполнения.ТочныйСрок;
    КонецЕсли;    
    
    Если ЗначениеЗаполнено(Объект.ИсполнителиЗадач[0].ДатаИсполнения) Тогда
        Исполнение.СрокИсполненияПроцесса = КонецДня(Объект.ИсполнителиЗадач[0].ДатаИсполнения);
    КонецЕсли;    
    
    Исполнение.Записать();
    Исполнение.Старт();
    
    ВозвращаемыйРезультат = Новый Структура(
        "Ссылка, НавигационнаяСсылка, Представление",
        Исполнение.Ссылка,
        ПолучитьНавигационнуюСсылку(Исполнение.Ссылка),
        Строка(Исполнение));
        
    // Сохранение вводимых значений
    //СохранениеВводимыхЗначений.ОбновитьСпискиВыбора(ЭтаФорма, ЭлементыДляСохранения(), ЭтаФорма.ИмяФормы);
        
    Возврат ВозвращаемыйРезультат;

    КонецФункции
При записи пишет что номер не уникален. При проверке действительно присваивается последний причем имеющийся номер. методом присвоения нового кода код не присваивается...механизм перенумерации бизнес-процессов в документооборот отсутсвует. Что я делаю не так может кто подскажет. Спасибо

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.