Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Неоднозначное поле "УходТовара.Ссылка" в форме печати

Неоднозначное поле "УходТовара.Ссылка" в форме печати
Я
   подковы
 
22.12.21 - 15:54
Помогите выбивает ошибку при создании печати:
{(18, 2)}: Неоднозначное поле "УходТовара.Ссылка"
<<?>>УходТовара.Ссылка В (&Ссылка)
{Документ.УходТовара.МодульМенеджера(26)}:    Выборка = Запрос.Выполнить().Выбрать();
{Документ.УходТовара.Команда.Печать.МодульКоманды(18)}:    Документы.УходТовара.Печать(ТабДок, ПараметрКоманды);
{Документ.УходТовара.Команда.Печать.МодульКоманды(6)}:    Печать(ТабДок, ПараметрКоманды);

по причине:
{(18, 2)}: Неоднозначное поле "УходТовара.Ссылка"
<<?>>УходТовара.Ссылка В (&Ссылка)


Код печати:


Процедура Печать(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    Макет = Документы.УходТовара.ПолучитьМакет("Печать");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    УходТовара.Дата,
    |    УходТовара.Договор,
    |    УходТовара.Контрагент,
    |    УходТовара.Номер,
    |    УходТовара.Склад,
    |    УходТовара.Сотрудники,
    |    УходТовара.УходТовара.(
    |        НомерСтроки,
    |        Товар,
    |        Количество,
    |        Цена,
    |        Сумма
    |    )
    |ИЗ
    |    Документ.УходТовара КАК УходТовара
    |ГДЕ
    |    УходТовара.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьУходТовараШапка = Макет.ПолучитьОбласть("УходТовараШапка");
    ОбластьУходТовара = Макет.ПолучитьОбласть("УходТовара");
    ТабДок.Очистить();

    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;

        ТабДок.Вывести(ОбластьЗаголовок);

        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());

        ТабДок.Вывести(ОбластьУходТовараШапка);
        ВыборкаУходТовара = Выборка.УходТовара.Выбрать();
        Пока ВыборкаУходТовара.Следующий() Цикл
            ОбластьУходТовара.Параметры.Заполнить(ВыборкаУходТовара);
            ТабДок.Вывести(ОбластьУходТовара, ВыборкаУходТовара.Уровень());
        КонецЦикла;

        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //}}
КонецПроцедуры


Буду благодарен, кто сделает.
   patapum
 
1 - 22.12.21 - 15:58
У тебя одинаковые имена у документа и табличной части. Задай псевдоним таблицы, и во всех полях ее исправь.
ИЗ Документ.УходТовара КАК УходТовараДокумент
   vicof
 
2 - 22.12.21 - 16:08
Давно я конструктор печати не видел)
   Kassern
 
3 - 22.12.21 - 16:09
(0) "УходТовара.УходТовара." вот тут косяк
   Kassern
 
4 - 22.12.21 - 16:10
Вы табличную часть документа "УходТовара" назвали "УходТовара"?))
   Kassern
 
5 - 22.12.21 - 16:13
(0) Если вам нужна табличная часть, тогда ее и выбирайте:
"ВЫБРАТЬ
|    УходТовараУходТовара.Товар КАК Товар,
|ИЗ
|    Документ.УходТовара.УходТовара КАК УходТовараУходТовара"
П.С. Назовите уже нормально ТЧ, например "Товары"
   vicof
 
6 - 22.12.21 - 16:49
Еще реквизит можно назвать УходТовара. И этот реквизит сделать ссылочным.
   Kassern
 
7 - 22.12.21 - 16:52
(6) а вы знаете толк в извращениях)
   1Сергей
 
8 - 22.12.21 - 16:53
Запрос.Текст =
    "ВЫБРАТЬ
    |    Нурсултан.Дата,
    |    Нурсултан.Договор,
    |    Нурсултан.Нурсултан,
    |    Нурсултан.Номер,
    |    Нурсултан.Нурсултан.(
    |        Нурсултан,
    |        Нурсултан,
    |        Нурсултан,
    |        Нурсултан,
    |        Нурсултан
    |    )
    |ИЗ
    |    Документ.Нурсултан КАК Нурсултан
    |ГДЕ
    |    Нурсултан.Ссылка В (&Нурсултан)";
   Dmitrii
 
9 - 22.12.21 - 16:54
(6) >> Еще реквизит можно назвать УходТовара. И этот реквизит сделать ссылочным.

+ Ссылочным на справочник УходТовара, у которого есть табличная часть УходТовара с реквизитом УходТовара тип документ-ссылка УходТовара.
   Kassern
 
10 - 22.12.21 - 16:55
(6) надеюсь у этой ссылки будет свойство "УходТовара"
https://disk.yandex.ru/i/Wnnf1AlWiN4pyQ красота!))
   Kassern
 
11 - 22.12.21 - 16:56
(9) прям на одной волне)
   acht
 
12 - 22.12.21 - 20:50
Товар, уходи...
   acht
 
13 - 22.12.21 - 21:01
А, это эти наркоманские курсы, где уход товара делает приход...
https://avatars.mds.yandex.net/get-zen_doc/4520400/pub_606452dffa23f523d361f519_606c444111c8ff50b33d5340/scale_1200

Спрыгнул бы ты, ТС, с этой дряни пораньше.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.