Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1с Маркировка лекарственных средств ФН 1.2 Атол ошибка 0x7104

1с Маркировка лекарственных средств ФН 1.2 Атол ошибка 0x7104
Я
   illiona
 
30.11.21 - 12:20
Добрый день. Конфигурация самописная не уф. Взяла обработку для атола в новой торговле 10.3
Заполняю отраслевой реквизит товарной части и касса выдает ошибку 0x7104 - это тэг 1260

Если Константы.РежимФН12.Получить()=Истина ТОгда
            // ффд 1.2
            // 1260
            ОбщиеПараметры.ОтраслевойРеквизит.ИдентификаторФОИВ = "020";
            ОбщиеПараметры.ОтраслевойРеквизит.ДатаДокументаОснования = "14.12.2018";
            ОбщиеПараметры.ОтраслевойРеквизит.НомерДокументаОснования = "1556";
            ОбщиеПараметры.ОтраслевойРеквизит.ЗначениеРеквизита = "tm=mdlp&sid=" + ЧекККМ.Отдел.МестоДеятельностиМДЛП.Идентификатор + "&";
        КонецЕсли;
        

Процедура ЗаписатьОтраслевойРеквизит(ЗаписьXML, ОтраслевойРеквизит)
    
    ЗаписьXML.ЗаписатьНачалоЭлемента("IndustryAttribute");
    
    Если Не ПустаяСтрока(ОтраслевойРеквизит.ИдентификаторФОИВ) Тогда
        ЗаписьXML.ЗаписатьАтрибут("IdentifierFOIV",  XMLСтрока(ОтраслевойРеквизит.ИдентификаторФОИВ));
    КонецЕсли;
    Если Не ПустаяСтрока(ОтраслевойРеквизит.ДатаДокументаОснования) Тогда
        ДатаДокументаОснования = Формат(ОтраслевойРеквизит.ДатаДокументаОснования, "ДФ=""дд.ММ.гггг""");
        ЗаписьXML.ЗаписатьАтрибут("DocumentDate",  ДатаДокументаОснования);
    КонецЕсли;
    Если Не ПустаяСтрока(ОтраслевойРеквизит.НомерДокументаОснования) Тогда
        ЗаписьXML.ЗаписатьАтрибут("DocumentNumber",  XMLСтрока(ОтраслевойРеквизит.НомерДокументаОснования));
    КонецЕсли;
    Если Не ПустаяСтрока(ОтраслевойРеквизит.ЗначениеРеквизита) Тогда
        ЗаписьXML.ЗаписатьАтрибут("AttributeValue",  XMLСтрока(ОтраслевойРеквизит.ЗначениеРеквизита));
    КонецЕсли;
    
    ЗаписьXML.ЗаписатьКонецЭлемента();

    
КонецПроцедуры
ЗаписатьОтраслевойРеквизит(ЗаписьXML, ТекущаяПозиция.ОтраслевойРеквизит);

Может кто-нибудь сталкивался с этой ошибкой атола и исправил?
   Галахад
 
1 - 30.11.21 - 12:33
ИМХО, дата должна быть в формате yyyy.mm.dd
   illiona
 
2 - 30.11.21 - 16:22
вроде получилось, теперь касса требует заполнить тэг 1207. Может у кого есть пример заполнения этого ТЭГА
   Voidium
 
3 - 23.12.21 - 23:56
(2) А как удалось победить ошибку с тегом 1260? Такая же проблема

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.