Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Зачем нужны циклы кроме бесконечного??

↓ [Волшебник, 26.11.21 - 08:57]
Зачем нужны циклы кроме бесконечного??
Я
   dubolom
 
26.11.21 - 08:22
Единственный необходимый цикл выглядит так:

Пока Истина Цикл
   (инструкции)
   Если УсловиеПрерывания Тогда
      Прервать;
   КонецЕсли;
   (инструкции)
КонецЦикла;

Он гораздо более гибок, чем все эти Для, Для Каждого и Пока (без условий прерывания). Потому что можно прекращать в любом месте цикла и по любому условию. Очень легко смоделировать таким образом цикл Для, например:

а = 1;
Пока Истина Цикл
   а = а+1;
   Если а>МаксимальноеЗначение Тогда
      Прервать;
   КонецЕсли;
   (тело цикла)
КонецЦикла;

Считаю, что все вышеупомянутые виды циклов в платформе 1с избыточны.
   (
   SleepyHead
 
1 - 26.11.21 - 08:29
(0) Что за полумеры? Единственно, что тебе нужно, это оператор GOTO, а все эти богомерзские циклы придуманы лентяями.
   ДенисЧ
 
2 - 26.11.21 - 08:30
"Считаю, что все вышеупомянутые виды циклов в платформе 1с избыточны."


Считаю, что dubolom избыточен в 1с и на этом форуме.
   acht
 
3 - 26.11.21 - 08:35
(0) Чтобы стать хотя бы бледным подобием Ливингстара надо сменить десяток ников. Работай над собой и у тебя все получится!
   ADirks
 
4 - 26.11.21 - 08:43
(3) менять ники - это устаревший приём, и вообще пошло
а вот менять личность в рамках одного ника - это менее распространенное явление, тут можно и проявить свою яркую индивидуальность... ну, или мультивидуальность...
   Гипервизор
 
5 - 26.11.21 - 08:47
(0) А что насчёт циклов в других ЯП?
   ribuh
 
6 - 26.11.21 - 08:52
даааа ... мне бы ваши проблемы ...
вот глобально, у кого то есть ответ на вопрос:
Если Быть Или Не быть Тогда
    //тут всё понятно

Иначе
    //а вот это возможно?

КонецЕсли;
   Обработка
 
7 - 26.11.21 - 08:53
Вам не кажется что тут на форуме устроились работать несколько человек чтоб развлекать нас.
Волшебник признайся кому там сколько платишь?
   Волшебник
 
Модератор
8 - 26.11.21 - 08:57
(7) Наоборот, я их выгоняю, а они всё лезут и лезут...
   mistеr
 
9 - 26.11.21 - 09:01
(7) Рпхосту за политику точно платят. Если не Волшебник, то кто-то другой, однозначно.
   Тихий омут
 
10 - 26.11.21 - 09:34
(0) Да ладно, даже они избыточны. ТруЪ код - строго линейный, без использования переходов вообще... Уж на что на ZX экономили память (48КБ ОЗУ - это вам не хрен собачий, расслабились нынче на перепроизводстве полупроводников), но и там ради экономии нескольких сотен тактов за кадр циклы нередко разворачивали в линейный код. А если вспомнить оптимизацию кода с точки зрения строго определенного количества тактов на выполнение функции независимо от входных параметров... Короче, радуйся, что у тебя есть столько ненужных тебе возможностей:)
   VladZ
 
11 - 26.11.21 - 10:42
(0) Для удобства написания и для повышения читабельности.
   Злопчинский
 
12 - 26.11.21 - 11:07
(11) нифига.
Если так было бы тогда было бы
Функция СделатьВсе()
   hhhh
 
13 - 26.11.21 - 17:01
(6) ну это на всякий случай. А вдруг что-то случится. Я раньше тоже писал

Если ТЧ.Количество() <= 0

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.