Вход | Регистрация
 

Ошибка "Метод объекта не обнаружен (Печать)"

Ошибка "Метод объекта не обнаружен (Печать)"
Я
   oduvanchikyan
 
25.11.21 - 18:34
Добрый день, создаю внешнюю обработку на основе реализации товара, открывается форма, пользователь внес данные и потом нажимает печать.
Возникла проблема, что указав данные "СведениеОВнешнейОбработке" и добавив программу в 1с. Выскакивает ошибка - Метод объекта не обнаружен (Печать).
Код приложил внизу:
Функция СведенияОВнешнейОбработке()Экспорт
    
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму
    ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяДоработка"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
    //ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ТТН 2021"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
    ПараметрыРегистрации.Вставить("Версия", "2.0");
    ПараметрыРегистрации.Вставить("Информация", "Эту ВПФ мы сделали для того что бы посмотреть возможности БСП ");
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, "ТТН 2021-новая", "ТТН(1ТН)", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
    
Конецфункции

Функция ПолучитьТаблицуКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции
    
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
        
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
        
КонецПроцедуры
Спасибо за помощь!)
   ДенисЧ
 
1 - 25.11.21 - 18:36
А где таки функциЁ печать()?
На ИТС расписаны все функциЁ, которые должны быть в обработке печати...
   polosov
 
2 - 25.11.21 - 18:37
(0) Обычные формы похоже. Что за конфигурация?
   oduvanchikyan
 
3 - 25.11.21 - 18:39
(1) Так дело в том что самой ф-ции печати нет! Есть текст ошибки полный :
Метод объекта не обнаружен (Печать)
{ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(221)}:    ВнешняяОбработкаОбъект.Печать(
{ОбщаяФорма.ПечатьДокументов.Форма(349)}:            МодульДополнительныеОтчетыИОбработки.ПечатьПоВнешнемуИсточнику(Параметры.ИсточникДанных,
{ОбщаяФорма.ПечатьДокументов.Форма(36)}:    СформироватьПечатныеФормы(КоллекцияПечатныхФорм, Параметры.ИменаМакетов, Отказ);
{ОбщийМодуль.ДополнительныеОтчетыИОбработкиКлиент.Модуль(530)}:    ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия, Форма);
{ОбщийМодуль.ДополнительныеОтчетыИОбработкиКлиент.Модуль(511)}:        ВыполнитьОткрытиеПечатнойФормыЗавершение(ОбъектыНазначения, Параметры);
{ОбщийМодуль.ДополнительныеОтчетыИОбработкиКлиент.Модуль(354)}:        ВыполнитьОткрытиеПечатнойФормы(ВыполняемаяКоманда, Форма, ВыполняемаяКоманда.ОбъектыПечати);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(102)}:            МодульДополнительныеОтчетыИОбработкиКлиент.ВыполнитьНазначаемуюКомандуПечати(ОписаниеКоманды, Форма);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(81)}:    ВыполнитьПодключаемуюКомандуПечатиЗавершение(Истина, ДополнительныеПараметры);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(62)}:    ВыполнитьПодключаемуюКомандуПечатиПодключениеРасширенияРаботыСФайлами(ОбъектыПечати, ДополнительныеПараметры);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(24)}:    ВыполнитьПодключаемуюКомандуПечатиПодготовкаОбъектовПечати(ДополнительныеПараметры);
{ОбщийМодуль.УправлениеПечатьюКлиент.Модуль(158)}:    УправлениеПечатьюСлужебныйКлиент.ВыполнитьПодключаемуюКомандуПечатиПодтверждениеЗаписи(Неопределено, ДополнительныеПараметры);
{Документ.РеализацияТоваровУслуг.Форма.ФормаСписка.Форма(136)}:    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Элементы.Список);
   oduvanchikyan
 
4 - 25.11.21 - 18:39
(2) БУ для Украины 2.0
   oduvanchikyan
 
5 - 25.11.21 - 18:41
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
                            КоллекцияПечатныхФорм,
                            "РасходнаяВнешняя",
                            "Видаткова накладна "+" № "+МассивОбъектов[0].Номер+" від "+Формат(МассивОбъектов[0].Дата,"ДФ=dd.MM.yyyy"),
                            СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати));

КонецПроцедуры// Печать()



Функция СформироватьПечатнуюФорму(СсылкаНаОбъект,ОбъектыПечати)

//    

КонецФункции

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.