Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отчет По Прочие Расходы

Отчет По Прочие Расходы
Я
   Farid0516
 
24.11.21 - 09:19
Доброе утро.
Я скопировал документ Прочие Расходы и создал документ Зарплата. Но я хочу видеть документы Прочие Расходы и Зарплата в Отчет По Прочие Расходы. Как добавить?
   Farid0516
 
1 - 24.11.21 - 09:20
Функция ТекстЗапроса(Параметр)
    текст="";
    
    Текст = 
    "
    |ВЫБРАТЬ
    |ВЫБОР
    |    КОГДА КассаДвижение.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
    |    ТОГДА КассаДвижение.Сумма
    |    ИНАЧЕ 0
    |КОНЕЦ  как СуммаРасход,
    |КассаДвижение.Касса как Касса,
    |КассаДвижение.Валюта  как Валюта,
    |КассаДвижение.Кому_ОтКого как Кому_ОтКого,
    |КассаДвижение.СтатяЗатрат как СтатяЗатрат,
    |ВЫРАЗИТЬ(КассаДвижение.Регистратор КАК Документ.ПрочиеРасходы И Документ.Зарплата) как Регистратор
    |ИЗ
    |    РегистрНакопления.Касса КАК КассаДвижение
    |ГДЕ
    |    КассаДвижение.Период МЕЖДУ &ДатаНачала И &ДатаКонца
    |И  ВЫРАЗИТЬ(КассаДвижение.Регистратор КАК Документ.ПрочиеРасходы И Документ.Зарплата)<>НЕОПРЕДЕЛЕНО
    |   ТекстОтбораДвижение 
    |   ТекстПорядок
    |ИТОГИ
    |    СУММА(СуммаРасход)
    |ПО
    |    //ИтогКасса//                        Касса   

    |    //ИтогВалюта//                       Валюта

    |    //ИтогКому_ОтКого//                  Кому_ОтКого   

    |    //ИтогСтатяЗатрат//                  СтатяЗатрат";

     возврат текст;
КонецФункции// ТекстЗапроса()



Процедура Отчет(ТабДок)
    мСписокГруппировки=новый СписокЗначений;
    мСписокВыбранныеПоля=новый СписокЗначений;
    номГруппировкиРегистратор=0;
    
    ПоказатьДетал=ложь;
    печСписокГруппировки="";

    Макет = ПолучитьМакет("Отчет");
    ПостроительОтчета=новый ПостроительОтчета;
    ПостроительОтчета.Текст="ВЫБРАТЬ
                            |    ПрочиеРасходыТЧ.Касса + ЗарплатаТЧ.Касса КАК Касса,
                            |    ПрочиеРасходыТЧ.Кому + ЗарплатаТЧ.Кому КАК Кому_ОтКого,
                            |    ПрочиеРасходыТЧ.Сумма + ЗарплатаТЧ.Сумма КАК СуммаРасход,
                            |    ПрочиеРасходыТЧ.СтатяЗатрат + ЗарплатаТЧ.СтатяЗатрат КАК СтатяЗатрат,
                            |    ПрочиеРасходыТЧ.Ссылка.Валюта + ЗарплатаТЧ.Ссылка.Валюта КАК Валюта,
                            |    ПрочиеРасходыТЧ.Ссылка + ЗарплатаТЧ.Ссылка КАК Регистратор,
                            |    ПрочиеРасходыТЧ.Заметка + ЗарплатаТЧ.Заметка как Комментарий
                            |ИЗ
                            |    Документ.ПрочиеРасходы.ТЧ И Документ.Зарплата.ТЧ КАК ПрочиеРасходыТЧ
                            |ГДЕ
                            |    ПрочиеРасходыТЧ.Ссылка.Проведен И ЗарплатаТЧ.Ссылка.Проведен
                            |    И ПрочиеРасходыТЧ.Ссылка.Дата МЕЖДУ &ДатаНачала И &ДатаКонца
                            |    И ЗарплатаТЧ.Ссылка.Дата МЕЖДУ &ДатаНачала И &ДатаКонца
                            |{ГДЕ
                            |    ПрочиеРасходыТЧ.Касса.*,
                            |    ПрочиеРасходыТЧ.Кому.*,
                            |    ПрочиеРасходыТЧ.СтатяЗатрат.*,
                            |    ПрочиеРасходыТЧ.Ссылка.Валюта.*}
                            |    ЗарплатаТЧ.Касса.*,
                            |    ЗарплатаТЧ.Кому.*,
                            |    ЗарплатаТЧ.СтатяЗатрат.*,
                            |    ЗарплатаТЧ.Ссылка.Валюта.*}
                            |ИТОГИ
                            |    СУММА(СуммаРасход)
                            |ПО
                            |    Касса,
                            |    Валюта,
                            |    СтатяЗатрат
                            |{ИТОГИ ПО
                            |    Касса.*,
                            |    Кому_ОтКого.*,
                            |    СтатяЗатрат.*,
                            |    Валюта.*}
                            |АВТОУПОРЯДОЧИВАНИЕ";
    
                            ПостроительОтчета.Параметры.Вставить("ДатаНачала",НачалоДня(ДатаНачала));
                            ПостроительОтчета.Параметры.Вставить("ДатаКонца",КонецДня(ДатаКонца));
                            ПостроительОтчета.ЗаполнитьНастройки();
                            ПостроительОтчета.ВыбранныеПоля.Очистить();    
                            ПостроительОтчета.ВыбранныеПоля.Добавить("СуммаРасход");
                            ПостроительОтчета.ИзмеренияСтроки.Очистить();
                            Для каждого стрГруппировки Из ПоляГруппировки Цикл
                                Если  стрГруппировки.вкл Тогда
                                    Тип=ТипИзмеренияПостроителяОтчета .Элементы;
                                    если стрГруппировки.ТипИтогов=перечисления.ТипыИтогов.Только_Иерархия тогда
                                        Тип=ТипИзмеренияПостроителяОтчета.ТолькоИерархия;
                                    ИначеЕсли стрГруппировки.ТипИтогов=перечисления.ТипыИтогов.Иерархия тогда
                                        Тип=ТипИзмеренияПостроителяОтчета.Иерархия;
                                    Конецесли;
                                    печСписокГруппировки=печСписокГруппировки+?(печСписокГруппировки="","","/"+символы.ПС)+стрГруппировки.имяГруппировкаАзе;
                                    мСписокГруппировки.Добавить(стрГруппировки.имяГруппировка,стрГруппировки.имяГруппировкаАзе);
                                    ПостроительОтчета.ВыбранныеПоля.Добавить(стрГруппировки.имяГруппировка);
                                    Если стрГруппировки.имяГруппировка<>"Регистратор" Тогда
                                        ПостроительОтчета.ИзмеренияСтроки.Добавить(стрГруппировки.имяГруппировка,,Тип);
                                    Иначе
                                        ПоказатьДетал=Истина;
                                        ПостроительОтчета.ВыбранныеПоля.Добавить("Кому_ОтКого");
                                        ПостроительОтчета.ВыбранныеПоля.Добавить("Комментарий");
                                    КонецЕсли; 
                                КонецЕсли; 
                            КонецЦикла; 
                            
    
    
    Если мСписокГруппировки.Количество()+мСписокВыбранныеПоля.Количество()=0 Тогда
        ОбщегоНазначения.Хебердарлыг("Hesabat üçün heç bir sahə seçilməyib!");
        Возврат;
    КонецЕсли;
    ПечОтбор="";
    СписокТовары=неопределено;
    условиеДляОстаток="";
    строкаОтбор="";
    Для каждого стрМФ Из МФ Цикл
        Если стрМФ.вкл Тогда
            ПечОтбор=ПечОтбор+?(ПечОтбор="","",Символы.ПС)+Символы.Таб+стрМФ.реквизит+"- "+нрег(стрМФ.ТипВыбора)+": "+стрМФ.список;
            отбор=ПостроительОтчета.Отбор.Добавить(стрМФ.имяреквизит);
            отбор.ВидСравнения=?(стрМФ.ТипВыбора="Siyahıya daxil olan",ВидСравнения.ВСпискеПоИерархии,ВидСравнения.НеВСпискеПоИерархии);
            отбор.Использование=Истина;
            отбор.Значение=стрМФ.Список;
        КонецЕсли; 
    КонецЦикла;
   Farid0516
 
2 - 24.11.21 - 09:22
ПрочиеРасходыТЧ.Касса + ЗарплатаТЧ.Касса КАК Касса,


Это неправильный код да? ) Я новичок
   unbred
 
3 - 24.11.21 - 09:24
(2) да
   Farid0516
 
4 - 24.11.21 - 09:30
(3) А что правильно???
   Casey1984
 
5 - 24.11.21 - 09:33
(4) Объединение двух таблиц в запросе нужно, поизучай язык запросов.
   Farid0516
 
6 - 24.11.21 - 09:41
Где я могу научиться? Помогите, пожалуйста
   unbred
 
7 - 24.11.21 - 09:55
(6) гугл, ютуб, жёлтые книги, курсы...начни с ютуба
   Farid0516
 
8 - 24.11.21 - 12:30
Вы можете написать для меня пример модуля Пожалуйста?
   Farid0516
 
9 - 24.11.21 - 13:38
Помогите, пожалуйста
   Homer
 
10 - 24.11.21 - 13:49
Пример кода
...                           
|    ПрочиеРасходыТЧ.Ссылка + ЗарплатаТЧ.Ссылка КАК Регистратор,
|    ПрочиеРасходыТЧ.Заметка + ЗарплатаТЧ.Заметка как Комментарий
|ИЗ
|    Документ.ПрочиеРасходы.ТЧ И Документ.Зарплата.ТЧ КАК ПрочиеРасходыТЧ
...
надо сделать
...
|    ПрочиеРасходыТЧ.Ссылка КАК Регистратор,
|    ПрочиеРасходыТЧ.Заметка как Комментарий
|ИЗ
|    Документ.ПрочиеРасходы.ТЧ КАК ПрочиеРасходыТЧ
|Объединить все
|    ЗарплатаТЧ.Ссылка КАК Регистратор,
|    ЗарплатаТЧ.Заметка как Комментарий
|ИЗ
|    Документ.Зарплата.ТЧ КАК ПрочиеРасходыТЧ
...
   Homer
 
11 - 24.11.21 - 13:50
(10)*
|ИЗ
|    Документ.Зарплата.ТЧ КАК ПрочиеРасходыТЧ
заменит
|ИЗ
|    Документ.Зарплата.ТЧ КАК ЗарплатаТЧ
   Farid0516
 
12 - 24.11.21 - 16:26
Спасибо

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.