Вход | Регистрация
 

Ошибка при вызове метода контекста (ПрочитатьJSON)

Ошибка при вызове метода контекста (ПрочитатьJSON)
Я
   SherifSP
 
22.11.21 - 17:25
Добрый вечер уважаемые, столкнулся с проблемой передачи данных с мобильного приложения в 1с, а именно с ошибкой ПрочитатьJSON, ошибка преобразования данных XDTO, начало свойства Форма:Элемент, Тип:{http://www.w3.org/2001/XMLSchema}anyType.

Собственно сам код:
    ЧтениеJSON = Новый ЧтениеJSON;
    ЧтениеJSON.УстановитьСтроку(Параметр);
    МассивДокументов = СериализаторXDTO.ПрочитатьJSON(ЧтениеJSON); - ошибка на этой строке
    ЧтениеJSON.Закрыть();
    
    ЗаписьДокументовИзМП.ЗагрузитьДанныеСJSON(МассивДокументов);
   ДенисЧ
 
1 - 22.11.21 - 17:26
Покажи начало Josef Stalin Otec Narodov - файла.
   SherifSP
 
2 - 22.11.21 - 17:31
{
"#value": [
null
]
}

сама выборка:
Функция Получитьжесонсзаказами()
    
        ТекстЗапроса = "ВЫБРАТЬ
                   |    ЗаказПокупателя.Ссылка КАК Ссылка
                   |ИЗ
                   |    Документ.ЗаказПокупателя КАК ЗаказПокупателя
                   |ГДЕ
                   |    ЗаказПокупателя.Дата >= &Дата
                   |    И ЗаказПокупателя.ТорговыйПредставитель = &ТорговыйПредставитель";
    
    Запрос = Новый Запрос(ТекстЗапроса);
    Запрос.УстановитьПараметр("Дата", НачалоДня(ТекущаяДата()));
    Запрос.УстановитьПараметр("ТорговыйПредставитель", ПараметрыСеанса.ТекущийПользователь);
    
    Результат = Запрос.Выполнить().Выгрузить();
    
    //Массив документов

    МассивЗначений = Новый Массив;
    
    Для Каждого Строка Из Результат Цикл
        ТекОбъект = Строка.Ссылка.ПолучитьОбъект();
        //элемент с данными одного дока

        СтруктураДокумента = Новый Структура;
        СтруктураДокумента.Вставить("Номер",ТекОбъект.Номер);
        СтруктураДокумента.Вставить("Дата",ТекОбъект.Дата);
        СтруктураДокумента.Вставить("Контрагент",ТекОбъект.Контрагент.Код);
        СтруктураДокумента.Вставить("ТорговаТочка",ТекОбъект.ТорговаяТочка.Код);
        СтруктураДокумента.Вставить("ВидОперации",ТекОбъект.ВидОперации);
        СтруктураДокумента.Вставить("Маркетинг",ТекОбъект.Маркетинг);
        СтруктураДокумента.Вставить("ОтгрузкаПоФакту",ТекОбъект.ОтгрузкаПоФакту);
        СтруктураДокумента.Вставить("Форма2",ТекОбъект.Форма2);
        СтруктураДокумента.Вставить("Форма3",ТекОбъект.Форма3);
        МассивНоменклатуры = Новый Массив;
        Для Каждого СтрокаТЧ Из ТекОбъект.СписокТоваров Цикл
            СтрокаНоменклатуры = Новый Структура;
            СтрокаНоменклатуры.Вставить("Номенклатура",СтрокаТЧ.Номенклатура.Код);
            СтрокаНоменклатуры.Вставить("Цена",СтрокаТЧ.Цена);
            СтрокаНоменклатуры.Вставить("Количество",СтрокаТЧ.Количество);
            СтрокаНоменклатуры.Вставить("Стоимость",СтрокаТЧ.Стоимость);
            МассивНоменклатуры.Добавить(СтрокаНоменклатуры);
        КонецЦикла;
        СтруктураДокумента.Вставить("СписокТоваров", МассивНоменклатуры);
        МассивТары = Новый Массив;
        Для Каждого СтрокаТЧ Из ТекОбъект.Тара Цикл
            СтрокаТары = Новый Структура;
            СтрокаТары.Вставить("Номенклатура",СтрокаТЧ.Номенклатура.Код);
            СтрокаТары.Вставить("Количество",СтрокаТЧ.Количество);
            СтрокаТары.Вставить("Цена",СтрокаТЧ.Цена);
            СтрокаТары.Вставить("Сумма",СтрокаТЧ.Сумма);
            МассивТары.Добавить(СтрокаТары);
        КонецЦикла;
        СтруктураДокумента.Вставить("Тара", МассивТары);
        МассивЗначений.Добавить();
    КонецЦикла;
    
    ЗаписьJSON = Новый ЗаписьJSON;
    ЗаписьJSON.УстановитьСтроку();
    СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON, МассивЗначений, НазначениеТипаXML.Неявное);    
    ПараметрЗапроса = ЗаписьJSON.Закрыть();
    
    Возврат ПараметрЗапроса;
    
КонецФункции
   Armando
 
Модератор
4 - 22.11.21 - 22:35
SherifSP скрыл твоё сообщение. Не указывай IP адреса своих серверов.
   Ненавижу 1С
 
5 - 22.11.21 - 22:42
МассивЗначений.Добавить()

Наверное аргумент пропустил

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.