Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

нужен оброботка файл Копирование группы Контрагенты с иерархией вложенных элементов

нужен оброботка файл Копирование группы Контрагенты с иерархией вложенных элементов
Я
   Farid0516
 
21.11.21 - 18:36
нужен оброботка файл Копирование группы Контрагенты с иерархией вложенных элементов
1С:Предприятие 8.3 (8.3.3.687)
   ДенисЧ
 
1 - 21.11.21 - 18:38
100500 рублей.
   Farid0516
 
2 - 21.11.21 - 18:43
100499 можна?
   ДенисЧ
 
3 - 21.11.21 - 18:45
(2) Только 100511.
Ещё поторгуемся? )))
   Farid0516
 
4 - 21.11.21 - 19:01
Нет. Срочно нада )
   ДенисЧ
 
5 - 21.11.21 - 19:03
За полчаса можно уже было набросать первый шаблон и задавать конкретные вопросы )))
   Farid0516
 
6 - 21.11.21 - 19:07
Это отличный ответ. Действительно.
   Farid0516
 
7 - 21.11.21 - 19:09
Как создать обработка файл? Какая программа мне нужна?
   ReaLg
 
8 - 21.11.21 - 19:12
(7) Улыбнуло :) 1C. Конфигуратор. Но, как бы, там нет голосового помощника, который по запросу "нужен оброботка файл Копирование группы Контрагенты с иерархией вложенных элементов" создаст необходимую обработку. Если Вы не знаете, как создаются обработки, то прям "срочно" вряд ли сможете написать.
   Amra
 
9 - 21.11.21 - 19:43
(8) Да ладно, на Мисте зареган - можно идти ЕРП внедрять, по 4500 в час))
   Злопчинский
 
10 - 21.11.21 - 19:48
(0) а подчиненные/зависимые справочники - с ними что при копировании делать?
   Вася Теркин
 
11 - 21.11.21 - 20:00
(0) Тебе надо КД 2. До утра сможешь разобраться и все сделать. Ютуб в помощь. И подчиненные справочники туда же...
   серый КТУЛХУ
 
12 - 21.11.21 - 20:01
танунафиг даже конфигуратор не нужен.
"конвертация данных 2.1" + обработка "Универсальный обмен данными в формате XML"
1) в "конвертации" пишем правила обмена и выгружаем их в файл правил обмена
2) база-источник: запускаем обработку, натравливаем на файл правил обмена (см.п.1), выгружаем в xml-файл
3) база-приемник: запускаем обработку, натравливаем на xml-файл (см.п.2), загружаем.
   ReaLg
 
13 - 21.11.21 - 20:05
(9) Да, иногда я тоже так думаю :)
   ReaLg
 
14 - 21.11.21 - 20:09
(11)(12) Не факт, что речь про перенос данных из одной базы в другую. Я это понял как то, что человеку зачем-то нужна копия группы в контрагентах с иерархией(то-ли только папки, то ли и элементы). Но я этот вывод сделал на основании слов "копировать" и "обработка". Мой семантический анализатор не заменил их на "перенос данных" :)
   Ёпрст
 
15 - 21.11.21 - 20:47
Да-да -да..дайте ТС какую-нить г..поделку, потом будет тема про 6000000 вложенных групп..
:)
   acht
 
16 - 21.11.21 - 20:57
TL;DR
dubolom Kalimulin yine eğleniyor mu?
   Farid0516
 
17 - 22.11.21 - 14:26
Процедура ПриКопировании(РодительКопирования)
    Выборка = Справочники.Контрагенты.ВыбратьИерархически();
Пока Выборка.Следующий() Цикл
    Если Выборка.ЭтоГруппа тогда
        НоваяГруппа = Справочники.Контрагенты.СоздатьГруппу();
        НоваяГруппа.Код = "";
        НоваяГруппа.Наименование = Выборка.Наименование;
    Иначе
        НовыйЭлемент = Справочники.Контрагенты.СоздатьЭлемент();
        НовыйЭлемент.Код = "";
        НовыйЭлемент.Наименование = Выборка.Наименование;
        НовыйЭлемент.Записать();
    КонецЕсли;
КонецЦикла; 
  КонецПроцедуры
   dubolom
 
18 - 22.11.21 - 14:30
(17) Где использование РодительКопирования? (В отборе выборки, что логично).
Не учтено, что при копировании нужно и иерархичность копировать (копия родителя элемента должна быть родителем копии элемента).
   Farid0516
 
19 - 22.11.21 - 14:30
Когда я нажимаю кнопку «Копировать», я хочу, чтобы она копировала элементы и папки в папке, которую я щелкнул.
Простите за мой русский. Буду рад, если вы мне поможете.
   УдавВПопугаях
 
20 - 22.11.21 - 14:31
(14) +1
(17) и что конкретно не получилось? там еще много чего (возможно) надо проставить, кроме кода и наименования
   УдавВПопугаях
 
21 - 22.11.21 - 14:32
кнопка копировать стандартная с плюсиком или своя?
   Farid0516
 
22 - 22.11.21 - 14:32
стандартная
   Farid0516
 
23 - 22.11.21 - 14:33
копирование сработало. но он скопировал все элементы, а не только выбранную мной папку, и не выгружал элемент в папку
   УдавВПопугаях
 
24 - 22.11.21 - 14:34
(22) не пойдет, сделай свою, стандартная кнопка для стандартного копирования
   dubolom
 
25 - 22.11.21 - 14:34
(23) Так у тебя ВыбратьИерархически без отбора и значение Родитель не копируется. (18)
   dubolom
 
26 - 22.11.21 - 14:35
(24) Ему же надо механизм в дополнение к стандартному
   dubolom
 
27 - 22.11.21 - 14:35
(25) И после создания группы Записать нет.
   Галахад
 
28 - 22.11.21 - 14:37
(27) А если Esc?
   УдавВПопугаях
 
29 - 22.11.21 - 14:47
(26)я бы не стал путать стандартный с своими фантазиями, либо стандартное поведение надо отключить, а стнадартнойобработки там нет. стандартное поведение не записывает копируемый объект, только по кнопке ОК, поэтому "вохмоэного" родителя на момент создания/записи всей иерархии еще не будет
   УдавВПопугаях
 
30 - 22.11.21 - 14:48
"возможного"
 
 
   УдавВПопугаях
 
31 - 22.11.21 - 14:57
Не получится, в ПриКопировании нет нового объекта, РодительКопирования - объект с которого копируется, а не новый, который копируется. Он появится только вместе с формой нового элемента/группы. Создать программно свою новую ссылку, заполнить всю иерархию и тд можно, но от появления стандартного окна нового элемента похоже не избавиться. Так что сделай свою кнопку, постановщику задачи скажи что нибудь интересное.
пс. я смотрел на ОФ, может конечно в УФ что то по другому происходит
   Галахад
 
32 - 22.11.21 - 15:03
Можно попробовать скопировать иерархию после записи, опираясь на доп свойства, заполненные при копировании.
   УдавВПопугаях
 
33 - 22.11.21 - 15:04
можно, но будет сложно для тс да и спалится на задании
   Farid0516
 
34 - 22.11.21 - 16:04
mne nada tolko 1 raz. 1 papka est i papka est 5000+ kontragent. xo4y kopirovat eto papka
   УдавВПопугаях
 
35 - 22.11.21 - 16:18
тогда не надо это лепить в ПриКопировании, обработка, в ней кнопка, на ней этот код + все советы dubolom с (18)
   УдавВПопугаях
 
36 - 22.11.21 - 16:21
правда будут еще тонкости с иерархией и определением нужного родителя
   mistеr
 
37 - 22.11.21 - 18:58
Уже почти 50 и еще никто не спросил "зачем"? И не сказал "тебе это не надо"? Непорядок!


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.