Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Доработка кода ввода на основании

Доработка кода ввода на основании
Я
   anton54575
 
20.11.21 - 00:37
Привет всем!

Создаю обработку в СчетНаОплатуПоставщика

После("ОбработкаЗаполнения")
Процедура ЕВ_ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    Если ТипЗнч(ДанныеЗаполнения) = Тип("Структура") Тогда
        Если ДанныеЗаполнения.Свойство("Основание") Тогда
            Если ТипЗнч(ДанныеЗаполнения.Основание) = Тип("ДокументСсылка.СчетНаОплатуПокупателю") Тогда
                ЗаполнитьПоСчетуПокупателю(ДанныеЗаполнения.Основание);
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;

Попадают значения заимствованной формы СчетНаОплатуПокупателя - Контрагент и номер

Хотелось бы что бы на основании проставлялся реквизит СрокОплаты

Как реализовать?
   palsergeich
 
1 - 20.11.21 - 00:55
(0) Читаешь код процедурв ЗаполнитьПоСчетуПокупателю и думаешь как модифицировать.
Все просто

Список тем форума
 
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.