Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка аппарата ККМ

Ошибка аппарата ККМ
Я
   Фоксик
 
19.11.21 - 17:34
7d1h чек открыт - операция невозможна
   Фоксик
 
1 - 19.11.21 - 17:35
Всем привет, кто нибудь сталкивался с такой ошибкой ККМ?
   vovastar
 
2 - 19.11.21 - 18:00
(1) Здравствуйте. а что за аппарат? и где ошибка?
   Базис
 
3 - 19.11.21 - 18:03
Закрыть чек, закрыть смену.
   vovastar
 
4 - 19.11.21 - 18:07
(3) так операция же невозможна...
   Базис
 
5 - 19.11.21 - 18:24
Закрыть обычно можно.  Если не из 1С, так из программы или драйвера ККМ. Тут обычно забывают, что оборудование монопольно блокируется и нужно только одним инструментом работать с ККМ.
   GlRoznica
 
6 - 19.11.21 - 18:25
(5) что гадать, если неизвестно что вообще за аппарат?
   Garykom
 
7 - 19.11.21 - 18:36
выключить и включить из розетки
   big
 
8 - 19.11.21 - 21:00
Если чек открыт, то его можно отменить. 
Вот, применительно к Атолу
    Если Объект.СостояниеЧека <> 0 Тогда
        Объект.ОтменаЧека();
        Если Объект.Результат <> 0 Тогда
            Результат = "Ошибка::: "+Объект.ОписаниеРезультата;
            Сообщить("Неудачная попытка отмены чека");
            Возврат;
        КонецЕсли;
    КонецЕсли;
    
    Объект.ВыходИзРежима();
    Если Объект.Результат <> 0 Тогда
        Результат = "Ошибка::: "+Объект.ОписаниеРезультата;
        Сообщить("Неудачная попытка выйти из режима");
        Возврат;
    КонецЕсли;
    
    Объект.Пароль=30;
    Объект.Режим=0;
    Объект.УстановитьРежим();
   Фоксик
 
9 - 29.11.21 - 11:48
(2) Рр-01ф
   Михалай
 
10 - 29.11.21 - 12:31
(9) Закрыть 1С, запустить тест драйвера и из него закрыть чек. А потом вникать, почему он не закрылся штатно.
   ДедМорроз
 
11 - 29.11.21 - 14:03
Через драйвер,сначала пробовать отменить,а потом,если отмена невозможна,то закрыть.

Почему-то,1с разучилась отменять чеки после того,как перешла на отправку xml чека.

Список тем форума
 
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.