Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Зарелизили Комплексная автоматизация 2.5

Зарелизили Комплексная автоматизация 2.5
Я
   Topol-M
 
29.10.21 - 18:04
Сегодня перевели из тестовой в рабочую
2.5.7.226
Просто для информации
   Волшебник
 
Модератор
1 - 29.10.21 - 18:11
Держите нас в курсе.
   lubitelxml
 
2 - 29.10.21 - 18:21
через пол года можно будет обновлять, а то и через год на 2.5
   Mikhail Volkov
 
3 - 29.10.21 - 18:21
А дальше будут обновления КА 2.4, есть кто в курсе? УП ERP сейчас поддерживают обе версии 2.4 и 2.5. Хотелось бы услышать здесь мнения знатоков: стоит обновляться на 2.5?
   lubitelxml
 
4 - 29.10.21 - 18:22
(3) рановато, минимум после НГ, только первый релиз вышел, ошибки если хотите ловить - обновляйте
   lubitelxml
 
5 - 29.10.21 - 18:23
я вообще буду переходить когда 2.4 больше не будет обновляться
   Topol-M
 
6 - 29.10.21 - 18:23
(3) с оф. сайта

Уважаемые пользователи!
Релизы (три цифры номера) поддерживаются или до выхода следующего релиза той же подредакции (вторая цифра номера), или до окончания поддержки подредакции.
Сроки поддержки подредакций назначаются индивидуально.

Пока по 2.4 сроков прекращения и любых других сроков нигде не увидел.
   Garykom
 
7 - 29.10.21 - 18:28
(0) Наконец то!

УТ11 интересно когда
   lubitelxml
 
8 - 29.10.21 - 18:29
(7) что же там такого, что "Наконец то!"?
   Garykom
 
9 - 29.10.21 - 18:29
(8) ЗУП 3.1.18
   Garykom
 
10 - 29.10.21 - 18:31
(9)+ Только у нас ЗУП слегка вперед
В КА 2.5.7.226 либы ЗУП 3.1.18.217
А я ЗУП уже обновил до 3.1.18.246 хз можно ли типовым переносом с ЗУП на КА перейти
   kubik_live
 
11 - 29.10.21 - 19:50
(10) А в планируемых ЗУП 3.1.19 в вообще нет. Только 3.1.18 и 3.1.20
   Mikhail Volkov
 
12 - 30.10.21 - 07:16
(5) Что так, боязно, или есть определенные причины?
(6) Значит сообщат, а пока обе версии будут поддерживаться...
В УП ERP сейчас так же, поддерживают обе версии 2.4 и 2.5. Хотелось бы услышать здесь мнения знатоков на этот счет: что лучше 2.4 и 2.5?
   pechkin
 
13 - 30.10.21 - 09:30
(8) просто от ерп уже полгода назад зарелизилась
   Krendel
 
14 - 30.10.21 - 10:34
(12) в 2.5 новое ценообрвзование, дальнейшее упрощение работы с направлениями деятельности. В 2.5.7 новое резервирование
   Krendel
 
15 - 30.10.21 - 10:36
В 2.5.8 должны убрать маршрутные карты, будет интересно- сделали настройку для расчета себеса по тех операциям, это будет пушка тогда.
   RAJAH
 
16 - 30.10.21 - 11:29
(15) Маршрутные карты убраны уже в 2.5.7.
(12) > Хотелось бы услышать здесь мнения знатоков на этот счет: что лучше 2.4 и 2.5?
Честно говоря, ERP с версии 2.5 - это какой-то ужас: система стала прожорливой и требовательной, как к памяти (процесс закрытия месяца вылетал из-за нехватки), так и к занимаемому месту. Причём растёт не только сама база (у нас за год после установки 2.5 выросла со 100 до 700 Гб), но и tempdb (при закрытии до 550 Гб распухала). Закрытие месяца теперь проходит в разы дольше - сутки практически (раньше за ночь успевали).
   pechkin
 
17 - 30.10.21 - 14:18
(16) какая операция самая длинная в закрытии? там есть статистика по расчету себестоимости
   hhhh
 
18 - 30.10.21 - 14:39
в общем, ждем УТ 11.5. Пока даже в УТ проблемы не могут решить. переходить не имеет смысла.
(11) текущая зуп 3.1.19.80, вы там неизвестно где витаете.
   pechkin
 
19 - 30.10.21 - 17:46
В ерп только лтс зуп вставляют
   kubik_live
 
20 - 30.10.21 - 18:48
(18) Речь об обновлениях а не о текущей версии 3.1.19.80: Смотрите планы выхода: там про 3.1.19 обновления ничего...
   volfy
 
21 - 30.10.21 - 19:13
(3) это до 2 квартала, потом 2.4 в топку
   kauksi
 
22 - 30.10.21 - 19:46
(16) озвучьте параметры железа плиз. какие и скока процов на сервере БД, скока памяти под скуль, какие диски?
   RAJAH
 
23 - 31.10.21 - 01:10
(22) Не помню. Да, в принципе, это неважно: 2.4 шевелилась бодрее на том же железе, а для 2.5 пришлось докупить диски и память (вот оперативку знаю, что удвоили - до 256 Гб).
   Mikhail Volkov
 
24 - 31.10.21 - 07:12
(16) Серьезный аргумент.
   kauksi
 
25 - 31.10.21 - 18:40
(23) без параметров железа/версий софта/настроек такие утверждения сходны тому что на 7ке в 2009 все летало, а на 10ке в 2021м тормоза...
   Bukasoid
 
26 - 02.11.21 - 10:10
(3) По ERP сказано, что редакция 2.4 будет поддерживаться по апрель 2022 года, включая сдачу отчетности за первый квартал. По КА, скорее всего, ситуация будет аналогичная
   Garykom
 
27 - 02.11.21 - 10:13
(26) А судя по тому что УТ 11.5 до сих пор нет релиза что?
   Garykom
 
28 - 02.11.21 - 10:14
И да в новой КА 2.5.7.226 сча аж 66 расширений-патчей

Они там уху ели?
   Mikhail Volkov
 
29 - 02.11.21 - 10:27
Не могу правила обмена с УПП получить. Макет из tmplts\1c\ARAutomation20\2_5_7_226\AddFiles\Переходы с других конфигураций\УПП_КА1 сохранил в файл ПравилаОбменаУПП_КА1_ERP2_5_7_33.xml. Пытаюсь его загрузить в КД2, ошибка:
{Обработка.ЗагрузкаКонвертации.МодульОбъекта(2755)}: Ошибка при вызове метода контекста (Записать)
        НовыйПараметр.Записать();
по причине:
Значение поля "Код" не уникально
Как исправить?
   HeKrendel
 
30 - 02.11.21 - 10:30
(28) У тебя 2 франча ;-) Переживешь
 
 
   Mikhail Volkov
 
31 - 02.11.21 - 11:03
(26) А переходные на 2.5 новые конфигурации 2.4 надеюсь будут?
   Mikhail Volkov
 
32 - 05.11.21 - 16:40
(29) Там в макете дважды строка:
        <Параметр Имя="УчетПартийТолькоБУ" Наименование="УчетПартийТолькоБУ" ИспользуетсяПриЗагрузке="false" УстанавливатьВДиалоге="false" ТипЗначения="Булево" ПередаватьПараметрПриВыгрузке="false"/>
   Garykom
 
33 - 05.11.21 - 19:13
   RomanYS
 
34 - 05.11.21 - 19:28
(33) никогда не было и вот... опять. Такое могло быть с любой конфигурацией))
   Garykom
 
35 - 05.11.21 - 19:29
(34) Я для выгрузки устал правила править
А оно еще и не загружается, сначала про дубли ошибку написало, исправил а теперь вот это
   Garykom
 
36 - 05.11.21 - 19:32
И да качество типовых конфигураций от 1С опустилось ниже плинтуса!
Ошибка на ошибке и ошибкой погоняет.

>60 расширений-патчей для новой КА 2.5.7.226 сразу после выхода это пипипи

Мне кажется они там даже не тестируют уже, просто тупо "релизы" собирают и все
   DexterMorgan
 
37 - 05.11.21 - 20:36
Все не читал, про свободные остатки уже было?
   acanta
 
38 - 05.11.21 - 21:05
Еще раз, если можно. Через точку получает весь объект со всеми табличными частями. А получитьреквизит("имя реквизита")? Там нет второго параметра?
Например Чтото.получитьреквизит("имя реквизита",?(истина-с объектом, ложь-без обьекта)). А вдруг...
   Mikhail Volkov
 
39 - 06.11.21 - 05:30
(35) У нас пока в КА2 не работают, пробный вариант. З/п считают в КА1 (УПП). Ее перенести в КА2 возможно за предыдущие годы, месяца?
   ДенисЧ
 
40 - 06.11.21 - 05:34
(38) У кого ты собралась получить реквизит, если нет объект?
   acanta
 
41 - 06.11.21 - 06:39
(40) например, добавить колонку в справочнике номенклатура и вывести туда тмц.видноменклатуры.код?
   RomanYS
 
42 - 06.11.21 - 11:42
(39) Это эквивалентно переносу из ЗУП2.5 в ЗУП3.0, так что должно быть решено в каком-то объеме
   Garykom
 
43 - 06.11.21 - 12:00
(42) угу с дикими тормозами и кучей ошибок
   RomanYS
 
44 - 06.11.21 - 12:09
(43) Это ожидаемо... когда стопалась поддержка 2.5 и был массовый переход возможно ошибок было чуть меньше. Сейчас 3.0 уже несколько подредакций сменила, а за правилами возможно никто не следит...
   Garykom
 
45 - 06.11.21 - 12:30
(44) Даже перенос из ЗУП 3.1 в ERP/КА 2.5 типовой глючный.
Правила кривые куча "Удалить..." или забыли значения перечислений и т.д.

Но это ладно с этим я разобрался.
Но потом напоролся на прикольный глюк платформы 1С в файловой.
Короче при выгрузке получается довольно большой zip архив в 2 гига (внутри xml на 8 гигов).
И вот когда этот архив передается на файловой 1С через хранилище клиент-сервер и обратно он побивается.
Так что тот же 7z при тесте ошибку пишет.
А код загрузки перед распаковкой типа архив zip проверяет а по факту нет и получаем (33).

Офигел когда разобрался почему оно падает, там еще фоновым осложнено что очень смешно выглядит когда оно падает.
   Krendel
 
46 - 06.11.21 - 13:32
(45) а нафига переносить?
   Garykom
 
47 - 06.11.21 - 13:36
(46) И как?
Неужели предлагаешь базу ЗУП 3.1 снять с замка и поверх накатить КА 2.5 ?
   Krendel
 
48 - 06.11.21 - 13:41
(47) предлагаю оставить зуп отдельно, и обмениватся в одну сторону кпи, в другую затратами
   Garykom
 
49 - 06.11.21 - 13:43
(48) Не пойдет - ЗУП уже отдали в зачет апгрейда на КА
   Фрэнки
 
50 - 06.11.21 - 13:44
(49) ну и ССЗБ
   Krendel
 
51 - 06.11.21 - 13:45
(49) это 12 к, экономные
   Фрэнки
 
52 - 06.11.21 - 13:46
Например, я сейчас наоборот агитирую своего заказчика за покупку и установку ЗУП отдельно от КА, а твои взяли и похерили то, что у них уже было :-)
   Garykom
 
53 - 06.11.21 - 14:07
(52) Зачем? Чтобы потом за разгребание косяков обмена рубить постоянно $ ?
   Amra
 
54 - 06.11.21 - 14:08
(49) Купив КА вы имеете право использования отдельного ЗУПа, равно как и БП и УТ
   Garykom
 
55 - 06.11.21 - 14:09
(54) можно пруф?
   Krendel
 
56 - 06.11.21 - 14:10
(54) Эта тема была доступна на КА 1, вроде по КА 2 ее убирали
   Krendel
 
57 - 06.11.21 - 14:14
Но это не точно
   Amra
 
58 - 06.11.21 - 14:14
(56) КА 1 и КА 2 это один продукт, как для одного есть, а для другого нет?
   Amra
 
59 - 06.11.21 - 14:16
(55) Надо искать. Зайди на портал ИТС под вашей учеткой, посмотри какие конфигурации доступны
   RomanYS
 
60 - 06.11.21 - 14:21
На 2015 год ещё можно было (уже КА2 была)
https://1c.ru/news/info.jsp?id=20538

Но мне почему-то тоже кажется что эту "лазейку" прикрывали
 
 
   Garykom
 
61 - 06.11.21 - 14:25
(59) ЗУП 3.1 пока доступна но ЗУП 2.5 нет
Срок на переход вроде 3 месяца

Мы например Документооборот с ПРОФ на КОРП перешли, сдав ПРОФ так он больше не доступен, только КОРП остался
   Amra
 
62 - 06.11.21 - 14:29
(61) ЗУПа 2.5 там давно нет, даже у франчей. Поэтому не страдайте фигней, пользуйте ЗУП дальше
   Фрэнки
 
63 - 06.11.21 - 14:38
(53) затем, что разгребание косяков в зарплатной подсистеме КА оказывается намного более трудемким, чем сделать тоже самое в ЗУП.
Тут даже не вопрос заработка, а вопрос своевременного решения вопросов в части регламентированного учета, которые все равно возникают в процессе работы.

Как вариант, компромисное решение в том, чтобы разделить базу РИБ-ом на два узла с разной функциональностью и возможностью дообновления ЗУП-овского узла с гораздо более выской частотой, чем готов разрешить Заказчик на фоне работающей подсистемы Производства, Казначейства и т.п.
   Фрэнки
 
64 - 06.11.21 - 14:54
СОСТАВ ПРОДУКТА 1С:КОМПЛЕКСНАЯ АВТОМАТИЗАЦИЯ 8. РЕДАКЦИЯ 2 (1С:КА)
 

В состав программного продукта входят необходимые лицензии и дистрибутивы платформы 1С:Предприятие 8.3 и конфигурации "1С:Комплексная автоматизация 8. Редакция 2".

Кроме того в поставку продуктов входят следующие прикладные решения:

"1С:Управление торговлей", редакция 11.4.
"Зарплата и управление персоналом", редакция 3.1;
"Бухгалтерия предприятия ПРОФ", редакция 3.0;
В поставку также включена документация по платформе "1С:Предприятие 8.3" и соответствующим прикладным решениям:

1С:Предприятие 8. Конфигурация "Комплексная автоматизация". Редакция 2.0. Описание (в трех частях);
1С:Предприятие 8.3. Руководство администратора;
1С:Предприятие 8.3. Руководство разработчика (в двух частях);
1С:Предприятие 8.3. Руководство пользователя;
1С:Предприятие 8.3. Клиент-серверный вариант. Руководство администратора (в варианте поставки с сервером 1С:Предприятие).
В продукт "1С:Комплексная автоматизация для 10 пользователей + клиент-сервер (x86-64)" включена лицензия на 32/64-разрядный сервер "1С:Предприятия 8.3", а также клиентская лицензия "1С:Предприятия 8" на 10 рабочих мест.

---
это самый низ страницы https://www.ka4you.ru/index/kupit_1s_kompleksnaja_avtomatizacija_2/0-4
з.ы. пытался найти на еще более официальном ресурсе, но не нашел. Хотя раньше такое было.
   RomanYS
 
65 - 06.11.21 - 15:00
(64) в (60) же официальное письмо
   Фрэнки
 
66 - 06.11.21 - 15:03
(65) я вижу. Просто это в более обновленном варианте
   Garykom
 
67 - 06.11.21 - 16:05
(62) КА 1.0 и КА 1.1 есть
   Mikhail Volkov
 
68 - 06.11.21 - 17:16
(42) Макет ПравилаОбменаЗУП (Правила обмена ЗУП 2.5 -> ЗУП 3.1 из поставки БЗКР) брать из tmplts\1c\ARAutomation20\2_5_7_226\AddFiles\Переходы с других конфигураций\УПП_КА1\Выгрузка данных.epf, сохранять в файл ПравилаОбменаЗУП_КА2_5_7_226.xml? Затем загрузить его в КД2, получить конвертацию: ЗУП --> УП (2.5.130, 2.5.7, v.1)?
Она как, полностью перенесет зарплатные документы КА1 (УПП) в КА2, или только остатки (как из макета ПравилаОбменаУПП)?
   Фрэнки
 
69 - 06.11.21 - 17:52
(68) имхо, не будет полного переноса. Как нет переноса из 2.5 в 3.1, так и из КА1 в КА2 переноса документов не должно быть, а будет перезаливка остатков.
   Mikhail Volkov
 
70 - 07.11.21 - 07:16
(69) Да, для переноса документов сам дописывал правила, но зарплатные не трогал. Значит по ним тоже самое...
   Mikhail Volkov
 
71 - 10.11.21 - 12:44
Значит лучше из ЗУП 3.1 брать, а не из КА2/ERP?

Еще вопрос: В КА2.4 в документе Корректировка приобретения есть реквизиты Курс и Кратность. В КА2.5 вместо них Курс числитель и Курс знаменатель. Это просто переименование реквизитов, или как?
   Mikhail Volkov
 
72 - 11.11.21 - 18:21
Из макета tmplts\1c\ARAutomation20\2_5_7_226\AddFiles\Переходы с других конфигураций\УПП_КА1\Выгрузка данных.epf загрузил в КД2 правила УПП1.3.147 --> УправлениеПредприятием 2_5. В них в Справочники/Классификаторы добавили Справочник_СтавкиНДС. Его перенес в свои правила с дописанными для документов на вкладку Правила конвертации объектов. Теперь из УПП выгружаю нормально, а при загрузке в КА2.5 пишет: Ошибка при загрузке данных: Тип не определен (СправочникСсылка.СтавкиНДС)...
Куда его Справочник_СтавкиНДС еще занести в КД2?
   Mikhail Volkov
 
73 - 12.11.21 - 09:14
Вроде сделал удаление помеченных на удаление, эта ошибка пропала! Но вывались куча новых...
   Mikhail Volkov
 
74 - 12.11.21 - 15:22
Например: Действия с объектом временно запрещены, так как не завершен переход на новую версию программы.
Это плановый процесс, который скоро завершится.
Остались следующие процедуры обработки данных:
РегистрыСведений.ПорядокОтраженияНаСчетахУчета.ОбработатьДанныеДляПереходаНаНовуюВерсию...
Из всех перечисленных одна осталась: Не удалось выполнить обработчик обновления "РегистрыСведений.СуммыДокументовВВалютахУчета.ОбработатьДанныеДляПереходаНаНовуюВерсию". Подробнее в журнале регистрации.
Думаю, как искать причину?
   Mikhail Volkov
 
75 - 13.11.21 - 07:21
Результаты обновления программы: Выполнено 453 из 454. В Дополнительных процедурах обработки нахожу процедуру с ошибкой: Заполняет реквизит "Ставка НДС", заполняет другие служебные реквизиты. Ошибка: Процедура "РегистрыСведений.СуммыДокументовВВалютахУчета.ОбработатьДанныеДляПереходаНаНовуюВерсию" обработки данных завершилась с ошибкой: Произошло зацикливание процедуры обработки данных. Выполнение прервано.
Открываю РегистрыСведений.СуммыДокументовВВалютахУчета, там строки документов табличных частей Товары, в которых есть суммы НДС. На каком документе произошло зацикливание, как узнать?
   Фрэнки
 
76 - 13.11.21 - 09:13
(75) не глядя в код, чисто интуитивно предположу, что там результаты выборки есть, которые обрабатываются и эти результаты все таки упорядочены по времени.
Чтобы это проверить, можно посмотреть на список движений - ранние документы все обработаны или попадаются среди них необработанные?
Если преположение верное, то последний документ из этого списка и будет сбойным. Или следующий за последним.
   Фрэнки
 
77 - 13.11.21 - 09:15
Более долгий путь - найти место формирования текста сообщения и посмотреть рядом с ним - возможно там есть данные о текущем документе или текущей записи, но это не догадались вывести в текст сообщения.
   Mikhail Volkov
 
78 - 13.11.21 - 11:43
В процедуре РегистрыСведений.СуммыДокументовВВалютахУчета.ОбработатьДанныеДляПереходаНаНовуюВерсию(Параметры) поставил точку останова. В ней выполняется цикл, внутри Попытка, которая прекращается на выполнении ОбновлениеИнформационнойБазы.ЗаписатьНаборЗаписей(НаборЗаписей); точнее на НаборЗаписей.Записать(Замещать); с записью ЖР предупреждения:
Не удалось записать данные в регистр РегистрСведений.СуммыДокументовВВалютахУчета по регистратору "Приобретение товаров и услуг ТИП-0001083 от 30.10.2021 19:00:43", по причине: Запись с такими ключевыми полями существует! : СуммыДокументовВВалютахУчета: 30.10.2021 19:00:43, Приобретение товаров и услуг ТИП-0001083 от 30.10.2021 19:00:43,  (Регистр сведений: Суммы документов в валюте регл. учета; Номер строки: 2)
{ОбщийМодуль.ОбновлениеИнформационнойБазы.Модуль(112)}:    НаборЗаписей.Записать(Замещать);
{РегистрСведений.СуммыДокументовВВалютахУчета.МодульМенеджера(2844)}:                ОбновлениеИнформационнойБазы.ЗаписатьНаборЗаписей(НаборЗаписей);
{(1)}:РегистрыСведений.СуммыДокументовВВалютахУчета.ОбработатьДанныеДляПереходаНаНовуюВерсию(Параметры[0])
{ОбщийМодуль.ОбщегоНазначения.Модуль(5263)}:    Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(4130)}:        ОбщегоНазначения.ВыполнитьМетодКонфигурации(КонтекстОбработчика.ИмяОбработчика, ПараметрыВызова);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(7349)}:                        ВыполнитьОтложенныйОбработчик(КонтекстОбработчика, АдресРезультата);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(527)}:        ОбработчикиВыполнялись = ВыполнитьОтложенныйОбработчикОбновления(ПараметрыОбновления);
{Обработка.РезультатыОбновленияПрограммы.Форма.ИндикацияХодаОтложенногоОбновленияИБ.Форма(403)}:    ОбновлениеИнформационнойБазыСлужебный.ВыполнитьОтложенноеОбновлениеСейчас(Неопределено);

по причине:
Запись с такими ключевыми полями существует! : СуммыДокументовВВалютахУчета: 30.10.2021 19:00:43, Приобретение товаров и услуг ТИП-0001083 от 30.10.2021 19:00:43,  (Регистр сведений: Суммы документов в валюте регл. учета; Номер строки: 2)

Но почему? Замещать = Истина - перед записью существующие записи будут удалены. Ошибки не должно быть!
И почему зацикливание? В ЖР таких ошибок с документом Приобретение товаров и услуг ТИП-0001083 от 30.10.2021 19:00:43 (и Номер строки: 2) 23 подряд? Хотя в этом документе всего 6 строк. Документ вроде нормальный, пробовал перепровести, не дает.
   Доминошник
 
79 - 13.11.21 - 13:08
(78) А если не перепровести, а отменить проведение, а потом уже провести?

Подобного плана была ошибка в ERP 2.5.7.226 (Другой регистр, но такая же ошибка по заказу клиента). Помогло именно это (распровести, а потом уже - провести).
   Mikhail Volkov
 
80 - 13.11.21 - 13:45
(79) Ничего не позволяет делать: Действия с объектом временно запрещены, так как не завершен переход на новую версию программы. Если только до перехода на 2.5 в версии 2.4.
Заметил, что в документах где -то с апреля 2019 табличной частью Товары, в которых НДС > 0, неправильно установлен НалогообложениеНДС в Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС. Документы загружены из УПП, в правилах было прописано: Объект.НалогообложениеНДС = Справочники.Организации.НалогообложениеНДС(Объект.Организация, Неопределено, ТекущаяДата()); Эта функция устарела, в 2.5 ее нет. Теперь заменил на: Объект.НалогообложениеНДС = ?(Объект.Товары.Итог("СуммаНДС") = 0, Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС, Перечисления.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС); Может из-за этого?
Перезагружать из УПП много, хочу написать обработку по замене НалогообложениеНДС, в документах: ПриобретениеТоваровУслуг, КорректировкаПриобретения, РеализацияТоваровУслуг, КорректировкаРеализации, ОтчетОРозничныхПродажах, ВозвратТоваровПоставщику,  ВозвратТоваровОтКлиента, и других, где есть НДС и НалогообложениеНДС. Как получить список всех типов документов?
   Mikhail Volkov
 
81 - 13.11.21 - 14:00
   Mikhail Volkov
 
82 - 14.11.21 - 12:16
А что в КА2/ERP нет функции ЕстьРеквизитТабЧастиДокумента(ИмяРеквизита, МетаданныеДокумента, ИмяТабЧасти)? Хотелось бы в обработке (80) проверить все документы с НДС.
   Mikhail Volkov
 
83 - 14.11.21 - 14:59
Вроде нашел ОбщегоНазначенияУТ.ЕстьРеквизитТабЧастиОбъекта("СуммаНДС", МетаданныеДокумента, "Товары")
   Mikhail Volkov
 
84 - 15.11.21 - 06:48
Написал обработку (80):
&НаКлиенте
Процедура ИсправитьНалогообложениеНДС(Команда)
    ВыполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВыполнитьНаСервере()
    Для каждого МетаданныеДокумента Из Метаданные.Документы Цикл
        Если Не (ОбщегоНазначения.ЕстьРеквизитОбъекта("НалогообложениеНДС", МетаданныеДокумента)
            И ОбщегоНазначенияУТ.ЕстьРеквизитТабЧастиОбъекта("СуммаНДС", МетаданныеДокумента, "Товары")) Тогда
            Продолжить;
        КонецЕсли;
        Выборка = Документы[МетаданныеДокумента.Имя].Выбрать();
        Пока Выборка.Следующий() Цикл
            Если (Выборка.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС И Выборка.Товары.Итог("СуммаНДС") = 0)
             Или (Выборка.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС И Выборка.Товары.Итог("СуммаНДС") > 0) Тогда
                Продолжить;
            КонецЕсли;
            ОбъектДокумента = Выборка.Ссылка.ПолучитьОбъект();
            ОбъектДокумента.НалогообложениеНДС = ?(Выборка.Товары.Итог("СуммаНДС") = 0, Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС, Перечисления.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС);
            Попытка
                ОбъектДокумента.Записать(?(Выборка.Ссылка.Проведен, РежимЗаписиДокумента.Проведение, РежимЗаписиДокумента.Запись));
                Сообщить("Исправили: " + СокрЛП(Выборка.Ссылка), СтатусСообщения.Информация);
            Исключение
                Сообщить("Не удалось исправить: " + СокрЛП(Выборка.Ссылка) + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
            КонецПопытки;
        КонецЦикла;    
    КонецЦикла; 
КонецПроцедуры

Но она долго выполняется, и главное не видно хода процесса. В обычных формах при исправлении каждого документа выводится сообщение. А в УФ после выполнения всей обработки. Возможно ли в УФ сделать как в обычных формах.
   ДенисЧ
 
85 - 15.11.21 - 06:52
(84) Используй power of фоновые задания, young padavan...
   Mikhail Volkov
 
86 - 15.11.21 - 07:11
(85) Желательно средствами 1С.
   ДенисЧ
 
87 - 15.11.21 - 07:30
(86) Открою тайну, только ты того... Молчи...
"фоновые задания" - это средства 1с...
   Mikhail Volkov
 
88 - 15.11.21 - 14:49
(87) Наверное не просто... Добавил в обработку счетчик и реквизит ИсправлятьПо:
&НаСервере
Процедура ВыполнитьНаСервере()
    Всего = 0;
    Для каждого МетаданныеДокумента Из Метаданные.Документы Цикл
        Если Не (ОбщегоНазначения.ЕстьРеквизитОбъекта("НалогообложениеНДС", МетаданныеДокумента)
            И ОбщегоНазначенияУТ.ЕстьРеквизитТабЧастиОбъекта("СуммаНДС", МетаданныеДокумента, "Товары")) Тогда
            Продолжить;
        КонецЕсли;
        Если МетаданныеДокумента.Имя = "ПоступлениеТоваровНаСклад" Тогда
            Продолжить;
        КонецЕсли;
        Счетчик = 0;
        Выборка = Документы[МетаданныеДокумента.Имя].Выбрать();
        Пока Выборка.Следующий() Цикл
            Если (Выборка.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС И Выборка.Товары.Итог("СуммаНДС") = 0)
             Или (Выборка.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС И Выборка.Товары.Итог("СуммаНДС") > 0) Тогда
                Продолжить;
            КонецЕсли;
            Счетчик = Счетчик + 1;
            ОбъектДокумента = Выборка.Ссылка.ПолучитьОбъект();
            ОбъектДокумента.НалогообложениеНДС = ?(Выборка.Товары.Итог("СуммаНДС") = 0, Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС, Перечисления.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС);
            Попытка
                ОбъектДокумента.Записать(?(Выборка.Ссылка.Проведен, РежимЗаписиДокумента.Проведение, РежимЗаписиДокумента.Запись));
                Сообщить("Исправили: " + СокрЛП(Выборка.Ссылка), СтатусСообщения.Информация);
            Исключение
                Сообщить("Не удалось исправить: " + СокрЛП(Выборка.Ссылка) + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
            КонецПопытки; 
            Если Объект.ИсправлятьПо > 0 И Счетчик >= Объект.ИсправлятьПо Тогда
                Прервать;
            КонецЕсли;
        КонецЦикла;
        Всего = Всего + Счетчик;
        Сообщить(?(Счетчик = 0, "Нет для исправления", "Исправлено: " + Счетчик) + " " + МетаданныеДокумента.Синоним, СтатусСообщения.Информация);
    КонецЦикла; 
    Сообщить(?(Всего = 0, "Нет для исправления", "Исправлено: " + Всего) + " документов", СтатусСообщения.Информация);
КонецПроцедуры

Теперь можно небольшими порциями ее запускать... и если все нормально, можно запустить без ограничения (ИсправлятьПо = 0).

Теперь иногда выскакивает сообщение:
Обратите внимание, что тип налогообложения "Продажа облагается НДС" не поддерживается учетной политикой организации. В этом случае могут быть списаны только комиссионные товары.
У нас автосервис, патент на выполнение авторабот (услуги без НДС, кроме стоянки авто). А меняемые запчасти с НДС. Возможно ли настроить учетную политику организации, чтобы не выскакивали такие сообщения?
   rozer76
 
89 - 24.11.21 - 10:39
(26) где это сказано? Можно ссылку ?
   ildary
 
90 - 24.11.21 - 10:58
(90) Тут: https://releases.1c.ru/project/ARAutomation20

P.S. Зарелизили УТ 11.5. Это просто праздник какой-то.
   RAJAH
 
91 - 24.11.21 - 11:07
   ildary
 
92 - 24.11.21 - 11:16
+(90) И как всегда, правила перехода с других конфигураций на 11.5 не обновлены, их версия в дистрибутиве - скорей всего не рабочая. Кому надо - тот пусть напильником пилит.
   rozer76
 
93 - 24.11.21 - 11:22
(91) ндя...спасибо )
   Mikhail Volkov
 
94 - 24.11.21 - 15:28
Вышел релиз 2.5.7.255, с ним новые правила:
    <Ид>6bb3ab44-3890-11ec-9d6d-a85e452b0f50</Ид>
    <Наименование>УПП - УП 2.5.7</Наименование>
    <ДатаВремяСоздания>2021-10-29T13:05:52</ДатаВремяСоздания>
    <Источник ВерсияПлатформы="8.0" ВерсияКонфигурации="1.3.138.2" СинонимКонфигурации="Управление производственным предприятием, редакция 1.3">УправлениеПроизводственнымПредприятием</Источник>
    <Приемник ВерсияПлатформы="" ВерсияКонфигурации="2.5.7.201" СинонимКонфигурации="">УправлениеПредприятием</Приемник>
А ошибка та же (32).


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.