Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УТ11.4 - как быстро посмотреть для каких ролей доступен документ?

УТ11.4 - как быстро посмотреть для каких ролей доступен документ?
Я
   Vovik
 
20.10.21 - 16:54
Например документ "Возврат от клиента". Хочу не роясь в этой навозной куче из ролей сразу узнать в каких ролях доступна запись, проведение...?
   ДенисЧ
 
1 - 20.10.21 - 16:55
На нимфе есть отчётег...
Вот такой.. 779499_ПраваДоступаРолей
   DrShad
 
2 - 20.10.21 - 16:56
програмно обойти роли и проверить право доступа
   Vovik
 
3 - 20.10.21 - 16:59
Спс. Пошел на инфостарт. Думал ну вдруг есть что то штатное. А то ведь 1с все легче, проще, быстрее и удобнее.
   Kassern
 
4 - 20.10.21 - 16:59
(0) Дарю:
Для каждого Роль Из Метаданные.Роли Цикл
        Если ПравоДоступа("Чтение",Метаданные.<указываем что нужно>,Роль) Тогда 
            Сообщить(Роль);
        КонецЕсли;
    КонецЦикла;
   Kassern
 
5 - 20.10.21 - 16:59
(4) только вместо чтение можно указать право на запись
   Kassern
 
6 - 20.10.21 - 17:00
в общем юзайте СП, там много что есть)
   Vovik
 
7 - 20.10.21 - 17:01
спс. ща потестим
   ДенисЧ
 
8 - 20.10.21 - 17:15
(4) Так эт писать надо, макет оформлять...
   fisher
 
9 - 20.10.21 - 17:23
(3) Найдешь что-то достойное - отпишись.
   Kassern
 
10 - 20.10.21 - 17:29
(8) какой еще макет? Просто обработку на коленке, указать нужную мету и нужные права и все. Тебе выплюнет какие роли дают такие права
   Vovik
 
11 - 20.10.21 - 21:48
(9) так в (4) достойное. Я доволен и благодарен.

_Мета = Метаданные.Документы.ВозвратТоваровОтКлиента;
//_Право = "Чтение";

_Право = "Проведение";
Сообщить(""+_Мета + ": ");
Для каждого Роль Из Метаданные.Роли Цикл
      Если ПравоДоступа(_Право,_Мета,Роль) Тогда 
           Сообщить(""+Роль);
      КонецЕсли;
КонецЦикла;
   Сергиус
 
12 - 21.10.21 - 00:52
(0)Конфигуратор, Роли - ПКМ - Все роли, находишь свой док и смотришь.
   TormozIT
 
13 - 21.10.21 - 07:39
Есть в ИР мощный отчет "Анализ прав доступа" http://devtool1c.ucoz.ru/index/analiz_prav_dostupa/0-64

При использовании варианта "Расширение" из управляемой формы документа можно открыть так
1. Вызываешь глобальное меню (CTRL+ё) и выполняешь там команду "Форма. Редактор объекта"
2. В редакторе объекта снизу в подменю "Прочее" выполняешь команду "Анализ прав доступа"
   TormozIT
 
14 - 21.10.21 - 07:42
(13)+
3. Выбираешь в отчете сверху в подменю "Варианты" вариант "Роли с доступом к объекту"
   ДенисЧ
 
15 - 21.10.21 - 07:48
(13) Кстати... Скачал расширение свежее. Решил его в (почти) типовую бухию подключить...
Не дала, начала ругаться про разделение данных...
{ВнешняяОбработка.StandardExtensionsManagement.Форма.Form.Форма(314)}: Ошибка при вызове метода контекста (Записать): Нельзя установить область действия расширения конфигурации в значение РазделениеДанных в информационной базе, не использующей разделение данных
   TormozIT
 
16 - 21.10.21 - 08:36
(15) Кстати... Баги ИР принимаются так http://devtool1c.ucoz.ru/forum/2-2-1
   ДенисЧ
 
17 - 21.10.21 - 08:43
(16) А где там кнопка добавить сообщение без регистрации? ))
   TormozIT
 
18 - 21.10.21 - 09:12
(17) Че, даже на github до сих пор не зареган?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.