Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

как добавить значение в текущую строку таблицы документа (Процедура на сервере)

как добавить значение в текущую строку таблицы документа (Процедура на сервере)
Я
   kust1985d
 
20.10.21 - 13:37
Подскажите как добавить значение в текущую строку таблицы документа (Процедура на сервере)
   Малыш Джон
 
1 - 20.10.21 - 13:38
на сервере нет текущих строк
   Kassern
 
2 - 20.10.21 - 13:39
(0) Передать/Получить эту строку на сервере и присвоить значение
   kust1985d
 
3 - 20.10.21 - 13:40
Может есть пример
   youalex
 
4 - 20.10.21 - 13:41
(1) вообще есть:
ТекущаяСтрока (CurrentRow)

Тип: Произвольный.
Идентификатор текущей строки таблицы.
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, мобильное
   kust1985d
 
5 - 20.10.21 - 13:42
Процедура кодПриИзменении(Элемент)
    Код=Элементы.Товары.ТекущиеДанные.код;
    кодПриИзмененииНаСервере(Код);
КонецПроцедуры

Процедура кодПриИзмененииНаСервере(Элемент)
Товар = Справочники.Номенклатура.НайтиПоРеквизиту("код",Элемент);
КонецПроцедуры
   acht
 
6 - 20.10.21 - 13:42
(0) С днем рождения тебя!
   kust1985d
 
7 - 20.10.21 - 13:43
Как вставить найденное значение в номенклатуру на сервере
   youalex
 
8 - 20.10.21 - 13:46
(7) если это все что нужно, сделай бесконтекстную функцию получения номенклатуры и запихивай ее результат
   Мультук
 
9 - 20.10.21 - 13:46
&НаКлиенте
Процедура ДобавитьВТекущуюСтроку()
    пДанные = Элементы.Товары.ТекущиеДанные;
    Если пДанные <> Неопределено Тогда
        пДанные.Товар = ТоварПоКоду(пДанные.код);
    КонецЕсли; 
КонецПроцедуры

&НаСервереБезКонтекста
Функция ТоварПоКоду(код)
    Возврат Справочники.Номенклатура.НайтиПоРеквизиту("код", код);
КонецФункции
   DrShad
 
10 - 20.10.21 - 13:46
сделай ввод товара по коду и не парь никому мозг
   kust1985d
 
11 - 20.10.21 - 13:57
Мультук Спасибо
   Kassern
 
12 - 20.10.21 - 15:01
(11) Если уж хочется строку с клиента на сервер передать, то можете вот таким способом попробовать:
&НаКлиенте
Процедура УстановитьКоличество(Команда)
    ИндексСтроки=Элементы.Товары.ТекущаяСтрока;
    УстановитьКоличествоНаСервере(ИндексСтроки);
КонецПроцедуры

&НаСервере
Процедура УстановитьКоличествоНаСервере(ИндексСтроки) 
    СтрокаТЧ=Объект.Товары.НайтиПоИдентификатору(ИндексСтроки);
КонецПроцедуры

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.