Вход | Регистрация
    1  2

Гуру-тест: в расширении нужно использовать свою форму, не создавая новой роли.

Гуру-тест: в расширении нужно использовать свою форму, не создавая новой роли.
Я
   Гений 1С
 
12.10.21 - 12:32
Отсчет пошел, знатоки. ;-)
   Fragster
 
101 - 12.10.21 - 15:49
ответ на ГУРУ-тест:
"При подключении расширения к информационной базе есть возможность установить признак Использовать основные роли для всех пользователей. Данный флажок работает следующим образом:

● Если флажок установлен и в расширении задано свойство ОсновныеРоли, то минимальный набор прав будет определяться ролями, указанными в свойстве ОсновныеРоли. При этом администратор имеет возможность расширить состав ролей конкретного пользователя другими ролями расширения (не входящими в состав основных ролей расширения)."
(с) ИТС
https://its.1c.ru/db/v8320doc#bookmark:dev:TI000001845

а то, что предлагает автор - это полный отстой
   Kassern
 
102 - 12.10.21 - 15:50
(94) можете конкретный пример написать? Я тут глянул в типовых, где используется Пока Истина Цикл, так там без проблем можно выборку обходить. Еще используют чтобы мол красиво было, в попытке выполняют дейсвтие, если не получается счетчик ошибок копят, если больше определенного числа то выход из цикла. Что мешает при этом Для к=1 По КоличествоОшибок выполнять цикл я хз. Вот пример из типовой:
    Пока Истина Цикл
        Попытка
            Результат = Запрос.Выполнить();// Чтение вне транзакции, возможно появление ошибки.

                                            // Could not continue scan with NOLOCK due to data movement

                                            // в этом случае нужно повторить попытку чтения.

            Прервать;
        Исключение
            КоличествоПопыток = КоличествоПопыток + 1;
            Если КоличествоПопыток = 5 Тогда
                ВызватьИсключение;
            КонецЕсли;
        КонецПопытки;
    КонецЦикла;
   Kassern
 
103 - 12.10.21 - 15:54
(101) ну все, собеседование в фиксин групп вы уже не пройдете, а ответ был так близко)
   pechkin
 
104 - 12.10.21 - 15:56
правильный вариант: создать профиль и группу доступа (наверняка в типовой есть уже роль).
все юзеров добавить в эту группу
   Ненавижу 1С
 
105 - 12.10.21 - 15:56
(0) после передачи параметров с помощью регистра удивляться в этом цирке нечему
   Fragster
 
106 - 12.10.21 - 15:57
(103) у меня есть штук шесть грамот за подписью Сергея Нуралиева, где меня называют гуру 1с :)
   Fragster
 
107 - 12.10.21 - 15:58
буду их предъявлять
   H A D G E H O G s
 
108 - 12.10.21 - 15:59
(102) Лишний уровень вложенности кода
   pechkin
 
109 - 12.10.21 - 15:59
(106) котируется только за подписью Сергея Фиксина
   Eiffil123
 
110 - 12.10.21 - 16:08
(106) это которые печатают на ресепшене УЦ1 на желтых листах и там же подписывают? ))
   ДенисЧ
 
111 - 12.10.21 - 16:08
(106) Прямо так и написано "гуру"?
   Fragster
 
112 - 12.10.21 - 16:08
(111) ну
   Eiffil123
 
113 - 12.10.21 - 16:09
(85) нормальный вариант, когда заранее неизвестен объем обрабатываемых данных
   Fragster
 
114 - 12.10.21 - 16:11
(110) надо вот в таком списке оказаться: https://i.imgur.com/AfKKOPq.png
   Kassern
 
115 - 12.10.21 - 16:11
(113) ключевое слово если, а кто-то может взять за правило и в любой выборке так делать...
   fisher
 
116 - 12.10.21 - 16:12
(94) А в чем проблема? Количество порций типа неизвестно или что?
Все равно же есть какие-то условия выхода и обычно не составляет проблемы хотя бы одно из ключевых вынести в условие цикла, что сразу улучшает читабельность.
   Fragster
 
117 - 12.10.21 - 16:12
(115) в (102) вся мякотка в "ВызватьИсключение"
   Fragster
 
118 - 12.10.21 - 16:14
с другой стороны можно, конечно, сделать Для сч = 0 по МаксимальноеКоличество Цикл если Сч = МаксимальноеКоличество тогда вызватьИсключение конецЕсли но тогда немного страдает локальность кода
   Fragster
 
119 - 12.10.21 - 16:15
опять же, в цикле "пока" можно сделать условие не "5 попыток", а "пытаться 5 минут", например
   Kassern
 
120 - 12.10.21 - 16:15
(118) либо хранить переменную с результатом, если неопределено, то привет вызватьИсключение
   DexterMorgan
 
121 - 12.10.21 - 16:15
(101) Ну я ему писал (26) + (32) но "это слишком глубоко" и его метод "проще" xDDD
   Fragster
 
122 - 12.10.21 - 16:18
(121) да он, походу, даже не понял, что ты не предлагаешь расширять никакие роли
   fisher
 
123 - 12.10.21 - 16:20
(102)
УспешнаяОтправка = Ложь;
КоличествоПопыток = 0;
Пока Не УспешнаяОтправка И КоличествоПопыток < 5 Цикл
        Попытка
            Результат = Запрос.Выполнить();
            УспешнаяОтправка = Истина;
        Исключение
            КоличествоПопыток = КоличествоПопыток + 1;
        КонецПопытки;
КонецЦикла;
Если Не УспешнаяОтправка Тогда
     ВызватьИсключение;
КонецЕсли;
   Kassern
 
124 - 12.10.21 - 16:21
(123) что я и написал в (120) )
   fisher
 
125 - 12.10.21 - 16:22
Тьфу. Почему отправка? Параллельно о своей проблеме размышляю :)
   pechkin
 
126 - 12.10.21 - 16:23
(123) красивее с Для счетчик = 1 по 5 и прервать
   pechkin
 
127 - 12.10.21 - 16:24
УспешнаяОтправка = Ложь;
Для КоличествоПопыток = 1 По 5 Цикл
        Попытка
            Результат = Запрос.Выполнить();
            УспешнаяОтправка = Истина;
            Прервать;
        Исключение
        КонецПопытки;
КонецЦикла;
Если Не УспешнаяОтправка Тогда
     ВызватьИсключение;
КонецЕсли;

   fisher
 
128 - 12.10.21 - 16:24
(126) Мне - нет. Не красивее.
   Kassern
 
129 - 12.10.21 - 16:26
(127) (128) вы бы сами так стали обходить, или как создатели типовых Пока Истина Цикл?)
   fisher
 
130 - 12.10.21 - 16:27
В (123) я сразу вижу все условия выхода. Они просты и сразу понятна суть. Можно даже тело цикла не читать.
 
 
   fisher
 
131 - 12.10.21 - 16:34
Да и вообще "отстрел" прерываний и ветвлений всегда благотворно сказывается на читабельности. Код становится линейнее, мозг меньше притормаживает на поворотах.
Например, очень часто в "Если" можно избавиться от "Иначе" и в итоге становится только лучше.
   Гений 1С
 
132 - 12.10.21 - 16:41
(91) это ты спроси у разработчиков отраслевой, это их бесконечный цикл, я лишь поправил, чтобы он не был бесконечным, ты статью то прочитал?
   Гений 1С
 
133 - 12.10.21 - 16:42
(94) ну конкретно там можно было. получить все периоды для пересчета. а потов в обычном цикле если по периоду уже создан документ (в другом сеансе), то пропускаем. Не знаю, зачем там сделаны такие выкрунтасы
   Eiffil123
 
134 - 12.10.21 - 16:49
(114) для меня бы этот список мало что значил. Разве что другим участникам форума свои визитки раздать
   Гений 1С
 
135 - 12.10.21 - 16:51
(114) ты не поверишь, но я один раз там бывал. Когда во фране работал и доставал поддержку 1С вопросами.
   Eiffil123
 
136 - 12.10.21 - 16:52
(115) ну как бы применения разных циклов изучают чуть-ли не на 2м занятии программирования. Со школы или института все должны понимать отличия и применимость
   Гений 1С
 
137 - 12.10.21 - 21:05
(136) да, КЭП
   vicof
 
138 - 13.10.21 - 21:22
https://dszn.ru/press-center/news/5302
Главное — понимать, что чувство собственного превосходства, присущее неуверенному в себе человеку, хвастовство, раздутое эго — это первый сигнал того, что не хватает внимания: возможно, он одинок. Вступать в конфликт — бесполезная трата времени, а вот подружиться и действительно узнать его поближе — черта сильного человека. Поэтому ответом на вопрос, как общаться с людьми, которые считают себя лучше других, будет прост: принять их мнение о себе и показать, что вы на равных, через сотрудничество и партнерство. Общаясь с высокомерным или надменным человеком, следует понимать, что за этим скрывается большая, глубокая внутренняя проблема.
  1  2

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.