Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Активация элемента по Alt + подчёркнутый символ, траблы при английской раскладке

v7: Активация элемента по Alt + подчёркнутый символ, траблы при английской раскладке
Я
   evgpinsk_
 
09.10.21 - 23:31
Известно что если имя кнопки: "&Кнопка"
То по нажатию Alt+К фокус переходит на эту кнопку.
Но это работает только на русской раскладке. На английской не работает, и тратится время.
Сначала жмёшь Akt+K, ничего не происходит, потом пробуешь ещё раз, потом понимаешь что не та раскладка.

Вопрос: есть ли простой способ решить проблему нажатия кнопки клавиатурой через Alt+буква в не зависимости от установленной раскладки?
   серый КТУЛХУ
 
1 - 09.10.21 - 23:34
formex
   Ёпрст
 
2 - 10.10.21 - 00:14
(0) назнач свой хоткей кнопке, какой те нннадо
   evgpinsk_
 
3 - 10.10.21 - 00:37
(2) Каким образом? Стандартно назначается конкретная буква. Можно конечно цифру, но хотелось бы букву
   evgpinsk_
 
4 - 10.10.21 - 00:39
(2) Или имеется ввиду сочетание клавиш FN на закладке Команда? Это не очень удобно
   Ёпрст
 
5 - 10.10.21 - 10:00
   Ёпрст
 
6 - 10.10.21 - 10:01
Кнопку кидаешь на форму, делаешь невидимой, ари желании и привет.
   acanta
 
7 - 10.10.21 - 10:08
Две кнопки с разными буквами, одна из них невидимая.  Если есть переключение закладок, то в ней тоже видимость меняется. Если две кнопки на одном месте и обе видимые, то порядок обхода в свойствах формы (в стандартной 1с программно не меняется).
   evgpinsk_
 
8 - 10.10.21 - 16:10
(7) Понял, спасибо. Но приходится прятать одну кнопку за другой, т.к. при наличии закладок кнопка на секунду появляется )
   evgpinsk_
 
9 - 10.10.21 - 16:24
(5) Я туплю, но так и не понял как вызывается процедура КнопкаНажатие(Кнопка)
)
   Volodja
 
10 - 10.10.21 - 18:00
(9) Скорее всего разложено Gcomp-oм. Затем назначена HotKey: 7
А потом собрано снова в обработку.
   Ёпрст
 
11 - 10.10.21 - 18:05
(9) кнопке назначен нужный хоткей и все. Копируешь к себе нужную кнопку, пользуешься.
Только учти, есть платыорменное ограничение на количество хоткеев на форме, не помню, сколько там точно их. + Желательно такую кнопку сдвинуть вверх в порядке обхода и закинуть или в невидимый служебный слой или за пределы экрана, например, 10000х100000
   evgpinsk_
 
12 - 11.10.21 - 13:49
(11) Мне ведь нужно сочетание Alt+буква
вроде как в обработке "Кнопка" такое сочетание не реализовано.
И ещё странный момент - половина букв не реагирует на нажатие (два нижних ряда букв)
не стал разбираться с этой биоматью ) 

(7)  вот этот способ мне кажется самым простым
   evgpinsk_
 
13 - 11.10.21 - 13:53
(11) > "кнопке назначен нужный хоткей и все."

Как он назначен? Я знаю штатную возможность назначения только функциональных кнопок в свойстве кнопки на закладке "Команда"
   Ёпрст
 
14 - 11.10.21 - 15:36
(13) руками вестимо. Средств для работы с компаундом вагон и маленькая тележка
   Ёпрст
 
15 - 11.10.21 - 15:36
(12) все там реализовано. Это просто пример кнопок, которые когда-то мне были нужны. Можно сделать любой хоткей.
   Ёпрст
 
16 - 11.10.21 - 15:37
Ну и если религия позволяет, пользуйся отловом кнопок через формекс.
   uno-group
 
17 - 11.10.21 - 16:53
Процедура ПриНажатииКнопкиКлавиатуры(<?>,,,,,,)
КонецПроцедуры
СИНТАКСИС:
Процедура ПриНажатииКнопкиКлавиатуры(<Контекст>,<КодКлавиши>,<Alt>,<Shift>,<Ctrl>,<Символ>,<ФСО>)
КонецПроцедуры
НАЗНАЧЕНИЕ:
Предопределенная процедура при нажатии кнопки клавиатуры.
ПРИМЕР:
Процедура ПриНажатииКнопкиКлавиатуры(конт, код, _а, _ш, _к)
        Предупреждение(Нажата кнопка клавиатуры.);
КонецПроцедуры
ПАРАМЕТРЫ:
<Контекст> - контекст формы
<КодКлавиши> - код нажатой кнопки клавиатуры.
<Alt> - флаг нажатия кнопки
<Shift> - флаг нажатия кнопки
<Ctrl> - флаг нажатия кнопки
<Символ> - символ нажатой кнопки в формате ASCII.
<ФСО> - флаг стандартной обработки. Изначально равен 1. Если в теле процедуры сбросить
значение в 0, то стандартная обработка события не вызывается.
<> -
   victuan1
 
18 - 12.10.21 - 05:55
(13) С помощью i-gent'а можно назначить любую комбинацию клавиш: https://infostart.ru/public/14053/
   evgpinsk_
 
19 - 12.10.21 - 09:07
(18) Ого, интересно. А он не ругается с OpenConf?
   victuan1
 
20 - 12.10.21 - 09:33
(19) Так они вроде в непересекающихся параллельных вселенных живут.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.