Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Помогите решить задачу.

↓ [Волшебник, 04.10.21 - 07:50]
Помогите решить задачу.
Я
   Yulechka2000
 
04.10.21 - 06:17
Всем привет! Я только начинаю изучать 1С и у меня возникла проблема с решением одной задачи. Помогите, пожалуйста ;)
Написать обработку на форме которой находится ТЗ с единственной колонкой «число». Пользователь заполняет данную таблицу любыми значениями. Реализовать кнопку «Сумма» которая будет суммировать все значения в интервале между числом 100 и 100 исключая интервалы между числами 200. Интервал 200 может быть не закрыт так же как и 100. При этом не закрытый интервал 200 считается закрытым числом 100
   Ненавижу 1С
 
1 - 04.10.21 - 06:20
Какая шарага вас штампует?

Помогите решить задачку
   Yulechka2000
 
2 - 04.10.21 - 06:29
(1) По ссылке просто сравниваются два числа. Числа сравнивать я умею :) А вот составить алгоритм по данном задаче, у меня не получается. Помогите...
   SleepyHead
 
3 - 04.10.21 - 06:40
(0) Утром фотки - вечером помогут (если понравятся). Таково негласное правило форума.
   Yulechka2000
 
4 - 04.10.21 - 06:52
Ладно,буду сюда писать, что получается. Может кто натолкнет на правильную мысль.
Пока написала только такой код. Но здесь не могу понять как сделать проверку на закрытие интервала 200 или 100. Подскажите.

Процедура КнопкаВыполнитьНажатие(Кнопка)
    Итого = 0;
    Блок = Ложь;
    Для каждого Стр Из Таблица Цикл
        Если Стр.Число = 100 Тогда
            Блок = Истина;
            Продолжить;
        КонецЕсли;
        Если Стр.Число = 200 Тогда
            Блок = Ложь;
            Продолжить;
        КонецЕсли;        
        Если Блок Тогда
            Итого = Итого + Стр.Число;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
   Volodja
 
5 - 04.10.21 - 06:56
(3) В карточке Мужской пол указан
   SleepyHead
 
6 - 04.10.21 - 06:56
(5) Кругом обман!
   Yulechka2000
 
7 - 04.10.21 - 07:01
(5) При регистрации нигде не спрашивали пол :( Как исправить?
   Volodja
 
8 - 04.10.21 - 07:04
(7) Изменить. И точечку на "Ж" поставить
   SleepyHead
 
9 - 04.10.21 - 07:05
(7) И добавить фотки.
   Volodja
 
10 - 04.10.21 - 07:14
(4) по вашему алгоритму :
У вас будет неверно выходить итог на примере последовательности:
1,100,5,6,200,4,200,8,6
Он у вас выдаст 11.
А нужно 5+6+8+6=25

Фотки не забудь.
   hhhh
 
11 - 04.10.21 - 07:14
(0) переведи.
   Volodja
 
12 - 04.10.21 - 07:16
(4) Я бы завел две логические переменные Блок100 и Блок200
   Мультук
 
13 - 04.10.21 - 07:50
(0)

Текст задачи, прямо как тех.задание у части заказчиков.
Написано вроде по русски, но нихрена непонятно.
А потом в процессе разговора оказывается, что все просто, но совсем не так, как написано.
   Ненавижу 1С
 
14 - 04.10.21 - 07:58
(13) +100500
   Yulechka2000
 
15 - 04.10.21 - 08:02
(11) https://yapx.ru/v/OZq85
Вот картинка как должно быть. По ним понятно.
   osa1C
 
16 - 04.10.21 - 08:19
(10) Скорее нужно 5+6 = 11.  8 и 6 выходят за интервал
   Volodja
 
17 - 04.10.21 - 08:28
(16) Интервал 200 может быть не закрыт так же как и 100.
Я понял, что закрывать 100 не нужно.
   unbred
 
18 - 04.10.21 - 08:48
"При этом не закрытый интервал 200 считается закрытым числом 100"
на 2й картинке получаю 110.
херовое ТЗ
100
20 между 100 и 100
200(100) по условию..
45 между 100 и 100
45 между 100 и 100
100
   Yulechka2000
 
19 - 04.10.21 - 08:54
(18) ТЗ правильное. На второй картинке - открывается интервал 100 Итого = 20. Далее открывается интервал 200. 45 и 45 не считаем по условию (исключая интервалы между числами 200). Далее 200 закрывается 100. В итоге получаем 20.
   Volodja
 
20 - 04.10.21 - 09:04
(19) Фоток не ждать? Так бы уже помогли бы.
   Yulechka2000
 
21 - 04.10.21 - 09:11
(20) А просто помочь девушке в трудную минуту? :)
   Volodja
 
22 - 04.10.21 - 09:16
Значит не будет...
   DrShad
 
23 - 04.10.21 - 09:18
(21) для этого еще нужен авторитет
   Yulechka2000
 
24 - 04.10.21 - 09:23
(22) Жаль :( Я думала, что этот форум нужен для того, чтобы можно было попросить о помощи и тебе помогут. Ладно, буду сама дальше думать. Рыцари перевелись :(
   unbred
 
25 - 04.10.21 - 09:23
(19) ты или не читаешь, что я пишу, или не хочешь увидеть написанное, что, впрочем, одно и тоже.
напиши результат вот этого:
   unbred
 
26 - 04.10.21 - 09:24
(25) передумал писать пример)
   END
 
27 - 04.10.21 - 09:27
(24) Да, давай думай сама. Программирование это такое - думать надо. Даже в 1С.
   unbred
 
28 - 04.10.21 - 09:30
(27) где тут программирование?
задачка на логику.
любой универ 1й курс.
только логика должна быть логичной, а не вот это вот всё. тут нет четкого понятия открытия интервала. на картинке 2 это отчётливо видно. ты должен догадаться, по картинке, в ТЗ даже близко этого нет.
   Малыш Джон
 
29 - 04.10.21 - 09:37
(24) >>Я думала, что этот форум нужен для того, чтобы можно было попросить о помощи и тебе помогут.

Боже, какая прелесть ))))
   Yulechka2000
 
30 - 04.10.21 - 09:52
(26) Так и скажи, что решения не знаешь ;)
 
 
   Volodja
 
31 - 04.10.21 - 09:52
(24) ну уже кое-какие подсказки ведь дали.
Или сразу готовое решение выложить?
   unbred
 
32 - 04.10.21 - 09:56
(30) забавная провокация))
я знаю, но сначала фотка)
   Yulechka2000
 
33 - 04.10.21 - 09:59
(31) За подсказки про логические переменные Блок100 и Блок200, спасибо. Сейчас как раз думаю, как правильно с ними условия составить.
   Volodja
 
34 - 04.10.21 - 10:00
(33) Верный путь
Еще нужно там где-то пристроить Блок100=Не Блок100;
   fisher
 
35 - 04.10.21 - 10:04
Залип на формулировке
> значения в интервале между числом 100 и 100
Что такое "незакрытый интервал 200 считается закрытым числом 100" - даже боюсь начинать обдумывать, чтобы не перегреть мозг.
   unbred
 
36 - 04.10.21 - 10:07
(35) тут без картинки не раскурить)
   fisher
 
37 - 04.10.21 - 10:10
А, нашел картинку. Понимание конечных автоматов проверяют.
   Yulechka2000
 
38 - 04.10.21 - 11:08
Справилась сама. Еще раз спасибо Volodja за подсказку. Фотки пока оставлю при себе :Р
   osa1C
 
39 - 04.10.21 - 11:30
(38) тогда больше не лезь на форум))))  Без фоток второй раз ответ не получишь!!! Правила!!!
   SleepyHead
 
40 - 04.10.21 - 11:36
(21) Тут таких девушек и не девушек...
   Yulechka2000
 
41 - 04.10.21 - 11:49
(40) Понятно, имя таким Легион :) Но все-таки хочется верить в лучшее. Ведь изначально форумы в инете создавались для общения и помощи в чем-либо. Всем мир :)
   osa1C
 
42 - 04.10.21 - 12:47
(41) тут небольшое правило... сначала фото, а потом тебе помогут с удовольствием.


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.