Вход | Регистрация
 

Помогите решить задачку

Помогите решить задачку
Я
   Бурундук
 
03.10.21 - 14:07
Я только начала осваивать 1С. Как написать программу, которая будет сравнивать два числа А и Б и возвращать их значение, а не просто выводить на экран: "А > Б" и т.д. Как в таком случае описать функцию, помогите пожалуйста! Заранее благодарна
   GANR
 
1 - 03.10.21 - 14:28
(0) Читайте Радченко - по ходу поймете как это сделать. Если не готовы приложить усилия, чтобы прорешать Радченко, то боюсь Вам не по пути с 1С.
   Ненавижу 1С
 
2 - 03.10.21 - 14:29
(0) показывайте, что делали и что конкретно не удалось
   Бурундук
 
3 - 03.10.21 - 14:36
Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)
    Ср = СравнениеАиБ(ЧислоА, ЧислоБ);
    Сообщить(Ср);
КонецПроцедуры



Функция СравнениеАиБ(А, Б)
    
    Если А > Б Тогда
        Сообщить(А + ">" + Б);
        
        ИначеЕсли А < Б Тогда 
        Сообщить(А + "<" + Б);
        Иначе
            
        Сообщить(А + "=" + Б);  
    КонецЕсли;    
    Возврат А;
    Возврат Б;
        
        КонецФункции    


Просьба не кидать тапками, сама себе поставила такую задачу и не знаю, как правильно её написать. Занимаюсь только 1 неделю
   Смотрящий
 
4 - 03.10.21 - 14:38
(0) "сравнивать два числа А и Б и возвращать их значение" - значение сравнения ?
   rphosts
 
5 - 03.10.21 - 14:40
(3) Внутри Сообщить(...) для вашего случая добавьте в начале символ пробела, типа так: Сообщить(" "+А+">"........
   rphosts
 
6 - 03.10.21 - 14:40
А вообще Радченко вам в руки
   acanta
 
7 - 03.10.21 - 15:08
А можно такие вопросы чтобы на собеседованиях были?
   Бурундук
 
8 - 03.10.21 - 15:08
rposts, Спасибо большое, почти получилась. Только теперь после сравнения этих двух чисел постоянно внизу выдаёт значение А. Как исправить?
   Asmody
 
9 - 03.10.21 - 15:23
Что значит "возвращать их значение"? В 1С функции могут возвращать только одно значение.
   Ненавижу 1С
 
10 - 03.10.21 - 15:33
(9) можно упаковать в одно
   Ненавижу 1С
 
11 - 03.10.21 - 15:38
(8) функцию превратить в процедуру. Она же не возвращает по логике результат. Вызывать как процедуру. Убрать сообщить в основной процедуре.
   bolder
 
12 - 03.10.21 - 15:40
(0) В функции:
Ср = Новый Структура («А,Б,Результат”,А,Б,Неопределено);
Вместо сообщить присваиваешь  Результат и совращаешь Ср.
В основной процедуре сообщаешь все что нужно.
   bolder
 
13 - 03.10.21 - 15:42
(12) >совращаешь -> возвращаешь )))
   bolder
 
14 - 03.10.21 - 15:45
(0) Кстати, а что фотку зажала ?Тут вообще то правила. Могут совсем не помочь без фотки)
   Бурундук
 
15 - 03.10.21 - 15:48
bolder,ничего я не зажала)))) Просто я не разобралась, как её прикрепить
   hhhh
 
16 - 03.10.21 - 16:05
(15) вот так
    Возврат А;
    Возврат Б;
 
в программировании не катит. После Возврат уже работает основная процедура и второй Возврат никогда не вызывается. То есть срабатывает только

    Возврат А;

и потом сразу идет      
    Сообщить(Ср);
   rphosts
 
17 - 03.10.21 - 16:09
(9) формально, параметры передаваемые по ссылке (дефолтовая передача) могут быть использованы для возврата.... ну и вернуть можно обратно структуру в которой может быть много сякого
   rphosts
 
18 - 03.10.21 - 16:10
(13) оговорочка по Фрейду...
   Бурундук
 
19 - 03.10.21 - 16:45
Всем СПАСИБО БОЛЬШОЕ, у меня получилось то, что нужно!

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.