Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подскажите как сделать программно расшифровку сразу по нескольким полям

Подскажите как сделать программно расшифровку сразу по нескольким полям
Я
   URAL
 
01.10.21 - 16:17
Подскажите как сделать программно расшифровку сразу по нескольким полям,
прошу не предлагать вариант с рисованием макета

Сейчас у меня выводится расшифровка только по выбранному полю и ресурсу, а нужно вне зависимости какую выберу расшифровку сделать чтобы выводились заданное количество полей и ресурсы

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка,ДополнительныеПараметры)

  Перем ВыбранноеДействие;
  Перем ПараметрыВыбранногоДействия;

//  СтандартнаяОбработка = Ложь;
  ОбработкаРасшифровки =  Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(Отчет));

//  ОбработкаРасшифровки.ВыбратьДействие(Расшифровка, ВыбранноеДействие, ПараметрыВыбранногоДействия);

//  Если ВыбранноеДействие <> ДействиеОбработкиРасшифровкиКомпоновкиДанных.Нет Тогда
    Если ВыбранноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда
      ОткрытьЗначение(ПараметрыВыбранногоДействия);
    Иначе
      ОтработатьРасшифровку(Новый ОписаниеОбработкиРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Расшифровка, ПараметрыВыбранногоДействия));
    КонецЕсли;
  КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ОтработатьРасшифровку(ОписаниеОбработкиРасшифровки)

  ДанныеРасшифровкиОбъект = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
  ОбработкаРасшифровки =  Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровкиОбъект, Новый ИсточникДоступныхНастроекКомпоновкиДанных(Отчет));
  РезультирующиеНастройки = ОбработкаРасшифровки.ПрименитьНастройки(ОписаниеОбработкиРасшифровки.Идентификатор, ОписаниеОбработкиРасшифровки.ПрименяемыеНастройки);

  Если ТипЗнч(РезультирующиеНастройки) = Тип("НастройкиКомпоновкиДанных") Тогда
    Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(РезультирующиеНастройки);
  ИначеЕсли ТипЗнч(РезультирующиеНастройки) = Тип("ПользовательскиеНастройкиКомпоновкиДанных") Тогда
    Отчет.КомпоновщикНастроек.ЗагрузитьПользовательскиеНастройки(РезультирующиеНастройки);
  КонецЕсли;
  
  
  СкомпоноватьРезультат();

КонецПроцедуры
   hhhh
 
1 - 01.10.21 - 18:31
(0) в чем вопрос? Данные же там все есть в этой процедуре, вы можете вывести абсолютно все поля, какие захочется.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.