Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Можно ли сохранить внешний отчета/обработку при смене версии платформы в "старом" формате?

Можно ли сохранить внешний отчета/обработку при смене версии платформы в "старом" формате?
Я
   SleepyHead
 
01.10.21 - 10:19
Есть внешний отчет/обработка, которую раздаем клиентам.

Сохранили в конфигураторе версии 3.1.8 - и у клиентов с платформой 3.1.5 перестает открываться (ошибка формата потока). Другой формат, насколько я понимаю. То же самое, когда сохраняем в 8.3.18 - у клиентов на 8.3.18 обработка перестает открываться.
Есть возможность сохранять обработки в старом формате? Я не нашел.

Не все клиенты хотят переходить на новую версию платформы, но и отказываться от обработки не хотят. Кодить в двух платформах - ну, это то еще удовольствие. Какие есть варианты решения?
   ДенисЧ
 
1 - 01.10.21 - 10:20
Кодить в двух платформах.
   SleepyHead
 
2 - 01.10.21 - 10:20
(1) Вторую снесли уже.
   ДенисЧ
 
3 - 01.10.21 - 10:22
(2) Ну, кто же вам доктор-то?
Пиши на 77, там нет такой чехарды.
   Garykom
 
4 - 01.10.21 - 10:23
EDT
   SleepyHead
 
5 - 01.10.21 - 10:25
(3) Спасибо ))

Да решим вопрос, на втором сервере осталась старая платформа. Придется, видимо, кодить там.
   SleepyHead
 
6 - 01.10.21 - 10:26
(3) "Ну, кто же вам доктор-то?"

СБИС нам доктор. Он тащит из баз 1С по com-соединению нужные ему данные. Ком-коннектор на 8.3.18 оказался глючный, пришлось перейти на 8.3.19.
   SleepyHead
 
7 - 01.10.21 - 10:27
(4) не работал с таким. А он дает выбор, в каком формате сохранять?
   Serg_1960
 
8 - 01.10.21 - 10:43
Лучше спроси "А он работает с обычными приложением и формами?"
   Serg_1960
 
9 - 01.10.21 - 10:47
(7) Для упрощения процесса разработки и отладки 1C:EDT использует маски версий платформы. Например, это может быть маска <8.3.12> или
маска <8.3>. 1C:EDT будет использовать самую старшую из имеющихся версий платформы, удовлетворяющую этой маске.
Однако это не всегда удобно — например, при работе с серверными базами. В этом случае вы можете назначить маске конкретную версию, которая вам нужна.
Для этого нажмите в главном меню основного окна Окно > Параметры... > V8 > 1С:Предприятие. Выберите нужный шаблон и установите флажок у той версии платформы, которая должна использоваться для этого шаблона.

Источник: https://its.1c.ru/db/edtdoc#content:10115:hdoc
   SleepyHead
 
10 - 01.10.21 - 10:49
(8) Зачем? У меня на УФ
(9) Спасибо
   SleepyHead
 
11 - 01.10.21 - 10:50
В итоге оказалось все просто, файл при передаче клиенту был поврежден (рука лицо)

Проблема снята.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.