Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Параметры в динамическом списке

Параметры в динамическом списке
Я
   Snail
 
29.09.21 - 12:56
Есть динамический сисок товаров, в списке есть 4 булево (группа1, группа2, группа3, группа4)
Как передать параметры в сисок, чтобы был отбор, например, Группа 1 + Группа 3?



Если группа1 = Истина Тогда
Список.Параметры.УстановитьЗначениеПараметра("Группы", Справочники.ГруппыТоваров.НайтиПоНаименованию("Группа1"));
КонецЕсли

Отбор работает, но как прописать два отбора?
   Ненавижу 1С
 
1 - 29.09.21 - 12:58
(0) ничего непонятно, что такое "Группа 1 + Группа 3" если они булевы?
   Ненавижу 1С
 
2 - 29.09.21 - 12:58
показывайте уже место в запросе, где их используете
   Snail
 
3 - 29.09.21 - 12:59
Булево прилепил вверху формы списка, стобы при нажатии происходил отбор
   Ненавижу 1С
 
4 - 29.09.21 - 13:00
(3) абсолютно все равно что ты там прилипил, тебя не это спрашивают
   Snail
 
5 - 29.09.21 - 13:00
Сейча для пробы в 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Группа1 = истина;

Если группа1 = Истина Тогда
Список.Параметры.УстановитьЗначениеПараметра("Группы", Справочники.ГруппыТоваров.НайтиПоНаименованию("Группа1"));
КонецЕсли
   acht
 
6 - 29.09.21 - 13:09
(5) Ты "место в запросе" от кода 1С отличаешь, турист?
   pechkin
 
7 - 29.09.21 - 13:16
массив групп передавай
   hhhh
 
8 - 29.09.21 - 13:16
(5) Группа1 = истина;

списокГрупп = новый массив;
Если группа1 = Истина Тогда
СписокГрупп.Добавить(Справочники.ГруппыТоваров.НайтиПоНаименованию("Группа1"));
КонецЕсли;
Если группа2 = Истина Тогда
СписокГрупп.Добавить(Справочники.ГруппыТоваров.НайтиПоНаименованию("Группа2"));
КонецЕсли;
Если группа3 = Истина Тогда
СписокГрупп.Добавить(Справочники.ГруппыТоваров.НайтиПоНаименованию("Группа3"));
КонецЕсли;
Если группа4 = Истина Тогда
СписокГрупп.Добавить(Справочники.ГруппыТоваров.НайтиПоНаименованию("Группа4"));
КонецЕсли;
Список.Параметры.УстановитьЗначениеПараметра("Группы", СписокГрупп);
   pechkin
 
9 - 29.09.21 - 13:17
Массив = Новый Массив;
Если группа1 = Истина Тогда
  Массив.Добавить(Справочники.ГруппыТоваров.НайтиПоНаименованию("Группа1"));
КонецЕсли
Если группа2 = Истина Тогда
  Массив.Добавить(Справочники.ГруппыТоваров.НайтиПоНаименованию("Группа2"));
КонецЕсли
Список.Параметры.УстановитьЗначениеПараметра("Группы", Массив);

   Snail
 
10 - 29.09.21 - 13:21
Оргомное спасибо!
   acht
 
11 - 29.09.21 - 13:27
Тогда уж

Массив.Добавить("Группа1");
...
Массив.Добавить("Группа2");
...

И запрос подправить.
   Ненавижу 1С
 
12 - 29.09.21 - 13:37
Это соревнования по говнокодингу?
   acht
 
13 - 29.09.21 - 13:40
По телепатии
   Snail
 
14 - 29.09.21 - 14:23
Еще раз Спасибо!

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.