Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка записи документа

Ошибка записи документа
Я
   kust1985d
 
29.09.21 - 11:14
Подскажите почему вылетает ошибка  
Поле не доступно для записи комментарий

Процедура ПечатьНаСервере()
Перем НомерВ;    
Док = Документы.Товар.Выбрать(Объект.Нач, Объект.Кон);
Пока Док.Следующий() Цикл
Если Док.Проведен=Ложь Тогда
    
    Док.Комментарий=НомерВ;
    Сообщить(Док.Номер);
    Док.Записать();
    Док.Провести();
КонецЕсли;
НомерВ=Док.Номер;

КонецЦикла     
    
КонецПроцедуры
   polosov
 
1 - 29.09.21 - 11:16
(0) Получить объект надо. В ссылку писать не надо.
   kust1985d
 
2 - 29.09.21 - 11:20
Может есть пример
   shuhard
 
3 - 29.09.21 - 11:20
(2) под кнопкой Я их как грязи
   1Сергей
 
4 - 29.09.21 - 11:21
отладка на мисте, национальная забава
   Kassern
 
5 - 29.09.21 - 11:23
(0) крутой документ "Товар"))
А по сабжу ДокОбъект=Док.ПолучитьОбъект();
   Гипервизор
 
6 - 29.09.21 - 11:30
Проводить документы в процедуре печати? Почему бы инет.
   ДенисЧ
 
7 - 29.09.21 - 11:32
(6) Ну, в типовых последовательность в отчётах же восстанавливают...
   Kassern
 
8 - 29.09.21 - 11:33
(0) а давно ли метод  Провести() появился у документа?) Или это будет следующий сюрприз для ТС?)
   acht
 
9 - 29.09.21 - 11:36
(8) Очевидно, там "провести" в смысле "обвести вокруг пальца".
И перепроведение документов начинает играть новыми красками.
   kust1985d
 
10 - 29.09.21 - 11:39
перепутал с  7.7

Записать(РежимЗаписиДокумента.Проведение);
   kust1985d
 
11 - 29.09.21 - 11:40
СП
   acht
 
12 - 29.09.21 - 11:42
(11) Чему равен НомерВ для первого документа?
   lodger
 
13 - 29.09.21 - 11:50
(12) а это важно? пусть будет Неопределено :)
   Kassern
 
14 - 29.09.21 - 12:13
(12) это наверное какой то фетиш писать в комментарий номер прошлого документа из цикла)
   hhhh
 
15 - 29.09.21 - 13:05
(14) ну это какая-то тестовая задача похоже.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.