Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

БП ред 3. После обновления не пускает в конф - Требуется обновить шаблон на актуальную вер

БП ред 3. После обновления не пускает в конф - Требуется обновить шаблон на актуальную вер
Я
   bvn-2005
 
27.09.21 - 10:15
После обновления пользователь с ограниченными правами (кладовщик) не может войти:

Запуск программы невозможен по причине:
{(52, 11)}: Синтаксическая ошибка ":"
Ошибка<<?>>: Требуется обновить шаблон на актуальную версию, поставляемую в роли ИзменениеУчастниковГруппДоступа по причине: Используется устаревшая версия 17 шаблона ограничения доступа ПоЗначениямРасширенный. Объект: "Справочник.Организации", Право: "Чтение"

Роль ИзменениеУчастниковГруппДоступа не трогалась. Проверил - она совпадает с конфигурацией поставщика.

Как быть?
   ДенисЧ
 
1 - 27.09.21 - 10:16
Зайти админом, запустить обработку ОбновлениеВспомогательныхДанных
   bvn-2005
 
2 - 27.09.21 - 10:42
"запустить обработку"
Где взять? В Инструментах разработчика такую не вижу...
   ДенисЧ
 
3 - 27.09.21 - 11:13
(2) В дистре БСП
   VladZ
 
4 - 27.09.21 - 11:14
(2) спроси у гугла.
   Winnie Buh
 
5 - 27.09.21 - 12:42
(0) в типовой БП 3.0 нет такого профиля "Кладовщик" из коробки, т.е. его добавляли вручную или с помощью расширения,
соотвественно после обновления конфигурации проблемы вполне могут быть
   bvn-2005
 
6 - 28.09.21 - 08:22
"в типовой БП 3.0 нет такого профиля "Кладовщик""
Все так. Была скопирована стандартная роль "ДобавлениеИзменениеДанныхБухгалтерии", убрано все ненужное и добавлено несколько проверок RLS чтобы ограничить доступные склады. Получилась роль "Кладовщик".
Удалил роль Кладовщик и точно также создал ее заново. Все заработало. Где и в какой момент задействовалась роль ИзменениеУчастниковГруппДоступа - осталось загадкой...
   z_const
 
7 - 22.10.21 - 09:03
Дополню.

В ролях с шаблоном ограничений есть проверка на версию.

#ИначеЕсли Не СтрСодержит(&ВерсииШаблоновОграниченияДоступа, ",ПоЗначениямРасширенный17,") #Тогда
    Ошибка: Требуется обновить шаблон на актуальную версию, поставляемую в роли ИзменениеУчастниковГруппДоступа по причине: Используется устаревшая версия 17 шаблона ограничения доступа ПоЗначениямРасширенный. Объект: #ИмяТекущейТаблицы, Право: #ИмяТекущегоПраваДоступа.

#Иначе

Поэтому если роль с шаблоном была скопирована, то при такой ошибке идем в типовую роль ИзменениеУчастниковГруппДоступа, копируем шаблон на который ругается система и заменяем его в скопированной роли.

Список тем форума
 
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.