Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не работе отладка на сервере при работе не на сервере

Не работе отладка на сервере при работе не на сервере
Я
   fantomrik
 
24.09.21 - 11:36
Всем привет!
Уже тема сто раз обсуждалась везде и гуглом еще раз поискал и посмотрел но все равно проблема.
Если работать на сервере, где запущена служба 1с, все ок, и клиентская отладка и северна работают.
Но если подключаться с локальной машины или с другого сервера (в локальной сети), серверная отладка не работает, хотя соединение серверное видно.
Пробовали отключать полностью Брандмауер на локальной машине и сервере, все равно не работает удаленная серверная отладка.
Когда то давно было все ок, но потом перестало работать, думаю админы что то сделали, но что они не знаю и не понимаем как найти проблему.
Пробовали по разному ключ отладки прописать и - debug и /debug, безрезультатно.

https://c.radikal.ru/c39/2109/0b/3c3252cb42d6.jpg

https://b.radikal.ru/b38/2109/b7/c453dc42adab.jpg

https://d.radikal.ru/d32/2109/06/bb1c5f066da9.jpg
   Garykom
 
1 - 24.09.21 - 11:42
(0) на последнем скрине тыкни "Настройка" и покажи скрин
   fantomrik
 
2 - 24.09.21 - 11:44
   1Сергей
 
3 - 24.09.21 - 11:46
попробуйте отладку по нттр
   Garykom
 
4 - 24.09.21 - 11:47
и сервер рестартануть с чистой кэша
   Garykom
 
5 - 24.09.21 - 11:47
(4)+ не только сервер 1С а целиком весь сервер где сервер 1С
   fantomrik
 
6 - 24.09.21 - 11:53
(3) c http там свои есть нюансы, пока не можем на нее перейти на этом сервере.
Рестарт пробовали ранее (но может без чистки серв кеша), попробуем еще раз
   Garykom
 
7 - 24.09.21 - 11:55
И хорошо бы убедиться что порты открыты все же и доступны между машинами
   Nexux
 
8 - 24.09.21 - 12:46
Иногда помогает запустить конфигуратор от имени администратора
   fantomrik
 
9 - 24.09.21 - 13:16
(4) Сделали, не помогло (7) Админы посмотрели через telnetom, порты открыты
   fantomrik
 
10 - 24.09.21 - 13:20
(2) Тут видно, что отладчик запущен на той же машине? где открыт конфигуратор. Может тут должен быть путь к отладчику на сервере 1с? Но если так, как поменять этот путь?
   pechkin
 
11 - 24.09.21 - 13:24
Если без галки показывать предметы на компе не видит ничего, а сней видит, то это однозначно файрволл
   Dmitrii
 
12 - 24.09.21 - 13:28
(9) Проверьте ещё раз внимательно открытые порты и корректную их настройку в брандмауэре. Проверьте порты как на сервере так и на клиенте (том компе, где пытаетесь отлаживать).

Если платформа 1С для проведения отладки будет запускаться не на сервере 1С, на стороне клиента должны быть открыты TCP и UDP порты для диапазона 1560-1591.
На стороне сервера должны быть открыты TCP порты 1540, 1541, 1560-1591

Проверьте корректность настроек правил для портов.
Помнится как-то долго не мог понять в чем причина. Оказалось, что для правил исходящих соединений били ограничены локальные порты, а для входящих - удаленные.

Из магических шаманств - проверить, что в соединении корректно указано имя сервера. Если указано server1c.donen.ru, попробовать поменять на server1c (без указания домена). Или наоборот.
   fantomrik
 
13 - 24.09.21 - 13:29
(11) Так без галки он локально смотрит же только, а с галкой на указанном сервере. Брандмауер отключали для теста
   Dmitrii
 
14 - 24.09.21 - 13:53
(13) >> Брандмауер отключали для теста.

С обеих сторон - и на сервере и на клиенте?
В сети дополнительных брандмауэров нет?

Чуде не бывает © (не моё).

Косяк в закрытых или неверно настроенных портах или маршрутизации. Была бы проблема в маршрутизации, 1С бы вообще не могла подключиться с клиента к базе.

Если локально отладка работает, а по сети - нет, то проблема явно не в настройках службы или приложения.
Бывает ещё кэш чудит, но вы утверждаете, что чистили. К тому же пытались запускать с разных машин (если я правильно прочитал(0)).
   fantomrik
 
15 - 24.09.21 - 16:36
Пока не смогли найти решение, перешли на http отладку, с ней работает все
   pechkin
 
16 - 24.09.21 - 16:46
(13) нет конечно же. Именно клиентский файрволл. Кто-то при первом запуске нажал разрешить доступ к сети нет
   1Сергей
 
17 - 24.09.21 - 16:48
так и не увидел версию платформы

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.