Вход | Регистрация
 

Конвертация. Не загружать документы по организации

Конвертация. Не загружать документы по организации
Я
   Надо работать
 
22.09.21 - 11:15
Есть база источник (Reference), в которой формируются документы по двум организациям. Есть две базы с идентичной конфигурацией, каждая по одной организации. План обмена один на обе базы.

Как при загрузке данных вообще не загружать документ по не своей организации?

Используется конвертация редакции 2
   ДенисЧ
 
1 - 22.09.21 - 11:16
ПередВыгрузкойОбъекта в конвертации
Если источник.Организация = Параметры.ВреднаяОрганизация Тогда
отказ = Истина;
КонецЕсли

В параметрах задавать ту, которую не надо выгружать
   Надо работать
 
2 - 22.09.21 - 11:18
(1) а если в пакет попадет два документа по разным организациям, что в Параметры писать? Они же одни на весь пакет
   DimVad
 
3 - 22.09.21 - 11:20
(2) Тогда не перед выгрузкой а перед загрузкой :-)
   Надо работать
 
4 - 22.09.21 - 11:21
(3) да перед выгрузкой не вариант, пакет один общий на обе базы
   DimVad
 
5 - 22.09.21 - 11:21
+(3) А Вас же есть в этих конфигурациях что-то типа "ОсновнаяОрганизация" ? Ну вот.
   Надо работать
 
6 - 22.09.21 - 11:26
(5) есть конечно. Но надо как-то понять в ПередЗагрузкой по какой организации конкретный документ
   ДенисЧ
 
7 - 22.09.21 - 11:26
Какой пакет, к Морготу в Ангбанд?
   Мультук
 
8 - 22.09.21 - 11:29
(0)  План обмена один на обе базы.

А узел тоже один на две базы?
Чем не устроило типовое решение с двумя узлами и т.п. ? (примеров куча)
   Надо работать
 
9 - 22.09.21 - 11:33
(8) узел тоже один.

Там очень много справочных данных, общих на все базы, а документов единицы, не хотелось бы два раза конвертировать
   Мультук
 
10 - 22.09.21 - 11:40
(9)

В пятницу (например) идет обмен
1) Выгрузка из главного узла
2) Загрузка/выгрузка в дочка1. Успешно
3) Загрузка/выгрузка в дочка2. Неудача (куча причин)
4) Загрузка в главный ответа из дочка1. Очистка регистраций изменения

В понедельник оказывается, что обмен в дочку2 так и не прошел, а что там выгружалось уже неизвестно (узел то один)
После этого начинается анализ ЖР, анализ версионирования и прочие бесполезные пляски с бубном.

Но вам виднее на месте.
   ДенисЧ
 
11 - 22.09.21 - 11:42
(9) "узел тоже один"
Кто такую схему создал? Ты? Надеюсь, ты уже бежишь в ОК с заявлением об увольнении по профнепригодности?
   Надо работать
 
12 - 22.09.21 - 11:45
(11) надеюсь, ты работал когда-то с несколькими базами по паре терабайт каждая, будешь профпригодные советы давать
   Надо работать
 
13 - 22.09.21 - 11:59
Вообще, конечно, документы стоит вынести в отдельный план обмена, но это возня с транспортом
   ДенисЧ
 
14 - 22.09.21 - 12:04
(12) Работал. Дальше развивай свою мысль.
   hhhh
 
15 - 22.09.21 - 12:27
(12) ну уже разбирались, кто виноват, что база разрослась до 2 терабайт? Как вычислите, сразу пристрелите гада.
   Aleksey
 
16 - 22.09.21 - 12:52
А если поменять организацию?
   Мультук
 
17 - 22.09.21 - 13:13
(0)

"После загрузки" в конвертации

Если источник.Организация <> Параметры.ОрганизацияВбазеПриемнике Тогда
отказ = Истина;
КонецЕсли;

P.S.
По документации. Не проверял.
   Мультук
 
18 - 22.09.21 - 13:13
(15) Почему разрослась?
Быть может это ее натуральный цвет ? (с)
   Надо работать
 
19 - 22.09.21 - 14:58
(17) Спасибо. Был уверен что После загрузки это уже после записи, соотв. никакого Отказа не может быть
   Надо работать
 
20 - 22.09.21 - 15:06
(18) клиенты, сволочи, все заказывают и заказывают
   pechkin
 
21 - 22.09.21 - 15:09
лучше 2 пакета выгрузки делать
   Pro-tone
 
22 - 22.09.21 - 15:12
(0) самый лучший и правильный вариант - создать 2 узла в плане обмена под каждую организацию и регать с отбором по ним
   Aleksey
 
23 - 22.09.21 - 16:04
(19) из справки в конвертации
После загрузки

Условия возникновения события

Только для платформы V8.
Событие выполняется после прочтения и установки атрибутов объекта из файла, но до его записи в информационную базу. Возможна модификация загруженного объекта.

Параметры:

Отказ - Булево - Если Истина, то объект загружен не будет.
   Shur1cIT
 
24 - 22.09.21 - 17:07
Вариант 1 перед выгрузкой
Если Объект.Организация <> моя организация Тогда
    Отказ = Истина;
КонецЕсли;
Вариант 2 тоже самое только "После загрузки"
Если Объект.Организация <> моя организация Тогда
    Отказ = Истина;
КонецЕсли;

в первом случае не выгружаем, во втором не записываем при загрузке
   Aleksey
 
25 - 23.09.21 - 15:06
(24) А что делать со справочниками? Договора, организации


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.