Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Помогите распутаться с галками модулей, сервер/клиент/вызовсервера

Помогите распутаться с галками модулей, сервер/клиент/вызовсервера
Я
   seperblunt2
 
21.09.21 - 13:21
Всем привет.

Конфа работает на обычных формах, я делаю управляемую для одного документа.

проблема в том, что при попытке выбрать номенклатуру в табл часть - ругается на модуль менеджера (он оказывается инициализируется даже когда просто делаю выбор в форме подбора).

ругается на метод общего модуля - типа метод не найден.


метод такой:

#Если Сервер И НЕ Клиент И НЕ ВнешнееСоединение Тогда

Функция глЗначениеПеременной(Имя) Экспорт
    
    Кэш = ПараметрыСеанса.ОбщиеЗначения.Получить();
    КэшИзменен = Ложь;
    ПолученноеЗначение = ОбщегоНазначения.ПолучитьЗначениеПеременной(Имя, Кэш, КэшИзменен);
    
    Если КэшИзменен Тогда
        ПараметрыСеанса.ОбщиеЗначения = Новый ХранилищеЗначения(Кэш);
    КонецЕсли;
    
    Возврат ПолученноеЗначение;
    
КонецФункции

#КонецЕсли


стоят галки общ модуля:
Сервер
Клиент (обычное приложение)
Вызов сервера..


не пойму почему ругается, модуль менеджера - работает ведь на сервере (?), вызываю метод из серверного общ. модуля..

вобщем распутайте пжл
   seperblunt2
 
1 - 21.09.21 - 13:22
а сама ругань при попытки выбрать номенклатуру в табл часть:

Справочник.Номенклатура.МодульМенеджера(2678,39)}: Процедура или функция с указанным именем не определена (глЗначениеПеременной)
    НовыйДок.Ответственный             = <<?>>глЗначениеПеременной("глТекущийпользователь");
   pechkin
 
2 - 21.09.21 - 13:23
в толстом - работает на клиенте
   pechkin
 
3 - 21.09.21 - 13:24
а у тебя она только на сервере
   seperblunt2
 
4 - 21.09.21 - 13:24
да, в толстом все ок, и что удивительно  - в веб клиенте тоже все ок... не работает только тонкий
   Filin
 
5 - 21.09.21 - 13:25
(0) "модуль менеджера - работает ведь на сервере" - нет, не обязательно. В неуправляемом (обычном) приложении все модули, которые могут быть скомпилированы на клиенте, будут на клиенте. Твой модуль менеджера тоже. А ты вырезал из него кусок при компиляции директивами.
   seperblunt2
 
6 - 21.09.21 - 13:28
(5) тьфу точняк, у меня упр формы в толстом просто открыты были..

всем спасибо, все понял

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.