Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Удаление изображения из колонтитула в документе Word

Удаление изображения из колонтитула в документе Word
Я
   rene_den
 
21.09.21 - 10:44
День добрый,
Господа пытаюсь найти способ удалить изображение из колонтитула в документе Word.
Может кто то уже имел опыт и подскажет как это сделать.

Пробовал удалить саму закладку но удаляется только ссылка на нее сама картинка остается:
Headers = WordDoc.Sections(1).Headers;    //КоллекцияКолонтитулов

Для Сч = 1 По Headers.Count Цикл
    Range = Headers.Item(Сч).Range;
    Если Range.Bookmarks.Exists("Лого1") Тогда
        Range.Bookmarks("Лого1").Delete();            
    КонецЕсли;
КонецЦикла;

Пробовал выбрать картинку но не получается позиционироваться на ней и выполнить Select().
   rene_den
 
1 - 21.09.21 - 11:07
Для Сч = 1 По Headers.Count Цикл
    Range = Headers.Item(Сч).Range;
    Range.Delete();   
КонецЦикла;        

Так удаляется весь колонтитул. А вот выбрать картинку или закладку в нем для удаления не получается.
   Масянька
 
2 - 21.09.21 - 12:01
(1) Буквально вчера была тема - Удаление закладки из колонтитула в документе Word
PS Такой большой, а гуглить не умеет 😯
   rene_den
 
3 - 21.09.21 - 12:05
Да была и там была подобная задача, разобрались и выложил рабочий вариант.
Теперь другая. И тоже нет инфо, а найдем решение и будет.
   rene_den
 
4 - 24.09.21 - 15:51
В общем удалить у меня не получилось. Получилось только уменьшить до 0.
    Headers = WordDoc.Sections.Item(1).Headers;    //КоллекцияКолонтитулов

    
        Для Сч = 1 По Headers.Count Цикл
            Range = Headers.Item(Сч).Range;
            Попытка
                Range.InLineShapes(2).Width = 1;
                Range.InLineShapes(2).Height = 1;
                Range.InLineShapes(2).Line.Visible = 0;
            Исключение
            КонецПопытки;
        КонецЦикла;    

При этом вот эта строка тут лишня как по мне - но без нее не отрабатывает: Range.InLineShapes(2).Line.Visible = 0;
   rene_den
 
5 - 24.09.21 - 15:53
2 это номер строки в колонтитуле

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.