Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Внешняя обработка как регламент. Руками запуск работает, регламент - нет

Внешняя обработка как регламент. Руками запуск работает, регламент - нет
Я
   OldCondom
 
20.09.21 - 12:17
Подключил внешнюю обработку(тестовая отправка письма на почту), если зайти во внешние обработки, там выбрать подключенную и нажать "выполнить", все работает, письмо отправляется и я его вижу. Включаю расписание, смотрю ЖР, фоновое задание отрабатывает без ошибок. А письма нет.

Куда отладчик ставить тоже не очень понятно.

На всякий случай полный текст обработки

// Функция возвращает сведения о внешней обработке.
Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка());
    ПараметрыРегистрации.Вставить("Наименование", "РассылкаЗадолженности");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    ПараметрыРегистрации.Вставить("Информация", "Рассылка задолженности");
    
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд,
    "Рассылка задолженности",
    "РассылкаЗадолженности",
    "ВызовСерверногоМетода");
    
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
    
КонецФункции


Функция ПолучитьТаблицуКоманд()
    
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    
    Возврат Команды;
    
КонецФункции


Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
    
КонецПроцедуры


Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполнения = Неопределено) Экспорт
    
    Письмо = Новый ИнтернетПочтовоеСообщение;
    Письмо.Тексты.Добавить("Тест задолженности");
    Письмо.Получатели.Добавить("адрес почты . ру");
    
    Учетки = РаботаСПочтовымиСообщениями.ДоступныеУчетныеЗаписи();
    РаботаСПочтовымиСообщениями.ОтправитьПисьмо(Учетки[2].Ссылка, Письмо);
    
КонецПроцедуры
   серый КТУЛХУ
 
1 - 20.09.21 - 12:21
на сервере разрешить отладку.
в отладчике пойти в автоподключение, поставить галку на фоновых процессах, поставить брейкпойнт в нужном месте.
и запустить этот фоновый процесс через консоль заданий (если по расписанию ждать влом или оно не настроено).
   серый КТУЛХУ
 
2 - 20.09.21 - 12:22
а потом shift+F9 наше всё....
   Галахад
 
3 - 20.09.21 - 12:27
Это случайно не клиентская функция? "ДоступныеУчетныеЗаписи"
   OldCondom
 
4 - 20.09.21 - 12:28
(3) да вроде нет. Это из БСП
 Доступность
 Сервер, Толстый клиент, Внешнее соединение

ковыряюсь пока отладчиком..
   Галахад
 
5 - 20.09.21 - 12:31
(4) Не правильно выразился. Доступные каком-то конкретному пользователю?
   OldCondom
 
6 - 20.09.21 - 12:31
(5) Все, вы были правы. Только что провалился туда, нет там моей учетки.
Спасибо!

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.