Вход | Регистрация
 

УФ открыть отчет из доп отчетов и обработок с параметрами для скд

УФ открыть отчет из доп отчетов и обработок с параметрами для скд
Я
   lamme
 
17.09.21 - 11:30
в доп отчетах лежит отчет на скд.

у него в  модуле задается период выполнения отчета

НачалоОтчета    = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.ДатаНачала;
ОкончаниеОтчета    = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.ДатаОкончания;

я хочу открыть отчет - с указанием периода программно извне

&НаКлиенте
Процедура Команда1(Команда)
    ПараметрыОтчета = Новый Структура;
    ПараметрыОтчета.Вставить("СформироватьПриОткрытии", Истина);
    
    ОткрытьВнешнийОтчетОбработкуПоИмениСДопПараметрами("Сформировать остатки за период",ПараметрыОтчета,Истина,);
КонецПроцедуры




&НаКлиенте

Процедура ОткрытьВнешнийОтчетОбработкуПоИмениСДопПараметрами(ИмяОтчетаОбработки, ПараметрыОткрытия, ЭтоОтчет, РодительскаяФорма =Неопределено)
    ВнешнийОтчетОбработкаДляОткрытияСсылка = ПолучитьСсылкуНаВнешнийОтчетОбработкуПоИмениНаСервере (ИмяОтчетаОбработки);  
     // ВЫЗОВ ИЗ БСП ФУНКЦИИ ПОДКЛЮЧЕНИЯ ВНЕШНЕЙ ОБРАБОТКИ
    ИмяОбработкиСлужебное =ДополнительныеОтчетыИОбработкиВызовСервера.ПодключитьВнешнююОбработку(ВнешнийОтчетОбработкаДляОткрытияСсылка);
    Если ЭтоОтчет Тогда
        ОткрытьФорму("ВнешнийОтчет." + ИмяОбработкиСлужебное + ".Форма", ПараметрыОткрытия, РодительскаяФорма);
    Иначе
        ОткрытьФорму("ВнешняяОбработка." + ИмяОбработкиСлужебное + ".Форма", ПараметрыОткрытия, РодительскаяФорма);
    КонецЕсли;
КонецПроцедуры



Как указать перниод - за который хочу построить отчет?
   lamme
 
1 - 17.09.21 - 11:33
ПараметрыОтчета = Новый Структура;
    ПараметрыОтчета.Вставить("СформироватьПриОткрытии", Истина);
    
    
    
    ПараметрыОтчета.Вставить("НачалоОтчета",  НачалоМесяца(ТекущаяДата()));
    ПараметрыОтчета.Вставить("ОкончаниеОтчета",  ТекущаяДата());

    ОткрытьВнешнийОтчетОбработкуПоИмениСДопПараметрами("Эльба: Отчет о текущем состоянии",ПараметрыОтчета,Истина,);

так не всегда работает
вернее
так работает через раз
   ДенисЧ
 
2 - 17.09.21 - 11:33
Так же, как и просто форму с отборами
https://1c-programmer-blog.ru/programmirovanie/kak-otkryt-formu-s-otborom.html
   lamme
 
3 - 17.09.21 - 11:38
Спасибо

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.