Вход | Регистрация
 

Добавление кнопки удаления значений в полях

Добавление кнопки удаления значений в полях
Я
   NIGHTHUNTER
 
15.09.21 - 16:37
Общая форма СКД, на ней перерисовываются в зависимости от выбора макета параметры.
Они как то делаются на форме программно. Вопрос в том можно ли этим полям добавить кнопку очистки. Крестик ?
   NIGHTHUNTER
 
1 - 15.09.21 - 16:38
   Вафель
 
2 - 15.09.21 - 16:40
делай отбор, а не параметр
   NIGHTHUNTER
 
3 - 15.09.21 - 16:41
(2) то есть не параметры в запросе, а отборы в настройках СКД ?

Ясно, буду заниматься.
   NIGHTHUNTER
 
4 - 16.09.21 - 06:10
Я, когда были параметры. Делал проверку. На то что бы они все были заполнены. А как быть если я сделаю отборы в насройках СКД ?
Пока не могу найти, где задать им проверку.
    ВсеПараметрыЗаполнены = Истина;
    Для Каждого СтрПарам Из ПараметрыФормирования.ПользовательскиеНастройкиКД.Элементы Цикл
        Если Не ЗначениеЗаполнено(СтрПарам.Значение) Тогда
            ВсеПараметрыЗаполнены = Ложь;
        КонецЕсли;
    КонецЦикла;
    //

    Если ВсеПараметрыЗаполнены = Ложь Тогда
        Сообщить("Не все параметры заполнены !");
        Возврат Неопределено;
    КонецЕсли;
   NIGHTHUNTER
 
5 - 16.09.21 - 08:01
(2) Скажите а как использование отборов, повлияет на крестик у поля установки значения? Его же там все равно нет, и как сделать не понятно.
   banco
 
6 - 16.09.21 - 08:55
(0) "Они как то делаются на форме программно"
Найти место и дописать 
ТвоеПоле.КнопкаОчистки = Истина;
   NIGHTHUNTER
 
7 - 16.09.21 - 09:08
(6) А если эти поля как то програмно генерируются?
то есть тоггда искать как это происходит, и там делать как вы сказали?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.