Вход | Регистрация
 

Получить имя эл-та перечисления в цикле

Получить имя эл-та перечисления в цикле
Я
   Dirk Diggler
 
14.09.21 - 16:41
Как получить имя(не синоним!) элемента перечисления при обходе перечисления в цикле:

для каждого элтПеречисления из Перечисления.DX_ЧеклистПроверки цикл
КонецЦикла

?

Метаданные().Имя дает имя самого перечисления, что логично. Как получить имя именно элемента, не внося его в синоним и другие поля?
   asady
 
1 - 14.09.21 - 16:45
(0) XMLString(элтПеречисления)
   Dirk Diggler
 
2 - 14.09.21 - 16:46
(1) Работает. Огромное спасибо
   Ненавижу 1С
 
3 - 14.09.21 - 16:47
Для каждого Значение из Метаданные.Перечисления.СтавкиНДС.ЗначенияПеречисления Цикл

    Сообщить(Значение.Имя);

КонецЦикла;
   Kassern
 
4 - 14.09.21 - 16:48
(0) элтПеречисления.Метаданные().Имя
   Dirk Diggler
 
5 - 14.09.21 - 16:49
(4) так получишь только имя самого перечисления.
   Kassern
 
6 - 14.09.21 - 16:49
(5) А точно, тогда XMLСтрока(ТвоеПеречисление)
   Kassern
 
7 - 14.09.21 - 17:04
(5) но если принципиально дергать метаданные то можно вот так попробовать)
    ЗначенияПеречисленияМетаданные=Метаданные.Перечисления.DX_ЧеклистПроверки.ЗначенияПеречисления;
    Для к=0 По Перечисления.DX_ЧеклистПроверки.Количество()-1 Цикл
        ИмяЭлемента=ЗначенияПеречисленияМетаданные.Получить(к).Имя;
    КонецЦикла;

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.