Вход | Регистрация
 

Ошибка при открытии отчета СКД

Ошибка при открытии отчета СКД
Я
   NIGHTHUNTER
 
14.09.21 - 15:17
Почему идет ошибка на открытии отчета? Было "ВыбратьМакет", шла таже ошибка. Поменял на "ВыбратьМакет_Команда", ошибка таже.
Как нужно правильно ? Что бы не было ошибки, и почему она происходит?


Недопустимое значение
{ВнешнийОтчет.Форма.ФормаОтчетаБСП.Форма(138)}:    Кнопка.ИмяКоманды = "ВыбратьМакет_Команда";

по причине:
Недопустимое значение


    //нарисуем кнопку
    Кнопка                 = Элементы.Добавить("ВыбратьМакет", Тип("КнопкаФормы"), Элементы.ОсновнаяКоманднаяПанель);
    Кнопка.Вид             = ВидКнопкиФормы.КнопкаКоманднойПанели;
    Кнопка.ИмяКоманды      = "ВыбратьМакет_Команда";
    //заполним список макетов
    //макеты отбираем строго по типу СхемаКомпоновкиДанных, дабы в список не попали печатные макеты, двоичные данные и прочее
    ОтчетОбъект            = РеквизитФормыВЗначение("Отчет");
    СписокСхем.Очистить();
    Для Каждого Макет из ОтчетОбъект.Метаданные().Макеты Цикл
        Если Макет.ТипМакета = Метаданные.СвойстваОбъектов.ТипМакета.СхемаКомпоновкиДанных Тогда
            СписокСхем.Добавить(Макет.Имя, Макет.Синоним);
        КонецЕсли;
    КонецЦикла;
    Если СписокСхем.Количество() = 0 Тогда
        Отказ = Истина;
        Возврат;
    КонецЕсли;
    //выберем первый из макетов в качестве "начального"
    ВыбратьМакетЗавершениеНаСервере(Новый Структура("Значение, Представление", СписокСхем[0].Значение, СписокСхем[0].Представление));    
    // <-
    //
КонецПроцедуры
   NIGHTHUNTER
 
1 - 14.09.21 - 15:48
Никто не знает, почему тут ошибка ?
Кнопка.ИмяКоманды      = "ВыбратьМакет_Команда";
   DrShad
 
2 - 14.09.21 - 15:53
у тебя нет такой команды
   NIGHTHUNTER
 
3 - 14.09.21 - 15:53
Это (0) делается вот в этой процедуре, при открытии отчета, -

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   NIGHTHUNTER
 
4 - 14.09.21 - 15:54
(2) По теории она програмно же создается, код выше. делал по примеру.
То есть чт ото добавлять нужно видимо. Не все явно описано, до половины нужно догадаться.
   kobzon2
 
5 - 14.09.21 - 16:02
(4) Тебе специально комментарий написали //нарисуем кнопку. Где команда программно создается?
   NIGHTHUNTER
 
6 - 15.09.21 - 05:57
(5) Что то не понял значит, буду сейчас исправлять ситуацию!
   NIGHTHUNTER
 
7 - 15.09.21 - 06:28
Создал команду 

ВыбратьМакет_Команда

А ее обработчик какой создавать?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.