Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Некорректно открывается файл *.xlsx на веб клиенте. Ошибка: Редактирование uid.xlsx запрещ

Некорректно открывается файл *.xlsx на веб клиенте. Ошибка: Редактирование uid.xlsx запрещ
Я
   1Ckadeveloper
 
14.09.21 - 13:51
1. Конфигурация Управление торговлей, редакция 11 (11.4.13.275), база опубликованная на апаче, браузер Google Chrome, расширение на нем установил для работы с файлами (проверил - работает).
2. Есть расширение для конфигурации и там макет у документа, я открываю его в веб клиенте, таким кодом:  

&НаКлиенте
Процедура ПодключенияРасширенияЗавершение(РасширениеПодключено, ДополнительныеПараметры) Экспорт
    
    Если РасширениеПодключено Тогда
        
        ИмяФайла = Строка(Новый УникальныйИдентификатор) + ".xlsx";
        ДополнительныеПараметры = Новый Структура();
        ДополнительныеПараметры.Вставить("ИмяФайла", ИмяФайла);
        
        НачатьПолучениеКаталогаВременныхФайлов(Новый ОписаниеОповещения("ПолучитьКаталогВременныхФайловЗавершение", ЭтотОбъект, ДополнительныеПараметры));
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПолучитьКаталогВременныхФайловЗавершение(ИмяКаталогаВременныхФайлов, ДополнительныеПараметры) Экспорт
    
    Макет = ПолучитьШаблонExcelНаСервере();
    ИмяВременногоФайла = ИмяКаталогаВременныхФайлов + ДополнительныеПараметры.ИмяФайла;
    ИмяКаталогаВременныхФайловРеквизит = ИмяКаталогаВременныхФайлов;  
    ДополнительныеПараметры.Вставить("ИмяВременногоФайла", ИмяВременногоФайла);
    ДополнительныеПараметры.Вставить("ИмяКаталогаВременныхФайлов", ИмяКаталогаВременныхФайлов);
    Макет.НачатьЗапись(Новый ОписаниеОповещения("ЗаписьДвоичныхДанныхЗавершение", ЭтотОбъект, ДополнительныеПараметры), ИмяВременногоФайла);
    
КонецПроцедуры

&НаКлиенте
Процедура ЗаписьДвоичныхДанныхЗавершение(ДополнительныеПараметры) Экспорт
    
    НачатьЗапускПриложения(Новый ОписаниеОповещения("НачатьЗапускПриложенияЗавершение", ЭтотОбъект), ИмяВременногоФайла, ИмяКаталогаВременныхФайловРеквизит);
    
КонецПроцедуры

&НаКлиенте
Процедура НачатьЗапускПриложенияЗавершение(КодВозврата, ДополнительныеПараметры) Экспорт
    
    //Заглушка
    
КонецПроцедуры

3. При открытии файла возникает ошибка (скриншоты лучше смотреть по очереди 1, 2, 3):
3.1. https://disk.yandex.ru/i/SKiXUoSFLd8kjw
3.2. https://disk.yandex.ru/i/YQJnsTZ_uhcgOQ
3.3. https://disk.yandex.ru/i/FyW_TeF6p43kqQ

4. В чем может заключаться проблема?
   1Ckadeveloper
 
1 - 14.09.21 - 13:54
Помогите пожалуйста :(
   1Ckadeveloper
 
2 - 14.09.21 - 15:26
памагите
   piter3
 
3 - 14.09.21 - 15:27
надеюсь это тестовые данные на последнем скрине
   Kassern
 
4 - 14.09.21 - 15:29
(3) судя по номеру телефона и имени конторы, то очень похоже на тестовые
   Kassern
 
17 - 17.09.21 - 11:37
завязывайте флудить тут.
   1Ckadeveloper
 
18 - 17.09.21 - 15:50
С файлом все в порядке, с ним каких проблем нет, есть подозрения, что антивирус суету наводит с файлом, но это тоже проверил и отключил его на всякий случай. Без понятия в чем дело.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.