Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обмен не РИБ! Как сравнить реквизит документа источника и текущим объектом в этом узле?

Обмен не РИБ! Как сравнить реквизит документа источника и текущим объектом в этом узле?
Я
   Обработка
 
14.09.21 - 07:58
В старом УТ2 (аналог УТ10)... есть обмен не-РИБ-овская.
Документ (самописный) с авторегистрацией бегают по обмену туда сюда.
У документа есть реквизит "Статус" 6-7 значений типа справочник.
Как при обмене сравнив этот реквизит принимать или отказывать в приеме?
   Mankubus
 
1 - 14.09.21 - 08:01
Если Объект.Статус = Объект.Ссылка Статус ТОГДА
Отказ = Истина;
КонецЕсли;

   Василий Алибабаевич
 
2 - 14.09.21 - 08:08
(0) В модуле объекта в обработчике ПриЗаписи. Запись в РИБ определяется значением реквизита Объекта "Загрузка". При обмене оно устанавливается в Истина.

ЗЫ. Но идея очень хреновая. Поскольку порядок объектов ничем не гарантируется можно напороться на запись, например, подчиненных элементов справочника когда Владелец еще не записан. И по логике ТС записан вообще не будет. Так же будут записаны наборы регистров... А регистратор при записи получит отлуп. В общем нужно что-то в консерватории менять.
   Обработка
 
3 - 14.09.21 - 08:11
(1) Скрее всего может так?
Процедура ПриПолученииДанныхОтПодчиненного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
    
      ........
     Если ЭлементДанных.Статус = ЭлементДанных.Ссылка.Статус  Статус ТОГДА

          //Отказ тут не подойдет . Нужно команда игнорирования...

     КонецЕсли;
КонецПроцедуры
   Обработка
 
4 - 14.09.21 - 08:36
Кстати если не риб то работает ПриПолученииДанныхОтГлавного и ПриПолученииДанныхОтПодчиненного ???
   hhhh
 
5 - 14.09.21 - 08:50
(4) не, главный это ведь только у риб. у не-РИБ нет главных.
   Василий Алибабаевич
 
6 - 14.09.21 - 08:54
(5) "у не-РИБ нет главных." На самом деле есть.
   Обработка
 
7 - 14.09.21 - 09:50
Вместе с доком еще РС мигрирует со статусами.
И обмен каждые 5 мин.
Странно что срез последних РС не совпадает с реквизитом документа.
В общем тут надо копать и копать
   Василий Алибабаевич
 
8 - 14.09.21 - 09:51
(7) Срез не передается. Передается набор записей.
   Обработка
 
9 - 14.09.21 - 09:54
(8) Конечно же да. Но в базе на текущий момент запустил сравнение и увидел кучу не совпадений.

ВЫБРАТЬ
    ИсторияИзмененияСтатусовЗаказаСрезПоследних.Период КАК Период,
    ИсторияИзмененияСтатусовЗаказаСрезПоследних.ЗаказПокупателя КАК ЗаказПокупателя,
    ИсторияИзмененияСтатусовЗаказаСрезПоследних.Ответственный,
    ИсторияИзмененияСтатусовЗаказаСрезПоследних.СтатусЗаказа,
    ЗаказНаПеремещение.Ссылка,
    ЗаказНаПеремещение.Статус
ИЗ
    РегистрСведений.ИсторияИзмененияСтатусовЗаказа.СрезПоследних КАК ИсторияИзмененияСтатусовЗаказаСрезПоследних
        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказНаПеремещение КАК ЗаказНаПеремещение
        ПО ИсторияИзмененияСтатусовЗаказаСрезПоследних.ЗаказПокупателя = ЗаказНаПеремещение.Ссылка
ГДЕ
    ИсторияИзмененияСтатусовЗаказаСрезПоследних.Период > &Период
    И ЗаказНаПеремещение.Статус <> ИсторияИзмененияСтатусовЗаказаСрезПоследних.СтатусЗаказа
    И ЗаказНаПеремещение.Дата > &Период

УПОРЯДОЧИТЬ ПО
    Период,
    ЗаказПокупателя
   Василий Алибабаевич
 
10 - 14.09.21 - 10:08
(9) Не понял смысла запроса. Но это уже никак не связано с процессом обменами. Если есть артефакты - смотреть логику выборки и записи передаваемых объектов.
   Обработка
 
11 - 14.09.21 - 10:15
(10)  ДА конечно это с обменом не связано. Я просто пока пытаюсь анализировать почему так происходит.
Идет ли перезапись при обмене итп.

Эврика! Но пришла идея! Могу ведь по срезу последних делать изменения даже без обмена!
Тем более не срез передается в сам набор а набор это актульный статус!
   Serg_1960
 
12 - 14.09.21 - 10:23
Имхо, если это не РИБ-обмен, то - универсальный обмен - в правилах конвертации надо ловить Ваши статусы :)

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.