Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обновление УПП 1.3.165.2. Ошибка при проведении Документ.РеализацияТоваровУслуг

Обновление УПП 1.3.165.2. Ошибка при проведении Документ.РеализацияТоваровУслуг
Я
   Ivanich
 
13.09.21 - 12:22
Обновился с 1.3.165.1 до 1.3.165.2 Перестали проводиться документы РТиУ
Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{Документ.РеализацияТоваровУслуг.МодульОбъекта(3815)}: Значение не является значением объектного типа (Колонки)
   Ivanich
 
1 - 13.09.21 - 12:26
Прослеживаемые товары НЕ используем.
   Ivanich
 
2 - 13.09.21 - 12:36
Похоже ошибка начинается здесь:
Функция ТекстЗапросаПрослеживаемыеТовары(НомераТаблиц, ПараметрыПроведения, Реквизиты) Экспорт
    
    Если Не Реквизиты.ЕстьТовары
        ИЛИ Не Реквизиты.ВедетсяУчетПрослеживаемыхТоваров Тогда
        ПараметрыПроведения.Вставить("ВТ_Прослеживаемость",    Неопределено);
        ПараметрыПроведения.Вставить("ВТ_СуммыБезНДС",         Неопределено);
        ПараметрыПроведения.Вставить("ПрослеживаемыеОперации", Неопределено);
        ПараметрыПроведения.Вставить("ПрослеживаемыеТовары",   Неопределено);
        ПараметрыПроведения.Вставить("ПрослеживаемыеТоварыРеализованные",   Неопределено);
        Возврат "";
    КонецЕсли;

и уже в модуле объекта документа РТиУ ошибка на строке:
Если НЕ ПараметрыПроведения.ПрослеживаемыеОперации.Колонки.Найти("НомерДокумента") = Неопределено Тогда
   DrShad
 
3 - 13.09.21 - 12:42
продолжайте наблюдения, держите нас в курсе
   Ivanich
 
4 - 13.09.21 - 12:54
Включил флажок "Вести учет прослеживаемых товаров с " 01.07.21
ошибка исчезла.

Если нет прослеживаемых товаров, то ждем следующий релиз.
   Смотрящий от 1С
 
5 - 13.09.21 - 12:56
(2) закомментировал в модуле документа РТИУ со строки 4164
//Если НЕ ПараметрыПроведения.ПрослеживаемыеОперации.Колонки.Найти("НомерДокумента") = Неопределено Тогда       //глюк обновления  13092021

        //Для Каждого СтрокаТаблицы Из ПараметрыПроведения.ПрослеживаемыеОперации Цикл

        //    СтрокаТаблицы.НомерДокумента = ОбщегоНазначения.ПолучитьНомерНаПечать(Ссылка);

        //КонецЦикла;

    //КонецЕсли;



+ ошибка в документе ПТИУ в строке 3591 модуля объекта. Вернул как было

//ПлательщикНДС = УчетнаяПолитикаРегл.СистемаНалогообложения = Перечисления.СистемыНалогообложения.Общая;  // 13.09.2021    ощшибка при обновлении 13.09.2021

    ПлательщикНДС = СтруктураШапкиДокумента.УчитыватьНДС;
   Ivanich
 
6 - 13.09.21 - 16:50
Ответ из 1С
Добрый день.
Зарегистрирована ошибка 00-00397285.
Документ РеализацияТоваровУслуг, модуль объекта

После объявления процедуры:
Процедура ДвиженияПоРегистрамПрослеживаемыхТоваров(УсловияПрослеживаемости, СтруктураШапкиДокумента)

добавить проверку:
    Если Не УсловияПрослеживаемости.ВедетсяУчетПрослеживаемыхТоваров Тогда
        Возврат;
    КонецЕсли;
   Serg_1960
 
7 - 13.09.21 - 17:09
(5) Эта ошибка (получение значения для "ПлательщикНДС") растиражирована и по другим документам УПП.
PS: Вы не совсем корректно "исправили" ошибку.
   Ivanich
 
8 - 13.09.21 - 17:38
(5) А как проявляется ошибка (ПлательщикНДС)?
   Смотрящий от 1С
 
9 - 13.09.21 - 18:06
(7) согласен. Грубая заплатка. Мой чуткий сон был прерван звонком с производства. Встала приемка. Просто вернул как было до обновления. Ранее ПлетельщикНДС был булевом из шапки. Сейчас они его сделали значением перечисления "СистемыНалогообложения.Общая".
   Смотрящий от 1С
 
10 - 13.09.21 - 19:08
(8) Нашел еще переопределение ПлательщикНДС в модуле объекта Корректировка приобретения. Находится в процедуре ДвиженияПоРегистрамПрослеживаемыхТоваров. Вываливалось при проведении документа с ошибкой "Значение не является значением объектного типа СистемаНалогообложения"
   Mikhail Volkov
 
11 - 13.09.21 - 20:00
(4) Где этот флажок? Если добавить проверку (6), то не надо?
   Mikhail Volkov
 
12 - 13.09.21 - 20:04
(10) > Нашел еще переопределение ПлательщикНДС в модуле объекта Корректировка приобретения.
Только в Корректировка приобретения нашел, где еще?
   assasu
 
13 - 14.09.21 - 04:38
(0) расскажи лучше в чем такая необходимость обновляться с 1.3.165.1 до 1.3.165.2 ? Или я могу угадать - дернулся и не захотел сидеть на 1.3.164 ? Теперь вот из одой крайности в другую.
   ILM
 
14 - 14.09.21 - 06:27
(13) Так ошибку задваивания движений в ТН и Списании товаров исправили в 1.3.165.2
   alkras
 
15 - 14.09.21 - 07:01
Не формируется Декларация НДС (раздела 8) из за ошибки в книге покупок
В отчете КнигаПокупок1137 процедура СформироватьОсновнойРаздел при условии формирования декларации по версии постановления 4 используются области макета для версии 5
Необходимо перенести часть строк в условие применения версии 5.

Код:
Если СтруктураПараметров.ЗаполнениеДекларации Тогда
                        ОбластьСтрокиДляПовтора = Макет.ПолучитьОбласть("СтрокиДляПовтора");
                        СтруктураСекций.Вставить("ШапкаРаздел8", Макет.ПолучитьОбласть("ШапкаРаздел8"));
                        СтруктураСекций.Вставить("СтрокиДляПовтора", ОбластьСтрокиДляПовтора);
                        ОбластьСтрокиДляПовтора.Область("НомераГрафКнига").Видимость = Ложь;                 ******
                        
                        Если СтруктураПараметров.ВерсияПостановленияНДС1137 >= 5 Тогда
                                    ОбластьСтрокиДляПовтора.Область("НомераГрафДекларация81").Видимость = Ложь;
                        КонецЕсли;

заменить на 

Если СтруктураПараметров.ЗаполнениеДекларации Тогда
                        ОбластьСтрокиДляПовтора = Макет.ПолучитьОбласть("СтрокиДляПовтора");
                        СтруктураСекций.Вставить("ШапкаРаздел8", Макет.ПолучитьОбласть("ШапкаРаздел8"));
                        СтруктураСекций.Вставить("СтрокиДляПовтора", ОбластьСтрокиДляПовтора);
                        
                        Если СтруктураПараметров.ВерсияПостановленияНДС1137 >= 5 Тогда
                             ОбластьСтрокиДляПовтора.Область("НомераГрафКнига").Видимость = Ложь;             *****
                             ОбластьСтрокиДляПовтора.Область("НомераГрафДекларация81").Видимость = Ложь;
                        КонецЕсли;
   assasu
 
16 - 14.09.21 - 08:42
(14) ошибка в УПП 1.3.165.1 Значит я угадал
   ILM
 
17 - 14.09.21 - 09:55
(16) Да, я не стал писать, но сам решил эту проблему.
   Serg_1960
 
18 - 14.09.21 - 10:05
Sorry, дико извиняюсь за вопрос не по теме, но... Когда последний раз изменялись формы П-1, П-3 и П-4? В УПП они самые последние свежие?
   ILM
 
Модератор
19 - 14.09.21 - 10:30
(18) Это по статистике? Они там свежие, только заполнять нужно вручную.
   Serg_1960
 
20 - 14.09.21 - 10:36
(19) Да, статистика. Ок, спасибо, пойду обрадую бухих :)
   Ivanich
 
21 - 15.09.21 - 18:08
(11) Интерфейс "Заведующий учетом"
Настройка учета -> Настройка параметров учета -> Учет товаров.
   Mikhail Volkov
 
22 - 16.09.21 - 09:22
(21) И только? Операции/Константы/Настройка параметров учета/Учет товаров.
   Звездочёт
 
23 - 22.09.21 - 21:54
(0) Тоже словил баг.
После обновления на 1.3.166.1 исчез.
   Mikhail Volkov
 
24 - 23.09.21 - 08:47
Что-то по ссылке https://dl03.1c.ru/content/Enterprise/1_3_166_1/news.htm 404 Не Найдено!?
   Has
 
25 - 23.09.21 - 09:02
   Mikhail Volkov
 
26 - 23.09.21 - 09:56
(25) Обычно после обновлений эти (24) ссылки пользователям письмами рассылал, чтобы в курсе были вступивших изменений. А по этим (25) им коды доступа надо давать.
   Has
 
27 - 23.09.21 - 14:26
похоже что то меняют
см. структуры ссылки в (25) и прошлой версии:
https://releases.1c.ru/version_file?nick=Enterprise13&ver=1.3.165.1&path=Enterprise%5c1_3_165_1%5cnews.htm

а на https://v8.1c.ru/news вообще нет новости про 161
последнее
https://v8.1c.ru/news/vyshla-novaya-versiya-1-3-165-2-tipovoy-konfiguratsii-upravlenie-proizvodstvennym-predpriyatiem-reda.htm


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.