Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

как добавить склад и общее количество позиций в форму печать

как добавить склад и общее количество позиций в форму печать
Я
   seregapplk
 
11.09.21 - 10:13
Доброго времени суток.
Конфигурация Управление торговлей для Украины, редакция 3.1 (3.1.8.1) то же что и УТ11
Подскажите пожалуйста как добавить сумму колонки количество, общее количество позиций в форму печать. В обработке печать общих форм.
И нужно создать строку с отображением склада с которого отпускается товар.
Помогите пож.
   DrShad
 
1 - 11.09.21 - 10:22
и причем тут печать общих форм?
   seregapplk
 
2 - 11.09.21 - 10:31
(1)А где? макет тут в печати общих форм
   DrShad
 
3 - 11.09.21 - 10:37
т.е. ты решил тупо таб док програмно править?
   seregapplk
 
4 - 11.09.21 - 10:42
да,  а почему нет, база уже с правками
   DrShad
 
5 - 11.09.21 - 10:45
ну и чем тебе помочь? ты не знаешь как работать с таб доком?
   seregapplk
 
6 - 11.09.21 - 10:45
ОбластьМакета                                   = Макет.ПолучитьОбласть("Поставщик");
добавил поле с параметром склад
Склад = ???)) как получить?
   DrShad
 
7 - 11.09.21 - 10:54
из таб дока никак
   seregapplk
 
8 - 11.09.21 - 11:01
да, можно как?
   seregapplk
 
9 - 11.09.21 - 11:33
через запрос?
   seregapplk
 
10 - 11.09.21 - 12:15
сделал ("Склад", ДанныеПечати.Ссылка.Склад);
   seregapplk
 
11 - 11.09.21 - 12:24
как проще сделать итог ао количеству позииций
   seregapplk
 
12 - 11.09.21 - 12:49
Непонятно, задваивает область покупатель
хотя в макете все ок,
что я не так сделал


ОбластьМакета                                   = Макет.ПолучитьОбласть("Покупатель");
        ПредставлениеПолучателя                         = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ПолноеНаименование",,КодЯзыкаПечать);
        РеквизитыПокупателя                             = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ФактическийАдрес,Телефоны,",,КодЯзыкаПечать);
                СтруктураДанныхПокупатель = Новый Структура;
        СтруктураДанныхПокупатель.Вставить("ПредставлениеПолучателя", ПредставлениеПолучателя);
        СтруктураДанныхПокупатель.Вставить("Получатель", ДанныеПечати.Получатель);
        СтруктураДанныхПокупатель.Вставить("РеквизитыПокупателя", РеквизитыПокупателя);
        СтруктураДанныхПокупатель.Вставить("Склад", ДанныеПечати.Ссылка.Склад);
        ОбластьМакета.Параметры.Заполнить(СтруктураДанныхПокупатель);
        ТабличныйДокумент.Вывести(ОбластьМакета);
   seregapplk
 
13 - 11.09.21 - 12:54
ладно заново загружу сохранку, я что-то натупил, не найду
   seregapplk
 
14 - 11.09.21 - 13:46
Не выводит в печатную форму. 
Сообщение выводит если "Сообщить(ДанныеПечати.Ссылка.Склад);"
В форму нет.
В области "покупатель" создал ячейку с параметром "склад", что не так.
   seregapplk
 
15 - 12.09.21 - 09:44
удалось, нужно редактировать форму в самой программе.
   seregapplk
 
16 - 12.09.21 - 09:45
как проще сделать итог по количеству позииций номенклатуры
   seregapplk
 
17 - 12.09.21 - 10:53
ВсегоКлво = ВыборкаПоТоварам.Количество();
нашел))
   seregapplk
 
18 - 12.09.21 - 11:06
ВсегоКлво = ВыборкаПоТоварам.Количество(); это выводит количество строк, блин)
как выбрать количество товаров
   seregapplk
 
19 - 12.09.21 - 11:39
склад сделал и то хорошо, тут новых задач нарезали,
Подскажите пожалуйста как добавить сумму колонки количество, общее количество позиций в форму печать.
И нужно создать строку Весом из карточки номенклатуры.
Помогите пож. с запросами, сам не разберусь.
   DrShad
 
20 - 13.09.21 - 10:16
(10) а если в данных печати не будет реквизита Склад?
   acht
 
21 - 13.09.21 - 10:20
Такое впечатление, что у всех Сергеев-фрилансеров есть что-то неуловимо общее...
   DrShad
 
22 - 13.09.21 - 10:25
(21) и не говори
   seregapplk
 
23 - 13.09.21 - 11:36
(20) ну не будет и не будет, получит путое значение.
   seregapplk
 
24 - 13.09.21 - 11:38
(21) ха-ха, смешно, поможет кто нибудь? :-)
   МимохожийОднако
 
25 - 13.09.21 - 11:41
(24) Отладчиком пользоваться умеешь. Встань на строку с ошибкой и посмотри, что где лежит. Если долго думать, то всё получится. Я в тебя верю.
..
PS. Наверняка есть кому помочь, только надо не на форум, а к специалистам.
   d_monah
 
26 - 13.09.21 - 12:24
(24) Скажем так,не смешно.Помочь не проблема.НО!Этим же не ограничится?Сегодня правим печатную форму,завтра...?Потом ломаем данные и аля улю,лови гусей. Пройдите курсы,или поработайте с наставником,так будет лучше,поверьте.Помочь точно не жалко,но не на элементарщине и продакшене((
   DrShad
 
27 - 13.09.21 - 12:29
хотя бы открой для себя регистр сведений ПользовательскиеМакетыПечати
   acht
 
28 - 13.09.21 - 12:33
(26) > аля улю,лови гусей
При пожаре же всегда так делают, не?
   d_monah
 
29 - 13.09.21 - 12:42
(28) Печатная форма это точно не пожар. А с гусями много интересных вещей творят)),но это было давно и неправда.
   acht
 
30 - 13.09.21 - 12:52
(29) > точно не пожар
Ну как же, там еще ответного гудка ждали... Вот прям как помощи на форуме.
 
 
   d_monah
 
31 - 13.09.21 - 13:02
(30) Ага,в ВСК.Я ради интереса глянул,но рука испачканная в арбузе не позволила помочь.Тысяч за 15-20? Ну не знаю.Хотелок похоже там на 100 часов((
   seregapplk
 
32 - 13.09.21 - 17:58
Сейчас я все сделаю сам.
Запрос
ИтогКоличество = 0;
Для Каждого Стр из Товары Цикл
//Запоняем параметры строки

ИтогКоличество = ИтогКоличество + Стр.Количество;
КонецЦикла;
Так?
Вес я уже не беру.
   seregapplk
 
33 - 14.09.21 - 11:18
не выходит, ругается на 
Товары - Переменная не определена (Товары)
Вот мой код функции  помогите разобраться
   seregapplk
 
34 - 14.09.21 - 11:18
Функция ЗаполнитьТабличныйДокументРасходнаяНакладная(ТабличныйДокумент, ДанныеДляПечати, ОбъектыПечати, КомплектыПечати, ПараметрыПечати, ПараметрыВывода)

    Перем КомплектПечатиПоСсылке;
    
    КодЯзыкаПечать = ПараметрыВывода.КодЯзыкаДляМногоязычныхПечатныхФорм;    
    
    ДанныеПечати          = ДанныеДляПечати.РезультатПоШапке.Выбрать();
    ВыборкаПоДокументам = ДанныеДляПечати.РезультатПоТабличнойЧасти.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);


    Если ПараметрыПечати <> Неопределено И ПараметрыПечати.Свойство("ОтображатьСкидки") Тогда
        ОтображатьСкидки = ПараметрыПечати.ОтображатьСкидки;
    Иначе
        ОтображатьСкидки = (Константы.ОтображениеСкидокВПечатныхФормахДокументовПродажи.Получить()
            <> Перечисления.ВариантыВыводаСкидокВПечатныхФормах.НеВыводитьСкидки);
    КонецЕсли; 
    
    КолонкаКодов = ФормированиеПечатныхФорм.ИмяДополнительнойКолонки();
    ВыводитьКоды = ЗначениеЗаполнено(КолонкаКодов);
    
    ИспользоватьРучныеСкидки         = ПолучитьФункциональнуюОпцию("ИспользоватьРучныеСкидкиВПродажах");
    ИспользоватьАвтоматическиеСкидки = ПолучитьФункциональнуюОпцию("ИспользоватьАвтоматическиеСкидкиВПродажах");
    
    ПоказыватьНДС = Константы.ВыводитьДопКолонкиНДС.Получить();    
        
    ПервыйДокумент = Истина;
    
    Пока ДанныеПечати.Следующий() Цикл
        
        //Для печати комплектов

        Отказ = Ложь;
        
        ПодготовкаДляПечатиКомплектов(ДанныеПечати, КомплектыПечати, КомплектПечатиПоСсылке, Отказ);
        Если Отказ Тогда
            Продолжить;
        КонецЕсли;
        
        // Найдем в выборке товары по текущему документу

        СтруктураПоиска = Новый Структура("Ссылка", ДанныеПечати.Ссылка);
        НайденСледующий = ВыборкаПоДокументам.НайтиСледующий(СтруктураПоиска);
        
        // В одном вызове этой функции обрабатываются документы одного типа

        Если ТипЗнч(ДанныеПечати.Ссылка) = Тип("ДокументСсылка.РеализацияУслугПрочихАктивов")
         ИЛИ ТипЗнч(ДанныеПечати.Ссылка) = Тип("ДокументСсылка.ВыкупВозвратнойТарыКлиентом") 
         ИЛИ ТипЗнч(ДанныеПечати.Ссылка) = Тип("ДокументСсылка.ПередачаТоваровМеждуОрганизациями") Тогда
            ИспользоватьРучныеСкидки = Ложь;
            ИспользоватьАвтоматическиеСкидки = Ложь;
        КонецЕсли;
        
        Если ТипЗнч(ДанныеПечати.Ссылка) = Тип("ДокументСсылка.РеализацияУслугПрочихАктивов") Тогда
            ВыводитьКоды = Ложь;
        КонецЕсли;

        // Если в накладной только услуги - перейдем к следующему документу

        Если НайденСледующий Тогда
            ВыборкаПоТоварам = ВыборкаПоДокументам.Выбрать();            
            ЗаголовокСкидки = ФормированиеПечатныхФорм.НужноВыводитьСкидки(ВыборкаПоТоварам, ИспользоватьРучныеСкидки Или ИспользоватьАвтоматическиеСкидки, КодЯзыкаПечать);
            ЕстьСкидки = ЗаголовокСкидки.ЕстьСкидки;
            ЕстьНДС = ДанныеПечати.УчитыватьНДС;
            ВыборкаПоТоварам.Сбросить();
        Иначе
            Текст = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                НСтр("ru='В документе %1 отсутствуют товары. Печать накладной не требуется';uk='У документі %1 відсутні товари. Друк накладної не потрібний'"),
                ДанныеПечати.Ссылка
                );
                
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
                Текст,
                ДанныеПечати.Ссылка
            );
            Продолжить;
        КонецЕсли;
        
        // Макет необходимо получать для каждого документа, т.к. размеры колонок изменяются динамически

        Макет = УправлениеПечатью.ПолучитьМакет("Обработка.ПечатьОбщихФорм.ПФ_MXL_РасходнаяНакладная", КодЯзыкаПечать);
        
        Если Не ПервыйДокумент Тогда
            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        
        ПервыйДокумент    = Ложь;
        НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
        
        // Выводим шапку накладной

        
        ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
        ШтрихкодированиеПечатныхФорм.ВывестиШтрихкодВТабличныйДокумент(ТабличныйДокумент, Макет, ОбластьМакета, ДанныеПечати.Ссылка);
        
        ТекстЗаголовка = ОбщегоНазначенияУТКлиентСервер.СформироватьЗаголовокДокумента(ДанныеПечати, НСтр("ru='Расходная накладная';uk='Видаткова накладна'",КодЯзыкаПечать), КодЯзыкаПечать);
        
        СтруктураДанныхШапки = Новый Структура;
        СтруктураДанныхШапки.Вставить("ТекстЗаголовка", ТекстЗаголовка);
        ОбластьМакета.Параметры.Заполнить(СтруктураДанныхШапки);
        ТабличныйДокумент.Вывести(ОбластьМакета);
        
        СведенияОПоставщике    = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Организация, ДанныеПечати.Дата,,ДанныеПечати.БанковскийСчетОрганизации);    
        СведенияОПокупателе = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Получатель,  ДанныеПечати.Дата,,ДанныеПечати.БанковскийСчетКонтрагента);

        ОбластьМакета                                   = Макет.ПолучитьОбласть("Поставщик");
        ПредставлениеПоставщика                         = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ПолноеНаименование",,КодЯзыкаПечать);
        РеквизитыПоставщика                             = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "НомерСчета,Банк,МФО,/,ЮридическийАдрес,Телефоны,/,КодПоЕДРПОУ,КодПоДРФО,ИНН,НомерСвидетельства,/,ИнформацияОСтатусеПлательщикаНалогов,",,КодЯзыкаПечать);
        
        СтруктураДанныхПоставщик = Новый Структура;
        СтруктураДанныхПоставщик.Вставить("ПредставлениеПоставщика", ПредставлениеПоставщика);
        СтруктураДанныхПоставщик.Вставить("Поставщик", ДанныеПечати.Организация);
        СтруктураДанныхПоставщик.Вставить("РеквизитыПоставщика", РеквизитыПоставщика);
        СтруктураДанныхПоставщик.Вставить("Склад", ДанныеПечати.Ссылка.Склад);
        ОбластьМакета.Параметры.Заполнить(СтруктураДанныхПоставщик);
                ТабличныйДокумент.Вывести(ОбластьМакета);
        
        ОбластьМакета                                   = Макет.ПолучитьОбласть("Покупатель");
        ПредставлениеПолучателя                         = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ПолноеНаименование",,КодЯзыкаПечать);
        РеквизитыПокупателя                             = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ФактическийАдрес,Телефоны,",,КодЯзыкаПечать);
         Склад                                          = ДанныеПечати.Ссылка.Склад;
        СтруктураДанныхПокупатель = Новый Структура;
        СтруктураДанныхПокупатель.Вставить("ПредставлениеПолучателя", ПредставлениеПолучателя);
        СтруктураДанныхПокупатель.Вставить("Получатель", ДанныеПечати.Получатель);
        СтруктураДанныхПокупатель.Вставить("РеквизитыПокупателя", РеквизитыПокупателя);
        ОбластьМакета.Параметры.Заполнить(СтруктураДанныхПокупатель);
        Запрос2 = Новый Запрос(

        "ВЫБРАТЬ
        |    РасчетыСКлиентамиОстаткиИОбороты.СуммаКонечныйОстаток КАК СуммаКонечныйОстаток,
        |    РасчетыСКлиентамиОстаткиИОбороты.АналитикаУчетаПоПартнерам КАК АналитикаУчетаПоПартнерам,
        |    РасчетыСКлиентамиОстаткиИОбороты.Регистратор КАК Регистратор
        |ИЗ
        |    РегистрНакопления.РасчетыСКлиентами.ОстаткиИОбороты(, , Регистратор, Движения, ) КАК РасчетыСКлиентамиОстаткиИОбороты
        |ГДЕ
        |    РасчетыСКлиентамиОстаткиИОбороты.АналитикаУчетаПоПартнерам.Контрагент = &Контрагент
        |    И РасчетыСКлиентамиОстаткиИОбороты.Период = &Регистратор" );
        
        Запрос2.УстановитьПараметр("Контрагент", ДанныеПечати.Получатель);
        Запрос2.УстановитьПараметр("Регистратор", ДанныеПечати.Дата);
        Результат2 = Запрос2.Выполнить();
        
        ВыборкаДетальныеЗаписи2 = Результат2.Выбрать();

        Если ВыборкаДетальныеЗаписи2.Следующий() Тогда
            КонечныйДолг = ВыборкаДетальныеЗаписи2.СуммаКонечныйОстаток;
            Если КонечныйДолг < 0 Тогда
                ОбластьМакета.Параметры.ДолгИнфа = "Передоплата контрагента з урахуванням цієї накладної становить  " + (-1)*КонечныйДолг + " грн.";
            Иначе
                ОбластьМакета.Параметры.ДолгИнфа = "Заборгованість контрагента з урахуванням цієї накладної становить  " + КонечныйДолг + " грн.";

            КонецЕсли;    
        Иначе
            ОбластьМакета.Параметры.ДолгИнфа = "";
        КонецЕсли;
        ТабличныйДокумент.Вывести(ОбластьМакета);
        
        // Выводим дополнительно информацию о договоре и заказе

        СписокДополнительныхПараметров = "ДоговорНаименованиеДляПечати,";
        Если ДанныеПечати.ПечататьЗаказ Тогда
            // Реализацию и договор уже вывели

            СписокДополнительныхПараметров = СписокДополнительныхПараметров + "Заказ,";
        КонецЕсли;
        СписокДополнительныхПараметров = СписокДополнительныхПараметров + "АдресДоставки,";
        
        МассивСтруктурСтрок = ФормированиеПечатныхФорм.ДополнительнаяИнформация(ДанныеПечати, СписокДополнительныхПараметров, КодЯзыкаПечать);
        ОбластьМакета = Макет.ПолучитьОбласть("ДопИнформация");
        Для каждого СтруктураСтроки Из МассивСтруктурСтрок Цикл
            ОбластьМакета.Параметры.Заполнить(СтруктураСтроки);
            ТабличныйДокумент.Вывести(ОбластьМакета);
        КонецЦикла;        

        // Выводим заголовок таблицы Товары

        
        СуффиксОбластиСтроки = ?(ЕстьСкидки, "СоСкидкой", "") + ?(ЕстьНДС И ПоказыватьНДС, "СНДС", "");
        СуффиксОбластиКолонки = ?(ЕстьСкидки И ЕстьНДС И ПоказыватьНДС, "СоСкидкойСНДС", ?(ЕстьСкидки Или (ЕстьНДС И ПоказыватьНДС), "СоСкидкойИлиСНДС", ""));
        
        ОбластьКолонкаТовар = Макет.Область("ПерваяКолонкаТовара");
        ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки
            + ?(ВыводитьКоды, 0, Макет.Область("КолонкаКодов").ШиринаКолонки)
        ;
        
        ОбластьНомера  = Макет.ПолучитьОбласть("ШапкаТаблицы" + СуффиксОбластиСтроки + "|НомерСтроки");
        ОбластьКодов   = Макет.ПолучитьОбласть("ШапкаТаблицы" + СуффиксОбластиСтроки + "|КолонкаКодов");
        ОбластьТовар   = Макет.ПолучитьОбласть("ШапкаТаблицы" + СуффиксОбластиСтроки + "|Товар" + СуффиксОбластиКолонки);
        ОбластьДанных  = Макет.ПолучитьОбласть("ШапкаТаблицы" + СуффиксОбластиСтроки + "|Данные" + СуффиксОбластиКолонки);
        
        ТабличныйДокумент.Вывести(ОбластьНомера);
            
        Если ВыводитьКоды Тогда
            ОбластьКодов.Параметры.ИмяКолонкиКодов = КолонкаКодов;
            ТабличныйДокумент.Присоединить(ОбластьКодов);
        КонецЕсли;
        
        ЗаполнитьЗначенияСвойств(ОбластьДанных.Параметры, ФормированиеПечатныхФорм.СформироватьЗаголовкиДляСуммовыхПоказателей(ДанныеПечати, КодЯзыкаПечать));
        
        Если ЕстьСкидки Тогда
            СтруктураЗаголовокСкидки = Новый Структура("Скидка, СуммаБезСкидки", 
                ЗаголовокСкидки.Скидка,
                ЗаголовокСкидки.СуммаСкидки);
            ОбластьДанных.Параметры.Заполнить(СтруктураЗаголовокСкидки);
        КонецЕсли; 
        
        ТабличныйДокумент.Присоединить(ОбластьТовар);
        ТабличныйДокумент.Присоединить(ОбластьДанных);
        
        ОбластьНомераСтрокиСтандарт = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "|НомерСтроки");
        ОбластьКодовСтрокиСтандарт  = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "|КолонкаКодов");
        ОбластьТоварСтрокиСтандарт  = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "|Товар" + СуффиксОбластиКолонки);
        ОбластьДанныхСтрокиСтандарт = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "|Данные" + СуффиксОбластиКолонки);
        
        ИспользоватьНаборы = Ложь;
        Если ОбщегоНазначенияУТКлиентСервер.ЕстьРеквизитОбъекта(ВыборкаПоДокументам, "ЭтоНабор") Тогда
            ИспользоватьНаборы = Истина;
            ОбластьНомераСтрокиНабор         = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Набор"         + "|НомерСтроки");
            ОбластьНомераСтрокиКомплектующие = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Комплектующие" + "|НомерСтроки");
            ОбластьКодовСтрокиНабор          = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Набор"         + "|КолонкаКодов");
            ОбластьКодовСтрокиКомплектующие  = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Комплектующие" + "|КолонкаКодов");
            ОбластьТоварСтрокиНабор          = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Набор"         + "|Товар"  + СуффиксОбластиКолонки);
            ОбластьТоварСтрокиКомплектующие  = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Комплектующие" + "|Товар"  + СуффиксОбластиКолонки);
            ОбластьДанныхСтрокиНабор         = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Набор"         + "|Данные" + СуффиксОбластиКолонки);
            ОбластьДанныхСтрокиКомплектующие = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Комплектующие" + "|Данные" + СуффиксОбластиКолонки);
        КонецЕсли;
        
        Сумма          = 0;
        СуммаНДС       = 0;
        ВсегоСкидок    = 0;
        НомерСтроки    = 0;
        ВсегоБезСкидок = 0;
        
        ПустыеДанные = НаборыСервер.ПустыеДанные();
        
        // Выводим строки таблицы Товары

            
        Пока ВыборкаПоТоварам.Следующий() Цикл
            
            Если НаборыСервер.ИспользоватьОбластьНабор(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                ОбластьКодовСтроки   = ОбластьКодовСтрокиНабор;
                ОбластьНомераСтроки  = ОбластьНомераСтрокиНабор;
                ОбластьДанныхСтроки  = ОбластьДанныхСтрокиНабор;
                ОбластьТоварСтроки   = ОбластьТоварСтрокиНабор;
            ИначеЕсли НаборыСервер.ИспользоватьОбластьКомплектующие(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                ОбластьКодовСтроки   = ОбластьКодовСтрокиКомплектующие;
                ОбластьНомераСтроки  = ОбластьНомераСтрокиКомплектующие;
                ОбластьДанныхСтроки  = ОбластьДанныхСтрокиКомплектующие;
                ОбластьТоварСтроки   = ОбластьТоварСтрокиКомплектующие;
            Иначе
                ОбластьКодовСтроки   = ОбластьКодовСтрокиСтандарт;
                ОбластьНомераСтроки  = ОбластьНомераСтрокиСтандарт;
                ОбластьДанныхСтроки  = ОбластьДанныхСтрокиСтандарт;
                ОбластьТоварСтроки   = ОбластьТоварСтрокиСтандарт;
            КонецЕсли;
            
            Если НаборыСервер.ВыводитьТолькоЗаголовок(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                УстановитьПараметр(ОбластьНомераСтроки, "НомерСтроки", Неопределено);
            Иначе
                НомерСтроки = НомерСтроки + 1;
                УстановитьПараметр(ОбластьНомераСтроки, "НомерСтроки", НомерСтроки);
            КонецЕсли;
            ТабличныйДокумент.Вывести(ОбластьНомераСтроки);
            
            Если ВыводитьКоды Тогда
                СтруктураДанныхКоды = Новый Структура("Артикул", ВыборкаПоТоварам[КолонкаКодов]);
                ОбластьКодовСтроки.Параметры.Заполнить(СтруктураДанныхКоды);
                ТабличныйДокумент.Присоединить(ОбластьКодовСтроки);
            КонецЕсли;
            
            ПрефиксИПостфикс = НаборыСервер.ПолучитьПрефиксИПостфикс(ВыборкаПоТоварам, ИспользоватьНаборы);
            
            ОбластьТоварСтроки.Параметры.Заполнить(ВыборкаПоТоварам);
            Если ТипЗнч(ДанныеПечати.Ссылка) = Тип("ДокументСсылка.РеализацияУслугПрочихАктивов") Тогда    
                Товар = ВыборкаПоТоварам.Содержание;
                СтруктураДанныхТовар = Новый Структура("Товар", Товар);
                ОбластьТоварСтроки.Параметры.Заполнить(СтруктураДанныхТовар);
            Иначе    
                Товар = ПрефиксИПостфикс.Префикс + НоменклатураКлиентСервер.ПредставлениеНоменклатурыДляПечати(
                    ВыборкаПоТоварам.ТоварНаименованиеПолное,
                    ВыборкаПоТоварам.Характеристика,
                    ,
                    ,
                    ,
                    ВыборкаПоТоварам.ЭтоВозвратнаяТара, 
                    КодЯзыкаПечать) + ПрефиксИПостфикс.Постфикс;
                СтруктураДанныхТовар = Новый Структура("Товар", Товар);
                ОбластьТоварСтроки.Параметры.Заполнить(СтруктураДанныхТовар);
            КонецЕсли;
            
            ТабличныйДокумент.Присоединить(ОбластьТоварСтроки);
            
            Если ЗаголовокСкидки.ЕстьСкидки Тогда
                СтруктураДанныхСуммаСкидки = Новый Структура("СуммаСкидки", 
                    ?(ЗаголовокСкидки.ТолькоНаценка,- ВыборкаПоТоварам.СуммаСкидки,ВыборкаПоТоварам.СуммаСкидки));
                ОбластьДанныхСтроки.Параметры.Заполнить(СтруктураДанныхСуммаСкидки);
            КонецЕсли;
            
            Если НаборыСервер.ВыводитьТолькоЗаголовок(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                ОбластьДанныхСтроки.Параметры.Заполнить(ПустыеДанные);
            Иначе
                ОбластьДанныхСтроки.Параметры.Заполнить(ВыборкаПоТоварам);
            КонецЕсли;
            
            ТабличныйДокумент.Присоединить(ОбластьДанныхСтроки);
            
            Если Не НаборыСервер.ИспользоватьОбластьКомплектующие(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                Сумма          = Сумма          + ВыборкаПоТоварам.Сумма;
                СуммаНДС       = СуммаНДС       + ВыборкаПоТоварам.СуммаНДС;
                
                Если ЕстьСкидки Тогда
                    ВсегоСкидок    = ВсегоСкидок    + ВыборкаПоТоварам.СуммаСкидки;
                    ВсегоБезСкидок = ВсегоБезСкидок + ВыборкаПоТоварам.СуммаБезСкидки;
                КонецЕсли;
            КонецЕсли;
            
        КонецЦикла;
           
        
        
        // Выводим подвал

        
        ОбластьНомера  = Макет.ПолучитьОбласть("ПодвалТаблицы" + СуффиксОбластиСтроки + "|НомерСтроки");
        ОбластьКодов   = Макет.ПолучитьОбласть("ПодвалТаблицы" + СуффиксОбластиСтроки + "|КолонкаКодов");
        ОбластьТовар   = Макет.ПолучитьОбласть("ПодвалТаблицы" + СуффиксОбластиСтроки + "|Товар" + СуффиксОбластиКолонки);
        ОбластьДанных  = Макет.ПолучитьОбласть("ПодвалТаблицы" + СуффиксОбластиСтроки + "|Данные" + СуффиксОбластиКолонки);
        
        ТабличныйДокумент.Вывести(ОбластьНомера);
        
        Если ВыводитьКоды Тогда
            ТабличныйДокумент.Присоединить(ОбластьКодов);
        КонецЕсли;
        
        ТабличныйДокумент.Присоединить(ОбластьТовар);
        
        СтруктураДанныхВсегоСкидки = Новый Структура;
        Если ЕстьСкидки Тогда
            СтруктураДанныхВсегоСкидки.Вставить("ВсегоСкидок", ?(ЗаголовокСкидки.ТолькоНаценка,-ВсегоСкидок, ВсегоСкидок));
            СтруктураДанныхВсегоСкидки.Вставить("ВсегоБезСкидок", ВсегоБезСкидок);
        КонецЕсли;
        СтруктураДанныхВсегоСкидки.Вставить("Всего",  ФормированиеПечатныхФорм.ФорматСумм(Сумма));
        ОбластьДанных.Параметры.Заполнить(СтруктураДанныхВсегоСкидки);
        ТабличныйДокумент.Присоединить(ОбластьДанных);
        
        // Выводим ИтогоНДС

        
        Область = Макет.ПолучитьОбласть("ПодвалНДС");
        СтруктураДанныхПодвалНДС = Новый Структура;
        СтруктураДанныхПодвалНДС.Вставить("ВсегоНДС", СуммаНДС);
        Если ЕстьНДС Тогда
            СтруктураДанныхПодвалНДС.Вставить("НДС", ?(ДанныеПечати.ЦенаВключаетНДС, НСтр("ru='В том числе НДС:';uk='У тому числі ПДВ:'",КодЯзыкаПечать), НСтр("ru='Сумма НДС:';uk='Сума ПДВ:'",КодЯзыкаПечать)));
            Если Не ДанныеПечати.ЦенаВключаетНДС Тогда
                Область.Параметры.Заполнить(СтруктураДанныхПодвалНДС);
                ТабличныйДокумент.Вывести(Область);
                СтруктураДанныхПодвалНДС = Новый Структура;
                СтруктураДанныхПодвалНДС.Вставить("НДС", НСтр("ru='Всего с НДС:';uk='Всього із ПДВ:'",КодЯзыкаПечать));
                СтруктураДанныхПодвалНДС.Вставить("ВсегоНДС", Сумма + СуммаНДС);
            КонецЕсли;
        Иначе
            СтруктураДанныхПодвалНДС.Вставить("НДС", НСтр("ru='Без налога (НДС)';uk='Без податку (ПДВ)'",КодЯзыкаПечать));
        КонецЕсли;
        Область.Параметры.Заполнить(СтруктураДанныхПодвалНДС);
        ТабличныйДокумент.Присоединить(Область);
        
        // Выводим Сумму прописью

        
        ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
        СуммаКПрописи = Сумма + ?(ДанныеПечати.ЦенаВключаетНДС, 0, СуммаНДС);
        СтруктураДанныхСуммаПрописью = Новый Структура;
        
        ИтоговаяСтрока = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru='Всего наименований %1, на сумму %2';uk='Всього найменувань %1, на суму %2'",КодЯзыкаПечать),
            ВыборкаПоТоварам.Количество(),
            ФормированиеПечатныхФорм.ФорматСумм(СуммаКПрописи, ДанныеПечати.Валюта));
        
        СтруктураДанныхСуммаПрописью.Вставить("ИтоговаяСтрока", ИтоговаяСтрока);
        СтруктураДанныхСуммаПрописью.Вставить("СуммаПрописью", РаботаСКурсамиВалют.СформироватьСуммуПрописью(СуммаКПрописи, ДанныеПечати.Валюта, , КодЯзыкаПечать));
        ОбластьМакета.Параметры.Заполнить(СтруктураДанныхСуммаПрописью);
        ТабличныйДокумент.Вывести(ОбластьМакета);
        
        Если ЗначениеЗаполнено(ДанныеПечати.МестоСоставленияДокумента) Тогда
            ОбластьМакета = Макет.ПолучитьОбласть("МестоСоставления");
            СтруктураДанныхМестоСоставления = Новый Структура;
            СтруктураДанныхМестоСоставления.Вставить("МестоСоставления", СокрЛП(ДанныеПечати.МестоСоставленияДокумента));
            ОбластьМакета.Параметры.Заполнить(СтруктураДанныхМестоСоставления);
            ТабличныйДокумент.Вывести(ОбластьМакета);
        КонецЕсли;
        
        // Выводим подписи

        ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
        
        ОбластьМакета.Параметры.Заполнить(ФормированиеПечатныхФорм.СведенияОбОтветсвенныхЛицах(ДанныеПечати, КодЯзыкаПечать));
        
        ТабличныйДокумент.Вывести(ОбластьМакета);
        
        ЗавершениеДляПечатиКомплектов(КомплектыПечати, КомплектПечатиПоСсылке, ТабличныйДокумент, НомерСтрокиНачало);
        
        УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, НомерСтрокиНачало, ОбъектыПечати, ДанныеПечати.Ссылка);
        
    КонецЦикла;
     
КонецФункции
   seregapplk
 
35 - 15.09.21 - 15:06
Подскажите что не так,

[CODE]Сумма          = 0;
        СуммаНДС       = 0;
        ВсегоСкидок    = 0;
        НомерСтроки    = 0;
        ВсегоБезСкидок = 0;
        ИтогКоличество = 0; 
        ИтогВес  = 0;
        
                Пока ВыборкаПоТоварам.Следующий() Цикл
//Тут все тело цикла

ИтогКоличество = ИтогКоличество + ВыборкаПоТоварам.Количество;
ИтогВес  = ИтогВес + ВыборкаПоТоварам.Номенклатура.Вес;
КонецЦикла;
ОбластьПодвалТаблицы.Параметры.ИтогВес = ИтогВес;  
ОбластьПодвалТаблицы.Параметры.ИтогКоличество = ИтогКоличество; 
        
        ПустыеДанные = НаборыСервер.ПустыеДанные();
        
        // Выводим строки таблицы Товары

[/CODE]
{Обработка.ПечатьОбщихФорм.МодульМенеджера(1017,1)}: Переменная не определена (ОбластьПодвалТаблицы)
<<?>>ОбластьПодвалТаблицы.Параметры.ИтогВес = ИтогВес;   (Проверка: Сервер)
{Обработка.ПечатьОбщихФорм.МодульМенеджера(1018,1)}: Переменная не определена (ОбластьПодвалТаблицы)
<<?>>ОбластьПодвалТаблицы.Параметры.ИтогКоличество = ИтогКоличество;  (Проверка: Сервер)
https://drive.google.com/file/d/1JLYnLH37PAAFjvaGbEIfsJLEAAWdGNen/view?usp=sharing
[url=https://d.radikal.ru/d06/2109/c0/20d20b9364a6.png][img]https://d.radikal.ru/d06/2109/c0/20d20b9364a6.png[/img][/url]
   seregapplk
 
36 - 15.09.21 - 15:07
подскажите что не так
   hhhh
 
37 - 15.09.21 - 15:21
(36) Переменная не определена (ОбластьПодвалТаблицы)
   seregapplk
 
38 - 15.09.21 - 16:23
ок Кєп
Почему?
   hhhh
 
39 - 15.09.21 - 16:32
(38) наверно забыл эту переменную определить. Покажи, где определяешь.
   seregapplk
 
40 - 15.09.21 - 17:14
точно, ее нет в эту область вноситься таким образом

// Выводим подвал

        
        ОбластьНомера  = Макет.ПолучитьОбласть("ПодвалТаблицы" + СуффиксОбластиСтроки + "|НомерСтроки");
        ОбластьКодов   = Макет.ПолучитьОбласть("ПодвалТаблицы" + СуффиксОбластиСтроки + "|КолонкаКодов");
        ОбластьТовар   = Макет.ПолучитьОбласть("ПодвалТаблицы" + СуффиксОбластиСтроки + "|Товар" + СуффиксОбластиКолонки);
        ОбластьДанных  = Макет.ПолучитьОбласть("ПодвалТаблицы" + СуффиксОбластиСтроки + "|Данные" + СуффиксОбластиКолонки);
        
        ТабличныйДокумент.Вывести(ОбластьНомера);
        
        Если ВыводитьКоды Тогда
            ТабличныйДокумент.Присоединить(ОбластьКодов);
        КонецЕсли;
        
        ТабличныйДокумент.Присоединить(ОбластьТовар);
        
        СтруктураДанныхВсегоСкидки = Новый Структура;
        Если ЕстьСкидки Тогда
            СтруктураДанныхВсегоСкидки.Вставить("ВсегоСкидок", ?(ЗаголовокСкидки.ТолькоНаценка,-ВсегоСкидок, ВсегоСкидок));
            СтруктураДанныхВсегоСкидки.Вставить("ВсегоБезСкидок", ВсегоБезСкидок);
        КонецЕсли;
        СтруктураДанныхВсегоСкидки.Вставить("Всего",  ФормированиеПечатныхФорм.ФорматСумм(Сумма));
        ОбластьДанных.Параметры.Заполнить(СтруктураДанныхВсегоСкидки);
        ТабличныйДокумент.Присоединить(ОбластьДанных);
   seregapplk
 
41 - 15.09.21 - 17:23
ОбластьПодвалТаблицы = макет.ПолучитьОбласть("ПодвалТаблицы");
   seregapplk
 
42 - 15.09.21 - 17:25
Пока ВыборкаПоТоварам.Следующий() Цикл
//Тут все тело цикла

ИтогКоличество = ИтогКоличество + ВыборкаПоТоварам.Количество;
ИтогВес  = ИтогВес + ВыборкаПоТоварам.Номенклатура.Вес;
КонецЦикла;
ОбластьПодвалТаблицы = макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьПодвалТаблицы.Параметры.ИтогВес = ИтогВес;  
ОбластьПодвалТаблицы.Параметры.ИтогКоличество = ИтогКоличество;
   seregapplk
 
43 - 15.09.21 - 17:25
ругается
{Обработка.ПечатьОбщихФорм.МодульМенеджера(1019)}: Поле объекта не обнаружено (ИтогКоличество)
ОбластьПодвалТаблицы.Параметры.ИтогКоличество = ИтогКоличество;
   hhhh
 
44 - 15.09.21 - 17:42
(43) чего хрень всякую постишь? Ну, посмотри, есть такая переменная ИтогКоличество и параметр ИтогКоличество в области.
   Droning1C
 
45 - 15.09.21 - 23:09
(21) тонко)
   seregapplk
 
46 - 16.09.21 - 09:45
все считает, не могу вывести в подвал на форму,
   seregapplk
 
47 - 16.09.21 - 10:20
СтруктураДанныхПодвалНДС.Вставить("ИтогКоличество", ИтогКоличество);
        //СтруктураДанныхПодвалНДС.Вставить("ИтогВес", ИтогВес);

Выводит
теперь не выводит товары в печатную форму
   seregapplk
 
48 - 16.09.21 - 10:21
в печатной форме в строке товары пусто
   seregapplk
 
49 - 16.09.21 - 10:21
// Выводим заголовок таблицы Товары

        
        СуффиксОбластиСтроки = ?(ЕстьСкидки, "СоСкидкой", "") + ?(ЕстьНДС И ПоказыватьНДС, "СНДС", "");
        СуффиксОбластиКолонки = ?(ЕстьСкидки И ЕстьНДС И ПоказыватьНДС, "СоСкидкойСНДС", ?(ЕстьСкидки Или (ЕстьНДС И ПоказыватьНДС), "СоСкидкойИлиСНДС", ""));
        
        ОбластьКолонкаТовар = Макет.Область("ПерваяКолонкаТовара");
        ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки
            + ?(ВыводитьКоды, 0, Макет.Область("КолонкаКодов").ШиринаКолонки)
        ;
        
        ОбластьНомера  = Макет.ПолучитьОбласть("ШапкаТаблицы" + СуффиксОбластиСтроки + "|НомерСтроки");
        ОбластьКодов   = Макет.ПолучитьОбласть("ШапкаТаблицы" + СуффиксОбластиСтроки + "|КолонкаКодов");
        ОбластьТовар   = Макет.ПолучитьОбласть("ШапкаТаблицы" + СуффиксОбластиСтроки + "|Товар" + СуффиксОбластиКолонки);
        ОбластьДанных  = Макет.ПолучитьОбласть("ШапкаТаблицы" + СуффиксОбластиСтроки + "|Данные" + СуффиксОбластиКолонки);
        
        ТабличныйДокумент.Вывести(ОбластьНомера);
            
        Если ВыводитьКоды Тогда
            ОбластьКодов.Параметры.ИмяКолонкиКодов = КолонкаКодов;
            ТабличныйДокумент.Присоединить(ОбластьКодов);
        КонецЕсли;
        
        ЗаполнитьЗначенияСвойств(ОбластьДанных.Параметры, ФормированиеПечатныхФорм.СформироватьЗаголовкиДляСуммовыхПоказателей(ДанныеПечати, КодЯзыкаПечать));
        
        Если ЕстьСкидки Тогда
            СтруктураЗаголовокСкидки = Новый Структура("Скидка, СуммаБезСкидки", 
                ЗаголовокСкидки.Скидка,
                ЗаголовокСкидки.СуммаСкидки);
            ОбластьДанных.Параметры.Заполнить(СтруктураЗаголовокСкидки);
        КонецЕсли; 
        
        ТабличныйДокумент.Присоединить(ОбластьТовар);
        ТабличныйДокумент.Присоединить(ОбластьДанных);
        
        ОбластьНомераСтрокиСтандарт = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "|НомерСтроки");
        ОбластьКодовСтрокиСтандарт  = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "|КолонкаКодов");
        ОбластьТоварСтрокиСтандарт  = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "|Товар" + СуффиксОбластиКолонки);
        ОбластьДанныхСтрокиСтандарт = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "|Данные" + СуффиксОбластиКолонки);
        
        ИспользоватьНаборы = Ложь;
        Если ОбщегоНазначенияУТКлиентСервер.ЕстьРеквизитОбъекта(ВыборкаПоДокументам, "ЭтоНабор") Тогда
            ИспользоватьНаборы = Истина;
            ОбластьНомераСтрокиНабор         = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Набор"         + "|НомерСтроки");
            ОбластьНомераСтрокиКомплектующие = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Комплектующие" + "|НомерСтроки");
            ОбластьКодовСтрокиНабор          = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Набор"         + "|КолонкаКодов");
            ОбластьКодовСтрокиКомплектующие  = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Комплектующие" + "|КолонкаКодов");
            ОбластьТоварСтрокиНабор          = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Набор"         + "|Товар"  + СуффиксОбластиКолонки);
            ОбластьТоварСтрокиКомплектующие  = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Комплектующие" + "|Товар"  + СуффиксОбластиКолонки);
            ОбластьДанныхСтрокиНабор         = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Набор"         + "|Данные" + СуффиксОбластиКолонки);
            ОбластьДанныхСтрокиКомплектующие = Макет.ПолучитьОбласть("СтрокаТаблицы" + СуффиксОбластиСтроки + "Комплектующие" + "|Данные" + СуффиксОбластиКолонки);
        КонецЕсли;
        
        Сумма          = 0;
        СуммаНДС       = 0;
        ВсегоСкидок    = 0;
        НомерСтроки    = 0;
        ВсегоБезСкидок = 0;
        ПустыеДанные = НаборыСервер.ПустыеДанные();
        // вес 

         ИтогКоличество = 0; 
         ИтогВес  = 0;
          Пока ВыборкаПоТоварам.Следующий() Цикл
//Тут все тело цикла

ИтогКоличество = ИтогКоличество + ВыборкаПоТоварам.Количество;
ИтогВес  = ИтогВес + ВыборкаПоТоварам.Номенклатура.Вес;
КонецЦикла;
Сообщить(ИтогКоличество);
Сообщить(ИтогВес);
        
        
        
        // Выводим строки таблицы Товары

            
        Пока ВыборкаПоТоварам.Следующий() Цикл
            
            Если НаборыСервер.ИспользоватьОбластьНабор(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                ОбластьКодовСтроки   = ОбластьКодовСтрокиНабор;
                ОбластьНомераСтроки  = ОбластьНомераСтрокиНабор;
                ОбластьДанныхСтроки  = ОбластьДанныхСтрокиНабор;
                ОбластьТоварСтроки   = ОбластьТоварСтрокиНабор;
            ИначеЕсли НаборыСервер.ИспользоватьОбластьКомплектующие(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                ОбластьКодовСтроки   = ОбластьКодовСтрокиКомплектующие;
                ОбластьНомераСтроки  = ОбластьНомераСтрокиКомплектующие;
                ОбластьДанныхСтроки  = ОбластьДанныхСтрокиКомплектующие;
                ОбластьТоварСтроки   = ОбластьТоварСтрокиКомплектующие;
            Иначе
                ОбластьКодовСтроки   = ОбластьКодовСтрокиСтандарт;
                ОбластьНомераСтроки  = ОбластьНомераСтрокиСтандарт;
                ОбластьДанныхСтроки  = ОбластьДанныхСтрокиСтандарт;
                ОбластьТоварСтроки   = ОбластьТоварСтрокиСтандарт;
            КонецЕсли;
            
            Если НаборыСервер.ВыводитьТолькоЗаголовок(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                УстановитьПараметр(ОбластьНомераСтроки, "НомерСтроки", Неопределено);
            Иначе
                НомерСтроки = НомерСтроки + 1;
                УстановитьПараметр(ОбластьНомераСтроки, "НомерСтроки", НомерСтроки);
            КонецЕсли;
            ТабличныйДокумент.Вывести(ОбластьНомераСтроки);
            
            Если ВыводитьКоды Тогда
                СтруктураДанныхКоды = Новый Структура("Артикул", ВыборкаПоТоварам[КолонкаКодов]);
                ОбластьКодовСтроки.Параметры.Заполнить(СтруктураДанныхКоды);
                ТабличныйДокумент.Присоединить(ОбластьКодовСтроки);
            КонецЕсли;
            
            ПрефиксИПостфикс = НаборыСервер.ПолучитьПрефиксИПостфикс(ВыборкаПоТоварам, ИспользоватьНаборы);
            
            ОбластьТоварСтроки.Параметры.Заполнить(ВыборкаПоТоварам);
            Если ТипЗнч(ДанныеПечати.Ссылка) = Тип("ДокументСсылка.РеализацияУслугПрочихАктивов") Тогда    
                Товар = ВыборкаПоТоварам.Содержание;
                СтруктураДанныхТовар = Новый Структура("Товар", Товар);
                ОбластьТоварСтроки.Параметры.Заполнить(СтруктураДанныхТовар);
            Иначе    
                Товар = ПрефиксИПостфикс.Префикс + НоменклатураКлиентСервер.ПредставлениеНоменклатурыДляПечати(
                    ВыборкаПоТоварам.ТоварНаименованиеПолное,
                    ВыборкаПоТоварам.Характеристика,
                    ,
                    ,
                    ,
                    ВыборкаПоТоварам.ЭтоВозвратнаяТара, 
                    КодЯзыкаПечать) + ПрефиксИПостфикс.Постфикс;
                СтруктураДанныхТовар = Новый Структура("Товар", Товар);
                ОбластьТоварСтроки.Параметры.Заполнить(СтруктураДанныхТовар);
            КонецЕсли;
            
            ТабличныйДокумент.Присоединить(ОбластьТоварСтроки);
            
            Если ЗаголовокСкидки.ЕстьСкидки Тогда
                СтруктураДанныхСуммаСкидки = Новый Структура("СуммаСкидки", 
                    ?(ЗаголовокСкидки.ТолькоНаценка,- ВыборкаПоТоварам.СуммаСкидки,ВыборкаПоТоварам.СуммаСкидки));
                ОбластьДанныхСтроки.Параметры.Заполнить(СтруктураДанныхСуммаСкидки);
            КонецЕсли;
            
            Если НаборыСервер.ВыводитьТолькоЗаголовок(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                ОбластьДанныхСтроки.Параметры.Заполнить(ПустыеДанные);
            Иначе
                ОбластьДанныхСтроки.Параметры.Заполнить(ВыборкаПоТоварам);
            КонецЕсли;
            
            ТабличныйДокумент.Присоединить(ОбластьДанныхСтроки);
            
            Если Не НаборыСервер.ИспользоватьОбластьКомплектующие(ВыборкаПоТоварам, ИспользоватьНаборы) Тогда
                Сумма          = Сумма          + ВыборкаПоТоварам.Сумма;
                СуммаНДС       = СуммаНДС       + ВыборкаПоТоварам.СуммаНДС;
                
                Если ЕстьСкидки Тогда
                    ВсегоСкидок    = ВсегоСкидок    + ВыборкаПоТоварам.СуммаСкидки;
                    ВсегоБезСкидок = ВсегоБезСкидок + ВыборкаПоТоварам.СуммаБезСкидки;
                КонецЕсли;
            КонецЕсли;
            
        КонецЦикла;
   УдавВПопугаях
 
50 - 16.09.21 - 10:29
(21) полоска?
   seregapplk
 
51 - 16.09.21 - 10:31
пустая строка
   seregapplk
 
52 - 16.09.21 - 10:33
на печать выводит количество/вес ))
   seregapplk
 
53 - 16.09.21 - 10:44
Выводит только шапку таблтцы
   DrShad
 
54 - 16.09.21 - 10:49
продолжайте наблюдения, держите нас в курсе
   seregapplk
 
55 - 16.09.21 - 11:05
Объясните почему так?
   acht
 
56 - 16.09.21 - 11:14
Poke Driven Development
   DrShad
 
57 - 16.09.21 - 11:30
(55) ты реально думаешь, что кто-то будет читать твою простыню?
   hhhh
 
58 - 16.09.21 - 11:54
(55) копай в сторону Пока ВыборкаПоТоварам.Следующий() Цикл
   seregapplk
 
59 - 16.09.21 - 12:30
все разобрался, я протупил)) Всем Спасибо огромное!
   seregapplk
 
60 - 16.09.21 - 12:51
ИтогВес = ИтогВес + ВыборкаПоТоварам.Номенклатура.Вес;
получаем вес по количеству строк, 
как получить вес по количеству номенклатуры?
 
 
   hhhh
 
61 - 16.09.21 - 12:54
(60) включить мозг.
   seregapplk
 
62 - 16.09.21 - 12:58
естественно, мозгом я понимаю
что нудно получить вес "по строке"
и сложить. но как составить это в коде нет.
   seregapplk
 
63 - 17.09.21 - 09:58
Получиорсь, Всем Спасибо


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.