Вход | Регистрация
 

Не получается пометить на удаление элементы справочника.Почему?

Не получается пометить на удаление элементы справочника.Почему?
Я
   AlexBor
 
09.09.21 - 12:21
&НаСервере
Процедура GoНаСервере()
      Запрос = Новый Запрос;
      Запрос.Текст ="ВЫБРАТЬ
     |    ФизическиеЛица.Наименование КАК Наименование
     |ИЗ
     |    Справочник.ФизическиеЛица КАК ФизическиеЛица";
     Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл
    Выборка = Результат.ПолучитьОбъект();
    Выборка.УстановитьПометкуУдаления(Истина);
    
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура Go(Команда)
    GoНаСервере();
КонецПроцедуры
   acht
 
1 - 09.09.21 - 12:23
Сообщения об ошибке мы так и не увидим?
   AlexBor
 
2 - 09.09.21 - 12:24
Метод объекта не обнаружен (ПолучитьОбъект)
{ВнешнийОтчет.ОбработкаПеребратьЭлементы.Форма.ФормаОтчета.Форма(12)}:    ВыборкаО = Результат.ПолучитьОбъект();
{ВнешнийОтчет.ОбработкаПеребратьЭлементы.Форма.ФормаОтчета.Форма(21)}:    GoНаСервере();
   timurhv
 
3 - 09.09.21 - 12:24
(0) Что за дичь написана? Выбрали наименование, обратились к результату выборке запроса, а не ссылке и помечаем на удаление?
   AlexBor
 
4 - 09.09.21 - 12:25
(3) Понял все

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.