Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Программно изменить строку тч заказ покупателя перед записью

Программно изменить строку тч заказ покупателя перед записью
Я
   letovd
 
07.09.21 - 12:38
Добрый день. Исходя из последовательности выполнения процедур проведения следует, что первой выполняется "Форма. Перед записью."
Перед записью хочу построчно перезаполнять вручную добавленную на форму документа заказ покупателя колонку "вес".
Для этого удобно использовать цикл "Для каждого".
В модуле формы, у процедуры "ПередЗаписью" осуществляется обращение к процедуре общего модуля "ОбработкаТабличныхЧастей.ПриЗаписиПроверитьЕдиницуИзмеренияМест(Товары);"
В данной процедуре представлен следующий код:
    Для каждого СтрокаТабличнойЧасти Из ТабличнаяЧасть Цикл
        Если ЗначениеЗаполнено(СтрокаТабличнойЧасти.ЕдиницаИзмеренияМест)
             И СтрокаТабличнойЧасти.КоличествоМест = 0 Тогда
            СтрокаТабличнойЧасти.ЕдиницаИзмеренияМест = Неопределено;
        КонецЕсли;
    КонецЦикла;
То есть процедура получает ТЧ документа ЗаказПокупателя и обрабатывает его.
Так как процедура общая, то ее трогать не правильно, ибо к ней могу обращаться другие модули программы.
На основе общей процедуры решил дописать модуль формы объекта, а именно процедуру "ПередЗаписью" модуля формы.
Добавил следующую часть:
    Для каждого Элемент Из Товары Цикл
        ВесВКарточке = Элемент.Номенклатура.ЕдиницаХраненияОстатков.Вес;
        Если НЕ (ВесВКарточке = 0) Тогда
        // ЭлементыФормы.Товары.ТекущиеДанные = ВесВКарточке * Элемент.Количество;
        КонецЕсли;
    КонецЦикла;
Вопрос следующий: Как обратиться к добавленной вручную фарму колонке вес? - Тип число, поле ввода, связь по типу ЭлементыФормы.Товары.ТекущиеДанные, Данные: пусто
   ДенисЧ
 
1 - 07.09.21 - 12:41
Колонка в документе есть? Не на форме, а в метаданных документа?
   Naumov
 
2 - 07.09.21 - 12:42
При чем тут текущие данные, если ты перебираешь ВСЕ?
Если вручную добавлено на форму, то не лучше ли и правильнее обрабатывать изменения в этой колонке в момент изменения, чтобы потом повторно не проходить?
   letovd
 
3 - 07.09.21 - 12:43
(1) Спасибо большое, точно!
   letovd
 
4 - 07.09.21 - 12:48
(2) Я написал это просто так. Теперь будет "Элемент.Вес".
Когда добавляют документ копированием, или через сканер штрихкода, строки не всегда редактируют
   DexterMorgan
 
5 - 07.09.21 - 13:29
Красиво запросы в цикле херачишь
   letovd
 
6 - 07.09.21 - 13:52
(5) Предложи вариант лучше, если знаешь

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.